RE: localhost input

Problems with the Windows version of XAMPP, questions, comments, and anything related.

RE: localhost input

Postby TonyMen » 08. April 2015 10:30

When I enter localhost:82/xampp/ I go XAMPP for Windows.

I have switched from Wamp where I only had to enter " localhost "

Now when I enter localhost I get/goto "Internet Information Services"

why is this ?
TonyMen
 
Posts: 9
Joined: 08. April 2015 10:13
Operating System: win 8.1 64 bit

Re: RE: localhost input

Postby Nobbie » 08. April 2015 10:49

Because you have changed Apache Port 80 to Port 82 (i.e. you changed the LISTEN option). Obviously you have a Microsoft IIS Installation running (what is a webserver as well and it usually comes with Ultimate Windows Editions), which already uses Port 80. This is what you get if you enter localhost without providing Port 82.

Exactly therefore it is NOT recommended to change Apache Port from 80 to any other value, instead you should stop (and probably de-install) Microsoft IIS in order to free Port 80 for Apache. Only if you NEED Microsoft IIS as well as Apache, you may change the Ports (but you have to accept the fact that you have to apply Port 82 in the URL), in any other case you should undo the Port change and de-install Microsoft IIS.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: RE: localhost input

Postby TonyMen » 08. April 2015 11:56

I cannot find IIS ?
I have gone to programs and features and IIS is not there, unless under another name
Would it be under MS ASP.NET MVC 4 Runtime ?
TonyMen
 
Posts: 9
Joined: 08. April 2015 10:13
Operating System: win 8.1 64 bit

Re: RE: localhost input

Postby Nobbie » 08. April 2015 13:40

TonyMen wrote:I cannot find IIS ?


IIS = Internet Information Services

I currently have no Windows Installation (i am using Ubuntu), but there *should* be a Windows Service in the Servces which contains any usefull name (containing http or IIS or Internet or similar). If in doubt, ask in a Windows forum.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: RE: localhost input

Postby JJ_Tagy » 08. April 2015 14:33

Start -> Control Panel -> Programs and Features. Then on the left side, look for "Turn Windows features on or off"
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: RE: localhost input

Postby TonyMen » 08. April 2015 16:33

sorry if the post has gone twice..Oops.

I deactivated all IIS but when entering localhost I still go to goto "Internet Information Services".Page.

Where is the function to delete IIS. I was hoping to send a pic of the IIS layout I deactivated so you might check if ok but this forum does not appear to have the "Send a Pic" function.

changed Apache Port from 82 back to 80 and this is what came up in the control panel.
Error: Apache shutdown unexpectedly.
16:31:56 [Apache] This may be due to a blocked port, missing dependencies,
16:31:56 [Apache] improper privileges, a crash, or a shutdown by another method.
16:31:56 [Apache] Press the Logs button to view error logs and check
16:31:56 [Apache] the Windows Event Viewer for more clues
16:31:56 [Apache] If you need more help, copy and post this
16:31:56 [Apache] entire log window on the forums
TonyMen
 
Posts: 9
Joined: 08. April 2015 10:13
Operating System: win 8.1 64 bit

Re: RE: localhost input

Postby JJ_Tagy » 08. April 2015 16:59

Go to the location above and uncheck the IIS block. That will uninstall it just like add/remove programs.

EDIT: Make sure both IIS blocks are unchecked. I just realized you are on Win8.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: RE: localhost input

Postby TonyMen » 09. April 2015 18:54

Still having trouble getting Apache in XAMPP to work. I did get xampp to work by setting the Apache to port 82. But when I installed Joomla it kept looking for localhost and of course localhost is port 80. In win7 I used Wamp and everything worked. Wamp wont install correctly in win8.1 it gives errors presumably its a port problem.

I uninstalled everything and re installed XAMPP And below are the errors I got regarding APACHE.
Problem detected!
18:32:20 [Apache] Port 80 in use by "Unable to open process" with PID 4!
18:32:20 [Apache] Apache WILL NOT start without the configured ports free!
18:32:20 [Apache] You need to uninstall/disable/reconfigure the blocking application
18:32:20 [Apache] or reconfigure Apache and the Control Panel to listen on a different port

18:23:31 [Apache] Apache WILL NOT start without the configured ports free!
18:23:31 [Apache] You need to uninstall/disable/reconfigure the blocking application
18:23:31 [Apache] or reconfigure Apache and the Control Panel to listen on a different port

I need to figure out how to get Apache to work with port80
I run win8.1 64bit

Realy need help on this one.
TonyMen
 
Posts: 9
Joined: 08. April 2015 10:13
Operating System: win 8.1 64 bit

Re: RE: localhost input

Postby TonyMen » 09. April 2015 20:05

I found the the NT Kernel was still listening on port 80
I NOW HAVE APACHE LISTENING ON PORT 80. See how below.

I have found process called "NT Kernel & System" is using port 80. It's a system process . I don't have any IIS or Web Server installed so I was pretty frustrated how to use that Port 80.

After hours of Googeling I found the answer thought it may help others.IE.

Start the World Wide Web Publishing Service.
On the Start menu, point to Settings, click Control Panel, double-click Administrative Tools, and then double-click Component Services.
In the console tree, click Services (Local).
In the details pane, right-click World Wide Web Publishing Service and right click select properties and select disable.Then in the right column click MORE ACTIONS select properties then in "START UP TYPE" SELECT DISABLED.

Now localhost goes straight to http://localhost/xampp/splash.php :D :D :D
TonyMen
 
Posts: 9
Joined: 08. April 2015 10:13
Operating System: win 8.1 64 bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 81 guests