Problem: a website doesn't correct work on a local network

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem: a website doesn't correct work on a local network

Postby tantogata » 23. March 2015 20:04

Hi all!
I built a website based on the latest XAMPP (5.6.3) and wordpress (4.1.1). On local computer my web site works perfect.
But when I tried to look at the website from another computer which connected through network I had some problem.
1. The website comes partially - no photos, no CSS. It looks ugly, lost structure.
2. When I tried to follow a link on the website, the link changed address. Like this: http://192.168.1.128/wp/membership/ changing to: http://localhost/wp/membership/ and of course there is nothing to see on a screen.

What I did (on local computer where is located a website):
1. Changed in a httpd.conf - changed: ServerName localhost:80 to ServerName 192.168.1.128:80 - restarted Apache - no effect.
2. Turned off a Firewall, antivirus - no effect.
3. Created in a router a virtual port to access through a network - no effect.
4. Looked through wordpress files: wp-config.php, wp-settings.php - no info about localhost.
5. Checked a file - hosts - no effect

When I point with a mouse to any link on my website it shows me a localhost address (like: http://localhost/wp/membership/ against: http://192.168.1.128/wp/membership/). I think that is why I'm loosing all pictures and may be the whole structure of the website.

The question:
What configuration file I need to change: localhost to 192.168.1.128?

Thank you.
tantogata
 
Posts: 2
Joined: 23. March 2015 19:23
Operating System: Windows 7 Pro

Re: Problem: a website doesn't correct work on a local netwo

Postby Altrea » 23. March 2015 20:30

Hi,

still a wordpress configuration issue:
https://wordpress.org/support/topic/css ... rk-in-mamp

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Problem: a website doesn't correct work on a local netwo

Postby tantogata » 23. March 2015 20:50

Thanks a lot Altrea!
This is exactly what I need!
After changing general wordpress configuration my website works much better.
But still you need manually change link address for some pictures and sliders.
Thanks again man. Now I know where to look for to fix it.
tantogata
 
Posts: 2
Joined: 23. March 2015 19:23
Operating System: Windows 7 Pro


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests