Xampp suddenly stopped working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp suddenly stopped working

Postby uglyeoin » 11. March 2015 13:29

Hi all,

I was using XAMPP yesterday, happily crafting a website on my local machine. I finished and left the office. At some point my computer rebooted. Upon startup XAMPP suddenly doesn't work.

I've spent hours troubleshooting it, and nothing seems to have worked, although my error messages have changed.

First I had access forbidden, so I managed to get that working.
Then Apache wouldn't start.
Then Apache started and I got object not found.
Finally, I just get unable to connect

I was able to access phpMyAdmin but now I can't, possibly because I cleared cache/cookies. Rather than making more trouble (asI know nothing), I thought I'd post here.

Here is my error log, it doesn't help me, hopefully it helps someone here to help me. Thank you advance to anyone who tries you help me, I really appreciate it.

Code: Select all
[Wed Mar 11 11:31:27.141420 2015] [core:warn] [pid 6616:tid 260] AH00098: pid file Z:/Xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
Apache server shutdown initiated...
sl:warn] [pid 6616:tid 260] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Mar 11 11:31:28.928425 2015] [mpm_winnt:notice] [pid 6616:tid 260] AH00455: Apache/2.4.9 (Win32) OpenSSL/1.0.1g PHP/5.5.11 configured -- resuming normal operations
[Wed Mar 11 11:31:28.928425 2015] [mpm_winnt:notice] [pid 6616:tid 260] AH00456: Apache Lounge VC11 Server built: Mar 16 2014 12:13:13
[Wed Mar 11 11:31:28.928425 2015] [core:notice] [pid 6616:tid 260] AH00094: Command line: 'apache\\bin\\httpd.exe -d Z:/Xampp/apache -f conf\\httpd.conf'
[Wed Mar 11 11:31:28.963427 2015] [mpm_winnt:notice] [pid 6616:tid 260] AH00418: Parent: Created child process 7092
AH00548: NameVirtualHost has no effect and will be removed in the next release Z:/Xampp/apache/conf/extra/httpd-vhosts.conf:20
AH00112: Warning: DocumentRoot [C:/Projects/transitCalculator/trunk] does not exist
[Wed Mar 11 11:31:29.587462 2015] [ssl:warn] [pid 7092:tid 272] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
AH00112: Warning: DocumentRoot [C:/Projects/transitCalculator/trunk] does not exist
[Wed Mar 11 11:31:29.808475 2015] [ssl:warn] [pid 7092:tid 272] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Mar 11 11:31:29.838477 2015] [mpm_winnt:notice] [pid 6616:tid 260] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Wed Mar 11 11:31:29.840477 2015] [mpm_winnt:notice] [pid 7092:tid 272] AH00354: Child: Starting 150 worker threads.
[Wed Mar 11 11:31:29.983485 2015] [mpm_winnt:error] [pid 7092:tid 456] (OS 10038)An operation was attempted on something that is not a socket.  : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?
[Wed Mar 11 11:31:31.983599 2015] [mpm_winnt:notice] [pid 7092:tid 272] AH00364: Child: All worker threads have exited.
[Wed Mar 11 11:31:32.008601 2015] [mpm_winnt:notice] [pid 6616:tid 260] AH00430: Parent: Child process 7092 exited successfully.
[Wed Mar 11 11:32:52.129155 2015] [ssl:warn] [pid 5076:tid 260] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
AH00112: Warning: DocumentRoot [C:/Projects/transitCalculator/trunk] does not exist
[Wed Mar 11 11:32:52.360168 2015] [ssl:warn] [pid 5076:tid 260] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Mar 11 11:32:52.892199 2015] [mpm_winnt:notice] [pid 5076:tid 260] AH00455: Apache/2.4.9 (Win32) OpenSSL/1.0.1g PHP/5.5.11 configured -- resuming normal operations
[Wed Mar 11 11:32:52.892199 2015] [mpm_winnt:notice] [pid 5076:tid 260] AH00456: Apache Lounge VC11 Server built: Mar 16 2014 12:13:13
[Wed Mar 11 11:32:52.892199 2015] [core:notice] [pid 5076:tid 260] AH00094: Command line: 'z:\\xampp\\apache\\bin\\httpd.exe -d Z:/Xampp/apache'
[Wed Mar 11 11:32:52.933201 2015] [mpm_winnt:notice] [pid 5076:tid 260] AH00418: Parent: Created child process 7260
AH00548: NameVirtualHost has no effect and will be removed in the next release Z:/Xampp/apache/conf/extra/httpd-vhosts.conf:20
AH00112: Warning: DocumentRoot [C:/Projects/transitCalculator/trunk] does not exist
[Wed Mar 11 11:32:53.409228 2015] [ssl:warn] [pid 7260:tid 272] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
AH00112: Warning: DocumentRoot [C:/Projects/transitCalculator/trunk] does not exist
[Wed Mar 11 11:32:53.581238 2015] [ssl:warn] [pid 7260:tid 272] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Mar 11 11:32:53.608240 2015] [mpm_winnt:notice] [pid 7260:tid 272] AH00354: Child: Starting 150 worker threads.
uglyeoin
 
Posts: 2
Joined: 05. August 2011 20:47

Re: Xampp suddenly stopped working

Postby gsmith » 12. March 2015 08:16

[Wed Mar 11 11:31:29.983485 2015] [mpm_winnt:error] [pid 7092:tid 456] (OS 10038)An operation was attempted on something that is not a socket. : AH00332: winnt_accept: getsockname error on listening socket, is IPv6 available?

OUCH!

Is this XP or (coughs) earlier?

Is this line in your httpd.conf uncommented?
Listen [::]:80
gsmith
 
Posts: 196
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP version: 0.0.0
Operating System: Win XP to 2012R2/VS 6,9,11,14


Return to XAMPP for Windows

Who is online

Users browsing this forum: DarthSidus and 57 guests