Access forbidden when I run PHP on XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Access forbidden when I run PHP on XAMPP

Postby jperson19468 » 27. February 2015 04:00

:?: To all,
When I try to run a php script on XAMPP
I get the following screen that says:
Access forbidden!
You don't have permission to access the requested object. It is either read-protected or not readable by the server.
If you think this is a server error, please contact the webmaster.
Error 403 localhost

In addition
Under the XAMPP for Windows:
the XAMPP Status says the following:
Some changes to the configuration may sometimes cause false negatives. All reports viewed with SSL (https://localhost) do not function!
This is how I run the script:
http://localhost/C:/xampp/htdocs/miles.php


I have the following setup
Apache/2.4.10 (Win32) OpenSSL/1.0.1i PHP/5.6.3
download xampp for windows version 5.6.3 (php 5.6.3)
My operating system is Windows Vista
I have software called Adblock Plus (blocks ads)
I also have norton 360 ant-virus
When I ping my localhost
I get jerome-PC {127.0.0.1} which matches the information I have in:
C:\Windows\System32\drivers\etc\host
host file reads:
127.0.0.1 localhost
XAMPP control panel screen says
Attempting to start Apache app...
Status change detected: running

Thank You
jperson19468
 
Posts: 2
Joined: 27. February 2015 02:48
Operating System: windows vista

Re: Access forbidden when I run PHP on XAMPP

Postby Nobbie » 27. February 2015 12:26



This is quite nonsense - have you ever seen an URL which includes drive letters?

Simply try http://localhost/miles.php and read some documentation about Apache.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: Access forbidden when I run PHP on XAMPP

Postby jperson19468 » 01. March 2015 03:57

Nobbie, thanks for your help. I was not sure if I was running it the right way. Now I just have to get my netbeans, xdebug and wordpress back working all together. Had a major problem with java and had to do a uninstall and a reinstall. Things started to go weird after that. Once again thanks for your help

Post IS NOW CLOSED :mrgreen:
jperson19468
 
Posts: 2
Joined: 27. February 2015 02:48
Operating System: windows vista


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests