Apache Startup Problem !!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Startup Problem !!

Postby SPJK » 21. February 2015 20:53

Hi,

In my system i was already install the Apache2.4 earlier manually and today i was install the xampp so i face the Apache start up issue, so i was disable the earlier installed Apache2.4 from the System through the Services.msc, and after that i was change the Second Apache configuration file which is install into the Xampp folder(C:\Xampp\apache) inside this folder i was edit the "httpd.conf" file and change the port no from the file ie.

Line 58: Listen 80
Line 220: ServerName localhost:80

i was change the all port no 80 to 81

and i was also edit the another file that is httpd-ssl.conf file ie.

Line 36: Listen 443
Line 81: <VirtualHost _default_:443>
Line 87: ServerName www.example.com:443

here i was change the all port no 443 to 8002.


but still the apache is not start.

when i start the xampp then i got the error ie.

Apache Service detected with wrong path
Change XAMPP Apache and Control Panel settings or
Uninstall/disable the other service manually first
Found Path: "C:\Servers\Apache\bin\httpd.exe" -k runservice
Expected Path: "c:\xampp\apache\bin\httpd.exe" -k runservice


and when i click once again click on Apache start button then i got the error ie

Attempting to start Apache service...

so, anyone have the good idea about how to resolve this problem then please help me, i am waiting for good response and please don't tell me to uninstall the earlier Apache.
SPJK
 
Posts: 1
Joined: 21. February 2015 20:25
Operating System: Windows Seven

Re: Apache Startup Problem !!

Postby Nobbie » 21. February 2015 21:11

SPJK wrote:so, anyone have the good idea about how to resolve this problem then please help me, i am waiting for good response and please don't tell me to uninstall the earlier Apache.


" please don't tell me to uninstall the earlier Apache."

Ok, then wait until end of all times, you cannot run two Windows Services with one name and different paths. Running two Apaches is useless anyway, but as will you not delete one: there is no solution.
Nobbie
 
Posts: 8762
Joined: 09. March 2008 13:04

Re: Apache Startup Problem !!

Postby Altrea » 21. February 2015 22:14

Change the expected Service Name (and new ports too) in your Xampp control panel configuration
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests