localhost and phpmyadmin failed to connect

Problems with the Windows version of XAMPP, questions, comments, and anything related.

localhost and phpmyadmin failed to connect

Postby Igor1947 » 21. February 2015 09:00

First of all I'm sorry for my english

I've got a problem with Xampp on my laptop on Windows 7 x64
I had read a lot of topic's on forums and I have tried every way to fix my problem
I have tried change a ports from 80 to 8081 etc.., remove "#" before 127.0.0.1 in hosts from Windows/system32/drivers/etc/hosts and etc...
After running Xampp control panel as administrator I clic start Apache and Mysql
MySql is running immediately but apache after approximately even 10 min
That's a content from Apache error.log
[Sat Feb 21 08:57:55.820454 2015] [ssl:warn] [pid 5916:tid 568] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Feb 21 08:57:56.694055 2015] [core:warn] [pid 5916:tid 568] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Feb 21 08:57:57.271256 2015] [ssl:warn] [pid 5916:tid 568] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Feb 21 08:57:57.598857 2015] [mpm_winnt:notice] [pid 5916:tid 568] AH00455: Apache/2.4.10 (Win32) OpenSSL/1.0.1i PHP/5.6.3 configured -- resuming normal operations
[Sat Feb 21 08:57:57.598857 2015] [mpm_winnt:notice] [pid 5916:tid 568] AH00456: Apache Lounge VC11 Server built: Jul 17 2014 11:50:08
[Sat Feb 21 08:57:57.598857 2015] [core:notice] [pid 5916:tid 568] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sat Feb 21 08:57:57.614457 2015] [mpm_winnt:notice] [pid 5916:tid 568] AH00418: Parent: Created child process 5872
[Sat Feb 21 08:57:59.736060 2015] [ssl:warn] [pid 5872:tid 580] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Feb 21 08:58:00.438062 2015] [ssl:warn] [pid 5872:tid 580] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Feb 21 08:58:00.531662 2015] [mpm_winnt:notice] [pid 5872:tid 580] AH00354: Child: Starting 150 worker threads.

That's a content from Mysql error.log

2015-02-21 08:45:54 5324 [Note] Plugin 'FEDERATED' is disabled.
2015-02-21 08:45:54 1704 InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2015-02-21 08:45:54 5324 [Note] InnoDB: Using atomics to ref count buffer pool pages
2015-02-21 08:45:54 5324 [Note] InnoDB: The InnoDB memory heap is disabled
2015-02-21 08:45:54 5324 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2015-02-21 08:45:54 5324 [Note] InnoDB: Memory barrier is not used
2015-02-21 08:45:54 5324 [Note] InnoDB: Compressed tables use zlib 1.2.3
2015-02-21 08:45:54 5324 [Note] InnoDB: Not using CPU crc32 instructions
2015-02-21 08:45:54 5324 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2015-02-21 08:45:54 5324 [Note] InnoDB: Completed initialization of buffer pool
2015-02-21 08:45:54 5324 [Note] InnoDB: Highest supported file format is Barracuda.
2015-02-21 08:45:54 5324 [Note] InnoDB: The log sequence numbers 0 and 0 in ibdata files do not match the log sequence number 1600724 in the ib_logfiles!
2015-02-21 08:45:54 5324 [Note] InnoDB: Database was not shutdown normally!
2015-02-21 08:45:54 5324 [Note] InnoDB: Starting crash recovery.
2015-02-21 08:45:54 5324 [Note] InnoDB: Reading tablespace information from the .ibd files...
2015-02-21 08:45:54 5324 [Note] InnoDB: Restoring possible half-written data pages
2015-02-21 08:45:54 5324 [Note] InnoDB: from the doublewrite buffer...
2015-02-21 08:45:55 5324 [Note] InnoDB: 128 rollback segment(s) are active.
2015-02-21 08:45:55 5324 [Note] InnoDB: Waiting for purge to start
2015-02-21 08:45:55 5324 [Note] InnoDB: 5.6.21 started; log sequence number 1600724
2015-02-21 08:45:55 5324 [Note] Server hostname (bind-address): '*'; port: 3306
2015-02-21 08:45:55 5324 [Note] IPv6 is available.
2015-02-21 08:45:55 5324 [Note] - '::' resolves to '::';
2015-02-21 08:45:55 5324 [Note] Server socket created on IP: '::'.
2015-02-21 08:48:55 5324 [Warning] InnoDB: Cannot open table mysql/slave_master_info from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
2015-02-21 08:48:55 5324 [Warning] Info table is not ready to be used. Table 'mysql.slave_master_info' cannot be opened.
2015-02-21 08:48:55 5324 [Warning] InnoDB: Cannot open table mysql/slave_worker_info from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
2015-02-21 08:48:55 5324 [Warning] InnoDB: Cannot open table mysql/slave_relay_log_info from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
2015-02-21 08:48:55 5324 [Warning] Info table is not ready to be used. Table 'mysql.slave_relay_log_info' cannot be opened.
2015-02-21 08:48:55 5324 [Note] Event Scheduler: Loaded 0 events
2015-02-21 08:48:55 5324 [Note] c:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '5.6.21' socket: '' port: 3306 MySQL Community Server (GPL)

When Apache and Mysql is already running , I try to enter localhost in my browser, but I get the message that: "Failed to connect " and when I press the "Admin " in the Xampp control panel, information in the browser is the same. What should I do. I'm not young but I want to learn something. Thanks in advance for any help
Igor1947
 
Posts: 4
Joined: 21. February 2015 08:06
Operating System: Windows 7 x64

Re: localhost and phpmyadmin failed to connect

Postby Nobbie » 21. February 2015 12:00

Igor1947 wrote:I have tried change a ports from 80 to 8081 etc..


Why? You should not change the Apache Port, it is better to find the reason if Port 80 is in use.

Anyway, IF you changed 80 to 8081, you MUST apply http://localhost:8081 in order to reach your Apache.
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: localhost and phpmyadmin failed to connect

Postby Igor1947 » 21. February 2015 12:15

Thank you for attention and answer


I changed because I thought it would work, but unfortunately . I tried to log in this way, but I got the same message from the browser : "Failed to connect". I tried to turn off antivirus (Avast), firewall (Comodo) but nothing helps. I removed Skype. I do not know how to solve this problem

I have return to default settings
Igor1947
 
Posts: 4
Joined: 21. February 2015 08:06
Operating System: Windows 7 x64

Re: localhost and phpmyadmin failed to connect

Postby Nobbie » 21. February 2015 13:06

Maybe you should try http://127.0.0.1 instead.
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: localhost and phpmyadmin failed to connect

Postby Igor1947 » 21. February 2015 13:54

I tried
Igor1947
 
Posts: 4
Joined: 21. February 2015 08:06
Operating System: Windows 7 x64

Re: localhost and phpmyadmin failed to connect

Postby Nobbie » 21. February 2015 14:14

If it does not work, you have serious problems with your Windows Installation, maybe there is a Virus or something similar. I have no idea, why Apache does not respond (and i cannot remember a similar case).
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: localhost and phpmyadmin failed to connect

Postby Igor1947 » 21. February 2015 16:13

ok
Thank you for time and help
I will reinstall Windows
Igor1947
 
Posts: 4
Joined: 21. February 2015 08:06
Operating System: Windows 7 x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests