Error and Warning while uncommand extension=php_oci8_11g.dll

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error and Warning while uncommand extension=php_oci8_11g.dll

Postby Xplosio » 18. February 2015 12:03

Hello everyone,

I have a huge problem. I couldn't solve it alone and I didn't find anything like this in the internet, either.

I downloaded the instantclient_11_2 and put it in the C:\xampp_new\php directory. Also I uncommand the line "extension=php_oci8_11g.dll" in the php.ini. Further more I had an older version of XAMPP so i took the "php_oci8.dll" and "php_oci8_11g.dll" from there and put it in the directory C:\xampp_new\php\ext.

My problem is, that when I uncommand the line "extension=php_oci8_11g.dll" and start apache an error windows pops up, which says: "The procedure entry point php_checkuid could not be located in dynamic link library php5ts.dll.". After pressing the "OK" button, another Warning window pops up which say: "PHP Startup: Unable to load dynamic library 'C.\xampp_new\php\ext\php_oci8_11g.dll' ' - The specified procedure could not be found.

Can someone please explain me, how to setup all things right, because when I command the line "extension=php_oci8_11g.dll" no error occured, but I needed because I have to make a databaseconnection.

Thank you and sorry for my english. If you have any question please ask me, to solve the problem together. :)
Xplosio
 
Posts: 2
Joined: 18. February 2015 10:08
Operating System: Windows 7

Re: Error and Warning while uncommand extension=php_oci8_11g

Postby tburba » 21. February 2015 20:39

Xplosio wrote:I had an older version of XAMPP so i took the "php_oci8.dll" and "php_oci8_11g.dll" from there and put it in the directory C:\xampp_new\php\ext.

You can't do that. php_checkuid is a part of PHP's Safe Mode, and the latter was removed in 5.4. Some extensions built for earlier PHP versions might need this function and can't therefore be loaded. This is triggered very early so you aren't getting the usual error message from PHP that php_oci8 module can't be initialized due to API version mismatch.

Don't you have the same files bundled with your newer XAMPP?
tburba
 
Posts: 2
Joined: 21. February 2013 22:48
Operating System: XP and up


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 67 guests