Teapot error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Teapot error

Postby bigjoe11a » 11. February 2015 12:54

I added 2 virtual hosts from a video I watch on youtube. I completed the video and I got an error I never had before. Some thing about a teapot. Sense I have no idea what this is. The error is below, I pasted the error log if any one needs it. It just seems to relate to one of the virtual hosts I made. "robert" I made 2, One called "joe" and the other "robert".

Code: Select all
 [client 127.0.0.1:1938] C:/xampp/htdocs/robert/.htaccess: Unsupported HTTP response code 418
[Tue Feb 10 10:55:52.690293 2015] [core:alert] [pid 6648:tid 1636] [client 127.0.0.1:1939] C:/xampp/htdocs/robert/.htaccess: Unsupported HTTP response code 418
[Tue Feb 10 10:55:52.690293 2015] [core:alert] [pid 6648:tid 1628] [client 127.0.0.1:1940] C:/xampp/htdocs/robert/.htaccess: Unsupported HTTP response code 418
[Wed Feb 11 05:46:43.086623 2015] [ssl:warn] [pid 6976:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Feb 11 05:46:44.364696 2015] [core:warn] [pid 6976:tid 256] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Wed Feb 11 05:46:44.555707 2015] [ssl:warn] [pid 6976:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Feb 11 05:46:48.765948 2015] [mpm_winnt:notice] [pid 6976:tid 256] AH00455: Apache/2.4.10 (Win32) OpenSSL/1.0.1i PHP/5.5.19 configured -- resuming normal operations
[Wed Feb 11 05:46:48.765948 2015] [mpm_winnt:notice] [pid 6976:tid 256] AH00456: Apache Lounge VC11 Server built: Jul 17 2014 11:50:08
[Wed Feb 11 05:46:48.765948 2015] [core:notice] [pid 6976:tid 256] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Wed Feb 11 05:46:48.782949 2015] [mpm_winnt:notice] [pid 6976:tid 256] AH00418: Parent: Created child process 5208
[Wed Feb 11 05:46:49.576994 2015] [ssl:warn] [pid 5208:tid 268] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Feb 11 05:46:49.929014 2015] [ssl:warn] [pid 5208:tid 268] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Feb 11 05:46:49.996018 2015] [mpm_winnt:notice] [pid 5208:tid 268] AH00354: Child: Starting 150 worker threads.
[Wed Feb 11 05:46:50.111025 2015] [core:alert] [pid 5208:tid 1604] [client 127.0.0.1:2779] C:/xampp/htdocs/robert/.htaccess: Unsupported HTTP response code 418
[Wed Feb 11 05:46:50.448044 2015] [core:alert] [pid 5208:tid 1604] [client 127.0.0.1:2780] C:/xampp/htdocs/robert/.htaccess: Unsupported HTTP response code 418
[Wed Feb 11 05:46:50.454044 2015] [core:alert] [pid 5208:tid 1688] [client 127.0.0.1:2781] C:/xampp/htdocs/robert/.htaccess: Unsupported HTTP response code 418
[Wed Feb 11 05:47:53.969677 2015] [core:alert] [pid 5208:tid 1688] [client 127.0.0.1:2795] C:/xampp/htdocs/robert/.htaccess: Unsupported HTTP response code 418
[Wed Feb 11 05:47:54.067683 2015] [core:alert] [pid 5208:tid 1688] [client 127.0.0.1:2796] C:/xampp/htdocs/robert/.htaccess: Unsupported HTTP response code 418
[Wed Feb 11 05:47:54.105685 2015] [core:alert] [pid 5208:tid 1688] [client 127.0.0.1:2797] C:/xampp/htdocs/robert/.htaccess: Unsupported HTTP response code 418
[Wed Feb 11 05:54:17.101591 2015] [core:alert] [pid 5208:tid 1688] [client 182.254.220.59:34858] C:/xampp/htdocs/robert/.htaccess: Unsupported HTTP response code 418
bigjoe11a
 
Posts: 3
Joined: 08. November 2014 13:50
Operating System: Windows 7

Re: Teapot error

Postby Nobbie » 11. February 2015 17:15

I cannot see anything about a "teapot", you must be dreaming.

You have an invalid .htaccess file in your folder "robert" which causes (or sets) an unknown HTTP error code (418). That is your .htaccess file and only you know, what the contents is.

P:S.: Looks as if someone is playing some jokes (either yourself or you copied something "funny" on your disk), the "teapot" message is a 1. April Joke and is issued by some browsers if they recognize the invalid URL "coffee://....". I think youre .htaccess is kind of a joke.

See http://en.wikipedia.org/wiki/Hyper_Text ... l_Protocol
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: Teapot error

Postby bigjoe11a » 11. February 2015 19:26

Thanks. I removed that file and I'm still getting the same error. So this has me so lost. The web sites is not mine. It's some one's web site I'm added a mysql crap to it. and well I never had this error before. So I deleted the file. Why as I still getting the same error.
bigjoe11a
 
Posts: 3
Joined: 08. November 2014 13:50
Operating System: Windows 7

Re: Teapot error

Postby Nobbie » 11. February 2015 22:18

bigjoe11a wrote:Thanks. I removed that file and I'm still getting the same error. So this has me so lost. The web sites is not mine. It's some one's web site I'm added a mysql crap to it. and well I never had this error before. So I deleted the file. Why as I still getting the same error.


I dont know. Ask the guy whos site it is.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests