Apache stops responding to requests

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache stops responding to requests

Postby FalseTetrabyte » 23. January 2015 18:35

I've tried searching for this particular problem, but everything I've come up with doesn't exactly match this particular issue.

We have uptimerobot checking our sites for us, but on two sites that we use will report that the site is not working every now and then. It's completely random, and other than Apache not responding to requests, the system itself is running fine.

Both systems in this case are Server 2012 R2 VMs, and CPU/RAM utilization is a non issue. (<5% CPU, RAM is around 1.3 GB in use out of 4GB allocated)

If I bounce the Apache service either via Services snapin or the XAMPP control panel, everything works fine again.

The logs don't show much, but maybe if I had a better understanding of what I needed to look for... I could be more useful in that regard.
FalseTetrabyte
 
Posts: 3
Joined: 23. January 2015 18:29
Operating System: Server 2012 R2

Re: Apache stops responding to requests

Postby gsmith » 23. January 2015 20:46

viewtopic.php?f=16&t=70116 ?
sounds like it to me.
gsmith
 
Posts: 194
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP version: 0.0.0
Operating System: Win XP to 2012R2/VS 6,9,11,14

Re: Apache stops responding to requests

Postby FalseTetrabyte » 23. January 2015 21:57

Nope. Does not apply. No such error in the log.
FalseTetrabyte
 
Posts: 3
Joined: 23. January 2015 18:29
Operating System: Server 2012 R2

Re: Apache stops responding to requests

Postby FalseTetrabyte » 23. January 2015 23:09

OK - deleted the log and allowed Apache to recreate it - something felt off and I was correct. The log repopulated and sure enough, there's the lines. I just edited the httpd.conf file and will see how that does. Thanks for the reference.
FalseTetrabyte
 
Posts: 3
Joined: 23. January 2015 18:29
Operating System: Server 2012 R2


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests