Updating xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Updating xampp

Postby townsbg » 21. January 2015 07:43

I have xampp 1.7.3 installed on an old windows 2003 test server that I use for forums. I want to install a test forum for phpbb 3.1 however my php version is too old. Somehow I need to either upgrade php on the existing install or create a new install of xampp and import the old data. I have tried both with no success. My most recent attempt was an install of xampp 1.8.2-6 but I actually corrupted mysql trying to add the databases from the old install and had to revert to the "backup" folder. My attempts at updating php on the 1.7 install either resulted in apache not starting or weren't recognized by the phpbb installer. I tried following some of the php upgrade steps here: http://stackoverflow.com/questions/2154762/upgrading-php-in-xampp-for-windows Any assistance you can provide would be appreciated.
townsbg
 
Posts: 8
Joined: 21. January 2015 07:26
Operating System: WIndows 2003

Re: Updating xampp

Postby Nobbie » 21. January 2015 13:02

townsbg wrote:and import the old data.


We need a more precisely description of what you tried there.
Nobbie
 
Posts: 8758
Joined: 09. March 2008 13:04

Re: Updating xampp

Postby Altrea » 21. January 2015 17:07

townsbg wrote:My attempts at updating php on the 1.7 install either resulted in apache not starting or weren't recognized by the phpbb installer.

For good reasons updating any of the single components is not supported with XAMPP.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Updating xampp

Postby townsbg » 21. January 2015 18:02

Nobbie wrote:
townsbg wrote:and import the old data.


We need a more precisely description of what you tried there.


1) Adding the php files as a new folder and editing the xampp config file under apache/conf/extra to point to the new location.
download your desired version of php binary from http://windows.php.net/download/ website. download Thread Safe binary zip version. Unzip the downloaded version of the PHP in a separate folder. Please make sure that your new php folder name is not "PHP". May be you can use filder name as the version name. For example for php 5.4 you can use php54.

Copy the new php folder into your xampp folder. Now go to yourxampp/apache/conf/extra folder. Open file httpd-xampp.conf from the folder extra. Change the following variables:

Variable PHPINIDir to be / Varaible LoadModule to be //php5apache2_2.dl

Save the file httpd-xampp.conf. Restart your XAMPP apache server. If your server get restarted successfully then your server php version is upgraded.


Result apache started but the update wasn't recognized by the installer.
2) Updating the php files as shown below.
Download the latest binary version of PHP (make sure to get the .zip package not the installer)
De-archive it to a directory
Overwrite the contents of directory in the php subfolder of your XAMPP installation directory.
Overwrite the contents of the directory apache\bin with the newer versions.
Now the trick: take the files which have a '_2' in their names (for example php5apache2_2.dll or php5apache2_2_filter.dll), copy them in the apache\bin subdirectory and remove the '_2' part, overwriting the existing files. This is necessary because by XAMPP uses Apache version 2.2 and the files with the 2 prefix are built for Apache 2.0, so you must take the files build for the newer version (which has a different plugin interface) and rename them in the filenames XAMPP expects.

NOTE: there are two directories to be updated with new version of files, namely php sub-directory and apache/bin sub-directory, inside XAMPP installation.

Result apache would not start.

3) Installing a new version and adding the database files from mysql/data.
Result errors when trying to load mysql admin page. mysql wouldn't funtion even after removing the files so I had to resort to the backup directory.

Altrea wrote:
townsbg wrote:My attempts at updating php on the 1.7 install either resulted in apache not starting or weren't recognized by the phpbb installer.

For good reasons updating any of the single components is not supported with XAMPP.

That really helps a lot. What am I suppose to do? :?
townsbg
 
Posts: 8
Joined: 21. January 2015 07:26
Operating System: WIndows 2003

Re: Updating xampp

Postby Altrea » 21. January 2015 21:48

Altrea wrote:That really helps a lot. What am I suppose to do? :?

My recommendation for such an environment would be to create a second XAMPP environment next to your existing one and move one application after another to the new environment;

Important notes:
  • Do backups all the time so that you can recreate your successfully running environment if something strange happens.
  • only move the applications and databases you have installed yourself, never ever do this with already existing databases like mysql or phpmyadmin.
Extract an XAMPP version next to he existing one (e.g. if C:\xampp\ is your existing one, use the zip version of XAMPP 1.8.2-6 and extract them to C:\xampp1826\).
Then execute C:\xampp1826\setup_xampp.bat to remap the needed paths of the configuration files.
After that make a clean database dump of the database(s) you want to move to the new xampp version (my favorite tool for this is mysqldump, a command line interface which comes with every MySQL).
Stop your old XAMPP, and reimport the dump (in the command line too) to the new MySQL version.
(the commands to dump and import a database in the commandline can be found here as example: viewtopic.php?f=16&t=56104&p=220404&hilit=mysqldump#p220404)
If you have created custom database users for your webapplications recreate them in the new MySQL too.
If this all can be done without any errors, copy the static files from htdocs you want to move to the new XAMPP htdocs.
Maybe at the end you need to change some parameters in your webapplications to fit the new environment.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Updating xampp

Postby townsbg » 23. January 2015 04:04

I was able to export the databases using the admin console and then import them and except for a strange error on the admin page the forum seems to be working. I haven't tried everything though. The bad news is that once I changed the mysql root password I couldn't perform any other actions and now I can no longer log in to the mysql admin console. The installer for the phpbb3.1 does recognize the new version but I haven't yet attempted install since I don't have an account for it yet. :? Here is the error message that I am receiving from mysql.

phpMyAdmin - Error

Error during session start; please check your PHP and/or webserver log file and configure your PHP installation properly. Also ensure that cookies are enabled in your browser.
townsbg
 
Posts: 8
Joined: 21. January 2015 07:26
Operating System: WIndows 2003

Re: Updating xampp

Postby Altrea » 23. January 2015 09:01

clear your browser cache
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Updating xampp

Postby townsbg » 25. January 2015 06:36

I've tried clearing the cache and I still can't log in. I'm not even getting the log in screen. I only get this.

Welcome to phpMyAdmin

Error

MySQL said: Documentation
#1045 - Access denied for user 'root'@'localhost' (using password: NO)
phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.


Beneath those messages there is a button that says retry to connect but that doesn't help. I still get that message.
townsbg
 
Posts: 8
Joined: 21. January 2015 07:26
Operating System: WIndows 2003

Re: Updating xampp

Postby Altrea » 25. January 2015 12:46

You need to tell phpMyAdmin the new password too, or at least change the auth method so that you get the login form.

  • open your \xampp\phpmyadmin\config.inc.php
  • search for the line
    Code: Select all
    $cfg['Servers'][$i]['auth_type'] = 'config';
  • change it to the following
    Code: Select all
    $cfg['Servers'][$i]['auth_type'] = 'cookie';
  • save the file
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Updating xampp

Postby townsbg » 28. January 2015 17:44

I didn't have to do that with the old version. That worked however I am getting timeouts. I think that I have a token problem because when I remove that part of the url it loads. The phpbb forum installed and is working perfectly however I have strange error message pertaining php files on my mybb board that I wasn't getting on the old version. The console is working though as far as I can tell.
townsbg
 
Posts: 8
Joined: 21. January 2015 07:26
Operating System: WIndows 2003

Re: Updating xampp

Postby townsbg » 29. January 2015 06:26

I am experiencing a lot of errors on my old phpbb forum in the admin console. They look like php errors.
townsbg
 
Posts: 8
Joined: 21. January 2015 07:26
Operating System: WIndows 2003

Re: Updating xampp

Postby townsbg » 01. February 2015 17:57

Do you have any ideas? I wasn't getting these errors on the old version.
townsbg
 
Posts: 8
Joined: 21. January 2015 07:26
Operating System: WIndows 2003

Re: Updating xampp

Postby Nobbie » 01. February 2015 21:42

As long as you do not provide any of these errors (full description!), as long you wont get any help. Error messages are not meant for "decoration" or similar, they are meant for help in order to find the error reason.
Nobbie
 
Posts: 8758
Joined: 09. March 2008 13:04

Re: Updating xampp

Postby townsbg » 02. February 2015 03:59

Nobbie wrote:As long as you do not provide any of these errors (full description!), as long you wont get any help. Error messages are not meant for "decoration" or similar, they are meant for help in order to find the error reason.


Fair enough. At the top of the page there is the line
Code: Select all
Warning [2] Creating default object from empty value - Line: 311 - File: C:\xampp\htdocs\mybb\admin\index.php PHP 5.4.31 (WINNT)


Then there is this in a text box.
Code: Select all
File    Line    Function
C:\xampp\htdocs\mybb\admin\index.php    311    errorHandler->error


Beneath where it says Dashboard there is this box.
Code: Select all
Warning [2] Illegal string offset 'flash_message' - Line: 134 - File: C:\xampp\htdocs\mybb\admin\inc\class_page.php PHP 5.4.31 (WINNT)
File    Line    Function
C:\xampp\htdocs\mybb\admin\inc\class_page.php    134    errorHandler->error
C:\xampp\htdocs\mybb\admin\modules\home\index.php    40    DefaultPage->output_header
C:\xampp\htdocs\mybb\admin\index.php    483    require
townsbg
 
Posts: 8
Joined: 21. January 2015 07:26
Operating System: WIndows 2003

Re: Updating xampp

Postby Nobbie » 02. February 2015 16:00

You should move to a MyBB Forum and show the error messages there. We cannot give MyBB support here. I am pretty sure, these errors may be known (due to newer PHP version or similar), but anyway, these are MyBB Errors.
Nobbie
 
Posts: 8758
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 42 guests