CGI Perl not connecting to MySQL on XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

CGI Perl not connecting to MySQL on XAMPP

Postby AndyJ » 30. December 2014 22:37

Hi everyone, I have tried various connection scripts and none will allow connection with MySQL. The script returns a blank browser page. The error log is displayed below. You may laugh but I have spent two days on this without success and would really appreciate some advice. I have tried adding libmysql_.dll file from Strawberry Perl download to xampp\perl\vendor\lib\auto\DBD\mysql\libmysql_.dll but without success.

[Tue Dec 30 21:20:11.564264 2014] [cgi:error] [pid 4492:tid 1616] [client ::1:50585] AH01215: install_driver(mysql) failed: Can't load 'C:/xampp/perl/vendor/lib/auto/DBD/mysql/mysql.dll' for module DBD::mysql: load_file:%1 is not a valid Win32 application at C:/xampp/perl/lib/DynaLoader.pm line 190.\r
[Tue Dec 30 21:20:11.564264 2014] [cgi:error] [pid 4492:tid 1616] [client ::1:50585] AH01215: at (eval 4) line 3.\r
[Tue Dec 30 21:20:11.564264 2014] [cgi:error] [pid 4492:tid 1616] [client ::1:50585] AH01215: Compilation failed in require at (eval 4) line 3.\r
[Tue Dec 30 21:20:11.564264 2014] [cgi:error] [pid 4492:tid 1616] [client ::1:50585] AH01215: Perhaps a required shared library or dll isn't installed where expected\r
[Tue Dec 30 21:20:11.564264 2014] [cgi:error] [pid 4492:tid 1616] [client ::1:50585] AH01215: at C:/xampp/cgi-bin/recipe2.pl line 17.\r

I appreciate any advice you can give.

Many thanks
Andy
AndyJ
 
Posts: 1
Joined: 30. December 2014 21:22
Operating System: Windows 7 Pro SP1 64-bit

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests