Apache Not Working In Xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Not Working In Xampp

Postby TimeToLearn » 20. December 2014 05:09

Hey there :)

MYSQL and FileZilla run just fine but I am having issues getting Apache to run on Xampp.
I changed the ports on both the httpd.conf and httpd-ssl.conf through the Config button on Xampp and got an error message of Port 80.
I went ahead and also changed the path through the C:\Apache24 folder but to a different port than the one I entered in Xampp and it didn't show me the error message anymore.

I then restarted Xampp and got this message in red
10:50:11 PM [Apache] Apache Service detected with wrong path
10:50:11 PM [Apache] Change XAMPP Apache and Control Panel settings or
10:50:11 PM [Apache] Uninstall/disable the other service manually first
10:50:11 PM [Apache] Found Path: "C:\Apache24\bin\httpd.exe" -k runservice
10:50:11 PM [Apache] Expected Path: "c:\xampp\apache\bin\httpd.exe" -k runservice

But then when I click Start it shows me
11:03:08 PM [Apache] Attempting to start Apache service...

and a window opens asking permission with details
Provider: Net Command
Verified Publisher: Microsoft Windows

*I had installed Apache BEFORE I installed Xampp*

Any suggestions?
Posts: 1
Joined: 20. December 2014 04:54
Operating System: Windows 8

Re: Apache Not Working In Xampp

Postby gsmith » 20. December 2014 19:55

Uninstall the old service and install a new one.

from a command prompt running as Administrator

httpd -k stop
httpd -k uninstall
httpd -k install
httpd -k start
Posts: 193
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP version: 0.0.0
Operating System: Win XP to 2012R2/VS 6,9,11,14

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 65 guests