XAMPP & fsockopen

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP & fsockopen

Postby swt4ajp » 05. December 2014 09:00

Hey everyone!

I have just migrated from IIS7 to XAMPP and am facing an issue where I am told that fsockopen is not enabled
https://www.phpbb.com/community/viewtopic.php?f=466&t=2280361#p13840416

I have gone through everything online and it is still not working
I am using the latest version of XAMPP on w2k8r2
http://gamesunited.eu/test.php

btw I am very confident in making changes, but I am still fairly a newbie when it comes to web design and coding :oops:

Please help!
swt4ajp
 
Posts: 3
Joined: 05. December 2014 08:53
Operating System: Windows Server 2008 r2

Re: XAMPP & fsockopen

Postby Altrea » 05. December 2014 09:37

Hi swt4ajp,

swt4ajp wrote:and am facing an issue where I am told that fsockopen is not enabled

I don't see any hint that fsockopen is not enabled on your system.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: XAMPP & fsockopen

Postby Nobbie » 05. December 2014 17:14

You are running your Server within CloudFlare, i dont know how this is working, but it kind of protects your site and i think, that is the reason for the blocking of outgoing port.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: XAMPP & fsockopen

Postby swt4ajp » 10. December 2014 13:14

Altrea wrote:Hi swt4ajp,

swt4ajp wrote:and am facing an issue where I am told that fsockopen is not enabled

I don't see any hint that fsockopen is not enabled on your system.

best wishes,
Altrea


I have been playing around with the config files trying to get it to work.
One thing that I have managed to do was setup a test page that calls another site and if available it returned http://gamesunited.eu/test.php/

Code: Select all
Warning: fsockopen(): unable to connect to www.google.com:80 (A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. ) in J:\GamesUnited\test.php on line 4
A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. (10060)


I am only following this route as the guys over on the phpbb boards said that because of the update error I am recieving is due to fsockopen not being open :S
https://www.phpbb.com/community/viewtopic.php?f=466&t=2280361
Code: Select all
Failed to obtain latest version information.

A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

Re-Check version · More information »

This is the only thing that I have been given to go on and have received no further help. This has only happened since I switched from IIS7 to Xampp for the PhpbbSEO extention to get it to work :( so really for one thing to work i have broke something else lol just my luck :(
And also I switched routers recently but that I think I might of forgotton some of the previous settings that I setup and I dont think that I have configured it correctly :(
but these 3 things are literally the only things that I can go off :(
swt4ajp
 
Posts: 3
Joined: 05. December 2014 08:53
Operating System: Windows Server 2008 r2

Re: XAMPP & fsockopen

Postby swt4ajp » 10. December 2014 13:18

Nobbie wrote:You are running your Server within CloudFlare, i dont know how this is working, but it kind of protects your site and i think, that is the reason for the blocking of outgoing port.



Hi nobbie,

I will be able to go out on a limb and say that it isnt due to the switch to move behind cloudflare as this happened before I switched over to cloudflare.

How the setup is:
My server (home) serving the website - Cloudflare (dns provider for Ns records) - client machine (end user)
so pretty much cloudflare is just a ns server for me to use. and it gives me a more detailed analystics of page view, unique visitors blardy blar blar :p
I have got the settings all down low as not to disrupt anything else from working :)

I have also noticed that recently my blog http://blog.gamesunited.eu has started with script execution time out errors as well now :(

This could either be really fun for some people and really annoying for others lol!
swt4ajp
 
Posts: 3
Joined: 05. December 2014 08:53
Operating System: Windows Server 2008 r2


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests