Xampp works--but Is this normal?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp works--but Is this normal?

Postby bobbybob » 17. November 2014 02:59

I installed xampp on my home computer running winxp. Then I copied all the backup PHPBB files from my online forum into the htdocs/phpbb folder. It opens the forum on my computer and looks great (pics don't quite display properly)

BUT here's the weird part: it runs in 'real time', showing any new posts from online, just as if I WAS online---basically a mirror of the online site---and I can post to it and it will show up online too--but any changes I make in the ACP don't affect the online version. If I shut off my internet connection, it stops running.

Is this the way XAMPP is supposed to work? I wanted to load the backup database onto my home computer and run it completely separately from the online version. What do I need to do? Sorry, I'm sure this is a dumb question for you gurus but I have just enough knowledge to be dangerous. :D
Bob
bobbybob
 
Posts: 4
Joined: 17. November 2014 02:49
Operating System: winxp

Re: Xampp works--but Is this normal?

Postby bobbybob » 19. November 2014 03:02

So, no one here is using xampp I suppose, since no one can tell me if this is normal. :roll:
bobbybob
 
Posts: 4
Joined: 17. November 2014 02:49
Operating System: winxp

Re: Xampp works--but Is this normal?

Postby giaza » 19. November 2014 06:11

Xammp has nothing to do with this behavior.
When you move a dynamic php app like phpbb to your local computer, its configuration needs to be changed as well.
Surely our local Phpbb local installation points to your online database (strange it can access from your local pc) so each post you add or edit are shown in the online version.
giaza
 
Posts: 1
Joined: 19. November 2014 06:01
Operating System: Windows

Re: Xampp works--but Is this normal?

Postby bobbybob » 19. November 2014 13:12

Thanks for that. I guess it's a question for the phpbb forum but while I'm here can anyone tell me how to reconfigure it so I can use a local database? I have the sql backup db. Thanks!
bobbybob
 
Posts: 4
Joined: 17. November 2014 02:49
Operating System: winxp

Re: Xampp works--but Is this normal?

Postby Nobbie » 19. November 2014 20:42

bobbybob wrote: I guess it's a question for the phpbb forum but


Exactly. You may be (very) lucky if someone can help you here, but you dont need any luck for usefull help in a PHPBB forum...
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests