Self hosting, problem with html <head> tag

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Self hosting, problem with html <head> tag

Postby Zeedjoy » 14. November 2014 14:49

Hi eveybody,

I'm trying to host a wordpress site by myself on my PC with xampp 1.8.3 on windows 7.
I followed this french guide : http://web.developpez.com/cours/serveur-web-chez-soi/#LVIII-A
After setting up xampp according to the guide, I can find my site by typing http://my_rooter_ip/wordpress in a browser (from the hosting PC and also from another PC).
From the hosting PC, no problem, everything is OK.
But from another PC, CSS doesn't work.

When I try "inspect element" with Firebug, the html <head> tag seems to be grey tinted as if it was not interpreted, that's why CSS doesn't work I think.

Does someone know why the <head> tag is not interpreted please ?

Thanks a lot !
Zeedjoy
 
Posts: 2
Joined: 14. November 2014 14:02
Operating System: Windows 7

Re: Self hosting, problem with html <head> tag

Postby Altrea » 14. November 2014 15:10

Commonly that's a WordPress configuration issue (base URL)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Self hosting, problem with html <head> tag

Postby Nobbie » 14. November 2014 15:47

Zeedjoy wrote:Does someone know why the <head> tag is not interpreted please ?


No.

The most common error in this context is the problem, that you have been asked for a Hostname (or Servername or Domain) when installing Wordpress and you probably applied "localhost". If you do so, all links to CSS documents refer to localhost - but this does not work if you request from a different PC, because in that context localhost yields to the wrong PC (not to the Xampp PC, but to the requesting PC).

If you want to run WordPress not only on localhost, you should provide the RouterIP instead for the Servername (not localhost).
Nobbie
 
Posts: 8758
Joined: 09. March 2008 13:04

Re: Self hosting, problem with html <head> tag

Postby Zeedjoy » 14. November 2014 16:10

OK thanks a lot, problem solved, I changed localhost by my rooter ip in wordpress admin pannel and it works.

See you !
Zeedjoy
 
Posts: 2
Joined: 14. November 2014 14:02
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 42 guests