Apache wont start. Strange log error!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache wont start. Strange log error!

Postby patlof76 » 12. November 2014 10:38

Yesterday I made a multiwordpress and suddenly it stopped working.
First it complaint towards Teamviewer was using 443. Hace changed port från 443 to 8443 in httpd-ssl.conf.
Still doesn't work. Have got a strange error which my only guess is that a plugin messed it up.
014] [ssl:warn] [pid 2064:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Nov 09 09:40:46.779670 2014] [mpm_winnt:notice] [pid 2064:tid 256] AH00354: Child: Starting 150 worker threads.
[Sun Nov 09 23:08:40.234896 2014] [mpm_winnt:notice] [pid 608:tid 352] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Sun Nov 09 23:08:51.248516 2014] [mpm_winnt:notice] [pid 2064:tid 256] AH00364: Child: All worker threads have exited.
[Sun Nov 09 23:09:11.044950 2014] [mpm_winnt:notice] [pid 608:tid 352] AH00431: Parent: Forcing termination of child process 2064
[Mon Nov 10 08:35:57.751258 2014] [ssl:warn] [pid 312:tid 352] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Nov 10 08:35:58.250459 2014] [ssl:warn] [pid 312:tid 352] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Nov 10 08:35:59.014860 2014] [mpm_winnt:notice] [pid 312:tid 352] AH00455: Apache/2.4.10 (Win32) OpenSSL/1.0.1i PHP/5.5.15 configured -- resuming normal operations
[Mon Nov 10 08:35:59.014860 2014] [mpm_winnt:notice] [pid 312:tid 352] AH00456: Apache Lounge VC11 Server built: Jul 17 2014 11:50:08
[Mon Nov 10 08:35:59.014860 2014] [core:notice] [pid 312:tid 352] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Mon Nov 10 08:35:59.014860 2014] [mpm_winnt:notice] [pid 312:tid 352] AH00418: Parent: Created child process 1860
[Mon Nov 10 08:36:00.044462 2014] [ssl:warn] [pid 1860:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Nov 10 08:36:00.465663 2014] [ssl:warn] [pid 1860:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Nov 10 08:36:00.512463 2014] [mpm_winnt:notice] [pid 1860:tid 256] AH00354: Child: Starting 150 worker threads.
[Mon Nov 10 15:51:55.566541 2014] [ssl:warn] [pid 2120:tid 352] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Nov 10 15:51:55.691341 2014] [core:warn] [pid 2120:tid 352] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Mon Nov 10 15:51:56.003341 2014] [ssl:warn] [pid 2120:tid 352] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Nov 10 15:51:56.720943 2014] [mpm_winnt:notice] [pid 2120:tid 352] AH00455: Apache/2.4.10 (Win32) OpenSSL/1.0.1i PHP/5.5.15 configured -- resuming normal operations
[Mon Nov 10 15:51:56.720943 2014] [mpm_winnt:notice] [pid 2120:tid 352] AH00456: Apache Lounge VC11 Server built: Jul 17 2014 11:50:08
[Mon Nov 10 15:51:56.720943 2014] [core:notice] [pid 2120:tid 352] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Mon Nov 10 15:51:56.736543 2014] [mpm_winnt:notice] [pid 2120:tid 352] AH00418: Parent: Created child process 2472
[Mon Nov 10 15:51:57.703744 2014] [ssl:warn] [pid 2472:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Nov 10 15:51:58.093745 2014] [ssl:warn] [pid 2472:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Nov 10 15:51:58.140545 2014] [mpm_winnt:notice] [pid 2472:tid 256] AH00354: Child: Starting 150 worker threads.
[Mon Nov 10 22:56:33.729245 2014] [mpm_winnt:notice] [pid 2120:tid 352] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Mon Nov 10 22:56:43.838063 2014] [mpm_winnt:notice] [pid 2472:tid 256] AH00364: Child: All worker threads have exited.
[Mon Nov 10 22:56:56.614485 2014] [mpm_winnt:notice] [pid 2120:tid 352] AH00430: Parent: Child process 2472 exited successfully.
[Tue Nov 11 11:24:31.514865 2014] [ssl:warn] [pid 1228:tid 352] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Nov 11 11:24:32.076466 2014] [ssl:warn] [pid 1228:tid 352] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Nov 11 11:24:33.106068 2014] [mpm_winnt:notice] [pid 1228:tid 352] AH00455: Apache/2.4.10 (Win32) OpenSSL/1.0.1i PHP/5.5.15 configured -- resuming normal operations
[Tue Nov 11 11:24:33.106068 2014] [mpm_winnt:notice] [pid 1228:tid 352] AH00456: Apache Lounge VC11 Server built: Jul 17 2014 11:50:08
[Tue Nov 11 11:24:33.106068 2014] [core:notice] [pid 1228:tid 352] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Tue Nov 11 11:24:33.106068 2014] [mpm_winnt:notice] [pid 1228:tid 352] AH00418: Parent: Created child process 2104
[Tue Nov 11 11:24:34.244870 2014] [ssl:warn] [pid 2104:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Nov 11 11:24:34.634871 2014] [ssl:warn] [pid 2104:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Nov 11 11:24:34.697271 2014] [mpm_winnt:notice] [pid 2104:tid 256] AH00354: Child: Starting 150 worker threads.
[Tue Nov 11 20:55:42.703971 2014] [mpm_winnt:notice] [pid 1228:tid 352] AH00428: Parent: child process 2104 exited with status 255 -- Restarting.
AH00526: Syntax error on line 1 of C:/xampp/apache/conf/extra/httpd-vhosts.conf:
Invalid command '{\\rtf1\\ansi\\ansicpg1252\\deff0{\\fonttbl{\\f0\\fnil\\fcharset0', perhaps misspelled or defined by a module not included in the server configuration

Very new to apache and Xampp so sorry if the problem is obvious. I have uninstalled teamviewer btw.

Thanks!
Patrik
patlof76
 
Posts: 2
Joined: 12. November 2014 10:29
Operating System: Windows 7

Re: Apache wont start. Strange log error!

Postby Altrea » 12. November 2014 11:14

Hi Patrik,

AH00526: Syntax error on line 1 of C:/xampp/apache/conf/extra/httpd-vhosts.conf:
Invalid command '{\\rtf1\\ansi\\ansicpg1252\\deff0{\\fonttbl{\\f0\\fnil\\fcharset0', perhaps misspelled or defined by a module not included in the server configuration


Did you edit your httpd-vhosts.conf with a RTF editor? You need to use a plain text editor.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache wont start. Strange log error!

Postby Nobbie » 12. November 2014 11:40

Altrea wrote:Did you edit your httpd-vhosts.conf with a RTF editor?


Obviously. Wordpad?!
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Apache wont start. Strange log error!

Postby patlof76 » 12. November 2014 12:32

Found it!!
Actually Altrea and Nobbie, you two saved me lots of time and are my heroes of today! Perhaps even the month!
Yes, I used wordpad and thought it didn't put any more text than the text itself. Can't remember it has done that before. Anyway! I say the strange strings when using Notepad! And put the plain text in the file and saved! It worked!!

Thank you so much!!
patlof76
 
Posts: 2
Joined: 12. November 2014 10:29
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests