Error establishing a database connection

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error establishing a database connection

Postby bert2bert » 05. November 2014 15:21

Fresh xampp install, upon entering localhost/mapthatiputunderhtdocs (witch contains an existing wordpress website) there is a 'Error establishing a database connection'. When i enter http://localhost/xampp/index.php there is no problem. when restarting apache this is in the error log :

[Wed Nov 05 15:19:51.962014 2014] [ssl:warn] [pid 4264:tid 392] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Nov 05 15:19:52.004074 2014] [core:warn] [pid 4264:tid 392] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Wed Nov 05 15:19:52.080479 2014] [ssl:warn] [pid 4264:tid 392] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Nov 05 15:19:52.103146 2014] [mpm_winnt:notice] [pid 4264:tid 392] AH00455: Apache/2.4.10 (Win32) OpenSSL/1.0.1i PHP/5.5.15 configured -- resuming normal operations
[Wed Nov 05 15:19:52.103146 2014] [mpm_winnt:notice] [pid 4264:tid 392] AH00456: Apache Lounge VC11 Server built: Jul 17 2014 11:50:08
[Wed Nov 05 15:19:52.103146 2014] [core:notice] [pid 4264:tid 392] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Wed Nov 05 15:19:52.103146 2014] [mpm_winnt:notice] [pid 4264:tid 392] AH00418: Parent: Created child process 6604
[Wed Nov 05 15:19:52.522453 2014] [ssl:warn] [pid 6604:tid 408] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Nov 05 15:19:52.646253 2014] [ssl:warn] [pid 6604:tid 408] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Nov 05 15:19:52.678258 2014] [mpm_winnt:notice] [pid 6604:tid 408] AH00354: Child: Starting 150 worker threads.

can anyone tell me what i do wrong / share experience ?

thanks
bert2bert
 
Posts: 3
Joined: 05. November 2014 15:13
Operating System: windows 8.1

Re: Error establishing a database connection

Postby Altrea » 05. November 2014 15:27

This is a wordpress configuration issue.
Check your database connection data in your wordpress configuration
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Error establishing a database connection

Postby bert2bert » 05. November 2014 16:22

thanks,
i tried https://wordpress.org/support/topic/xampp-error-establishing-a-database-connection-localhost
but it doesnt help
bert2bert
 
Posts: 3
Joined: 05. November 2014 15:13
Operating System: windows 8.1

Re: Error establishing a database connection

Postby bert2bert » 05. November 2014 17:46

this is whay i was looking for (the past two days) :
http://forums.phpfreaks.com/topic/110129-where-does-xampp-put-the-mysql-server/
bert2bert
 
Posts: 3
Joined: 05. November 2014 15:13
Operating System: windows 8.1

Re: Error establishing a database connection

Postby Nobbie » 05. November 2014 18:55

You provided the wrong credentials to the wordpress config file, but as long as you dont show us, what you applied, we cannot help you.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests