Apache won't start - port issue

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't start - port issue

Postby mcma0144 » 01. November 2014 22:07

I am getting the following error log:

4:50:41 PM [main] Initializing Control Panel
4:50:41 PM [main] Windows Version: Windows 8 64-bit
4:50:41 PM [main] XAMPP Version: 1.8.3
4:50:41 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
4:50:41 PM [main] You are not running with administrator rights! This will work for
4:50:41 PM [main] most application stuff but whenever you do something with services
4:50:41 PM [main] there will be a security dialogue or things will break! So think
4:50:41 PM [main] about running this application with administrator rights!
4:50:41 PM [main] XAMPP Installation Directory: "c:\xampp\"
4:50:41 PM [main] Checking for prerequisites
4:50:41 PM [main] All prerequisites found
4:50:41 PM [main] Initializing Modules
4:50:41 PM [Apache] Problem detected!
4:50:41 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
4:50:41 PM [Apache] Apache WILL NOT start without the configured ports free!
4:50:41 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
4:50:41 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
4:50:41 PM [Apache] Problem detected!
4:50:41 PM [Apache] Port 443 in use by ""C:\Program Files (x86)\VMware\VMware Workstation\vmware-hostd.exe" -u "C:\ProgramData\VMware\hostd\config.xml"" with PID 4508!
4:50:41 PM [Apache] Apache WILL NOT start without the configured ports free!
4:50:41 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
4:50:41 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
4:50:41 PM [mysql] Problem detected!
4:50:41 PM [mysql] Port 3306 in use by ""C:\Program Files\MySQL\MySQL Server 5.6\bin\mysqld" --defaults-file="C:\ProgramData\MySQL\MySQL Server 5.6\my.ini" MySQL56"!
4:50:41 PM [mysql] MySQL WILL NOT start without the configured ports free!
4:50:41 PM [mysql] You need to uninstall/disable/reconfigure the blocking application
4:50:41 PM [mysql] or reconfigure MySQL and the Control Panel to listen on a different port
4:50:41 PM [main] The FileZilla module is disabled
4:50:41 PM [main] The Tomcat module is disabled
4:50:41 PM [main] Starting Check-Timer
4:50:41 PM [main] Control Panel Ready
4:50:46 PM [Apache] Problem detected!
4:50:46 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
4:50:46 PM [Apache] Apache WILL NOT start without the configured ports free!
4:50:46 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
4:50:46 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
4:50:46 PM [Apache] Problem detected!
4:50:46 PM [Apache] Port 443 in use by ""C:\Program Files (x86)\VMware\VMware Workstation\vmware-hostd.exe" -u "C:\ProgramData\VMware\hostd\config.xml"" with PID 4508!
4:50:46 PM [Apache] Apache WILL NOT start without the configured ports free!
4:50:46 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
4:50:46 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
4:50:46 PM [Apache] Attempting to start Apache app...
4:50:47 PM [Apache] Status change detected: running
4:50:47 PM [Apache] Status change detected: stopped
4:50:47 PM [Apache] Error: Apache shutdown unexpectedly.
4:50:47 PM [Apache] This may be due to a blocked port, missing dependencies,
4:50:47 PM [Apache] improper privileges, a crash, or a shutdown by another method.
4:50:47 PM [Apache] Press the Logs button to view error logs and check
4:50:47 PM [Apache] the Windows Event Viewer for more clues
4:50:47 PM [Apache] If you need more help, copy and post this
4:50:47 PM [Apache] entire log window on the forums
4:52:02 PM [Apache] Problem detected!
4:52:02 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
4:52:02 PM [Apache] Apache WILL NOT start without the configured ports free!
4:52:02 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
4:52:02 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
4:52:02 PM [Apache] Problem detected!
4:52:02 PM [Apache] Port 443 in use by ""C:\Program Files (x86)\VMware\VMware Workstation\vmware-hostd.exe" -u "C:\ProgramData\VMware\hostd\config.xml"" with PID 4508!
4:52:02 PM [Apache] Apache WILL NOT start without the configured ports free!
4:52:02 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
4:52:02 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
4:52:02 PM [Apache] Attempting to start Apache app...
4:52:03 PM [Apache] Status change detected: running
4:52:03 PM [Apache] Status change detected: stopped
4:52:03 PM [Apache] Error: Apache shutdown unexpectedly.
4:52:03 PM [Apache] This may be due to a blocked port, missing dependencies,
4:52:03 PM [Apache] improper privileges, a crash, or a shutdown by another method.
4:52:03 PM [Apache] Press the Logs button to view error logs and check
4:52:03 PM [Apache] the Windows Event Viewer for more clues
4:52:03 PM [Apache] If you need more help, copy and post this
4:52:03 PM [Apache] entire log window on the forums


I have tried changing the listening port number from 80 to 1080 as a quick fix but it does not seem to be working. I'm at a bi of a loss here so any suggestions would be appreciated!

Thanks.
mcma0144
 
Posts: 2
Joined: 01. November 2014 22:02
Operating System: Windows 8

Re: Apache won't start - port issue

Postby mcma0144 » 01. November 2014 22:18

Made another change for a quick fix. I changed the listening port for the ssl in the config file. It's working now!
mcma0144
 
Posts: 2
Joined: 01. November 2014 22:02
Operating System: Windows 8

Re: Apache won't start - port issue

Postby Gwen » 05. November 2014 17:54

Hi, can you explain a bit more please ? same issue with a port already in used :D
Thanks
Gwen
 
Posts: 2
Joined: 05. November 2014 17:48
Operating System: WIN7 - WIN 8 - Ubuntu

Re: Apache won't start - port issue

Postby Nobbie » 06. November 2014 12:27

Changing the default ports for http(s) (80 and 443) is a bad idea, its better to find the blocking process and change that. Mostly it is Skype or Microsoft IIS (or, but not very often, like in this case a Virtual Machine).

If you change http or https default port, you always have to specify to port to your URL, what looks ugly and in some cases gives problems with 3d party products. For example, if you change 443 to 445, you cannot enter https://localhost/myfile.html into your browser, you have to use https://localhost:445/myfile.html instead

Same for http, if you change port 80 to 88 for example, you cannot use http://localhost/folder/file.php anymore, you must use http://localhost:88/folder/file.php (same for linking to your local server). Do you like this?
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: Apache won't start - port issue

Postby Altrea » 06. November 2014 12:33

I recommend to bind the http.sys driver to IPv6 only by using the following command:
Code: Select all
netsh http add iplisten ipaddress=::


http://www.mikeplate.com/2011/11/06/sto ... n-windows/

This should prevent PID 4 (http.sys) to listen on IPv4 port 80
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache won't start - port issue

Postby shemcristobal » 09. November 2014 08:35

Try this: change "Listen 80" to "Listen 8080" in httpd.conf and "Listen 443" to "Listen 4431" in httpd-ssl.conf.

mcma0144 wrote:I am getting the following error log:

4:50:41 PM [main] Initializing Control Panel
4:50:41 PM [main] Windows Version: Windows 8 64-bit
4:50:41 PM [main] XAMPP Version: 1.8.3
4:50:41 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
4:50:41 PM [main] You are not running with administrator rights! This will work for
4:50:41 PM [main] most application stuff but whenever you do something with services
4:50:41 PM [main] there will be a security dialogue or things will break! So think
4:50:41 PM [main] about running this application with administrator rights!
4:50:41 PM [main] XAMPP Installation Directory: "c:\xampp\"
4:50:41 PM [main] Checking for prerequisites
4:50:41 PM [main] All prerequisites found
4:50:41 PM [main] Initializing Modules
4:50:41 PM [Apache] Problem detected!
4:50:41 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
4:50:41 PM [Apache] Apache WILL NOT start without the configured ports free!
4:50:41 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
4:50:41 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
4:50:41 PM [Apache] Problem detected!
4:50:41 PM [Apache] Port 443 in use by ""C:\Program Files (x86)\VMware\VMware Workstation\vmware-hostd.exe" -u "C:\ProgramData\VMware\hostd\config.xml"" with PID 4508!
4:50:41 PM [Apache] Apache WILL NOT start without the configured ports free!
4:50:41 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
4:50:41 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port

....

I have tried changing the listening port number from 80 to 1080 as a quick fix but it does not seem to be working. I'm at a bi of a loss here so any suggestions would be appreciated!

Thanks.
shemcristobal
 
Posts: 2
Joined: 09. November 2014 08:25
Operating System: Windows 7

Re: Apache won't start - port issue

Postby Gwen » 11. November 2014 15:23

Great shemcristobal , good help ! thanks
Gwen
 
Posts: 2
Joined: 05. November 2014 17:48
Operating System: WIN7 - WIN 8 - Ubuntu

Re: Apache won't start - port issue

Postby Ambrofort » 11. November 2014 20:22

Hi,

I have a similar issue. I installed Web Matrix and MySQL; then, when I tried to access XAMPP- Apache I received an error saying port 80 was being used. I uninstalled both Web Matrix and MySQL; the issue continued; then, I changed port 80 to 8080; and, port 443 to 4431. Next issue I got was my XAMPP admin was IIS Windows (Internet Information Services); therefore, even though I changed the port; IIS is obstructing XAMPP. How do I kick out IIS Windows from my port to use XAMPP? or any other comment or idea to solve the situation would be highlighted appreciated. Thank you.
Ambrofort
 
Posts: 2
Joined: 11. November 2014 20:03
Operating System: Window

Re: Apache won't start - port issue

Postby Nobbie » 11. November 2014 23:07

Ambrofort wrote:Next issue I got was my XAMPP admin was IIS Windows (Internet Information Services); therefore, even though I changed the port; IIS is obstructing XAMPP


Did you read my previous post in this thread??
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: Apache won't start - port issue

Postby Altrea » 11. November 2014 23:40

I have added a section on how to change the Apache ports at my [FGA] Apache won't start.
Please read that section
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache won't start - port issue

Postby Ambrofort » 12. November 2014 22:37

Thank you! :)
Ambrofort
 
Posts: 2
Joined: 11. November 2014 20:03
Operating System: Window


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests