[WORK AROUND FOUND] error logs brimming with nonsense

Problems with the Windows version of XAMPP, questions, comments, and anything related.

[WORK AROUND FOUND] error logs brimming with nonsense

Postby kimmik » 25. October 2014 21:08

Well it is nonsense to me - anyone ideas where/what is causing this?

A cut from just one of the virtual host error logs (previously working php pages being called (in fact they work fine on the live server) so not a PHP coding error. No such request is made to bottom or top (.html) files - rather obviously as the virtual host directory is away on a different volume.

getting 1000's of these filling up the error log.
nothing in the access log other than the call to the main index.php page.

[Sat Oct 25 20:54:20.994842 2014] [include:error] [pid 4540:tid 1780] [client 127.0.0.1:62722] unable to include potential exec "include/bottom.html" in parsed file C:/XAMPP/apache/error/HTTP_NOT_FOUND.html.var, content type not text/*
[Sat Oct 25 20:54:20.995843 2014] [include:error] [pid 4540:tid 1724] [client 127.0.0.1:62726] unable to include potential exec "include/top.html" in parsed file C:/XAMPP/apache/error/HTTP_NOT_FOUND.html.var, content type not text/*

The files do exist in C:XAMPP/apache/error/include. The mystery is why can they not be accessed - and more importantly why are they being called in the first place? (and since when has a html file been called a "potential exec"?)

Beginning to think that the php has not been set up / installed correctly though suspicious of Apache.

This "simple" upgrade is fast becoming all consuming of time and frustration.
Last edited by kimmik on 08. November 2014 13:31, edited 1 time in total.
kimmik
 
Posts: 20
Joined: 24. October 2014 12:08
Operating System: Windows 7 Home Premium

Re: error logs brimming with nonsense

Postby kimmik » 29. October 2014 15:51

error.logs Still filling up with 2 sets of these messages for every page call in the access log

Any ideas on what is causing this or why the error is being triggered.

In the virtual host location there is not even a subdirectory /include. No file top.html or bottom.html is being requested by any html/php file within the project virtual host directory structure.

I have found a bottom.html and top.html inside C:XAMPP/apache/error/include/ but I do not understand why anything is being called inside this directory from a request on the virtual server.

Any help to resolve this issue most welcome.

I am currently emptying the error logs 3 times a day - these are normally remain pretty empty.
kimmik
 
Posts: 20
Joined: 24. October 2014 12:08
Operating System: Windows 7 Home Premium

Re: error logs brimming with nonsense

Postby JJ_Tagy » 29. October 2014 17:54

Are you using a custom redirect/.htaccess? When you say nothing in access log but main, you might show the full call. Scan for Malware?
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: error logs brimming with nonsense

Postby Nobbie » 29. October 2014 19:41

kimmik wrote:Any ideas on what is causing this or why the error is being triggered.


Probably you screwed up an existing or already working software by mixing wrong configuration (i.e. configuration files) into the application.

According to the fact, that you already have a bunch of unknown and annoying errors, you should think about formatting your harddisk and begin from scratch. I dont think we will find all the reasons for these errors, as already said, this all looks like a horrible mix of configurations and software, which do not fit to each other. We do not have any idea, what you are doing there, but i never before had a similar case with so many different errors.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: error logs brimming with nonsense

Postby kimmik » 29. October 2014 22:46

Thanks both for your valued input.
There has actually been very little change made to the system overall.
The "old" system with Apache2.2/MySQL5.5/PHP5.3 has been in faultless operation for several years. Happily virtual hosting many virtual hosts on the local intranet each with their own /conf/extra/httpd_xxx.conf files and included from the main conf/httpd.conf

The XAMPP install was made to upgrade to latest versions. Other than the correction given and acknowledged on another topic here for the change to all the httpd_xxx.conf files and the entry of the root password no other changes have been made to the configuration. Perhaps they should - but new to XAMPP and the updates I'm unaware.

The server has very little othe software on it other than Norton Security, the PHP Editor and Oracle Office 4.

This pair of error is happening in all projects' error logs. I do not understand why XAMPP error handling is even being called (Assumption that these files are part of XAMPP/apache error handling). Then why are the errors appearing inside the projects' error log?

I have generated some PHP errors (bad syntax/missing arguments) and these seem to all appear correctly in the log.
kimmik
 
Posts: 20
Joined: 24. October 2014 12:08
Operating System: Windows 7 Home Premium

Re: error logs brimming with nonsense

Postby kimmik » 08. November 2014 13:31

kimmik wrote:[Sat Oct 25 20:54:20.994842 2014] [include:error] [pid 4540:tid 1780] [client 127.0.0.1:62722] unable to include potential exec "include/bottom.html" in parsed file C:/XAMPP/apache/error/HTTP_NOT_FOUND.html.var, content type not text/*
[Sat Oct 25 20:54:20.995843 2014] [include:error] [pid 4540:tid 1724] [client 127.0.0.1:62726] unable to include potential exec "include/top.html" in parsed file C:/XAMPP/apache/error/HTTP_NOT_FOUND.html.var, content type not text/*


After many wasted hours I think I have got to the bottom of this mess. Perusing the access logs and error logs and the fact that these errors were generated on every page request - even a simple html blank page (no images, css, includes, js)
I have come to the conclusion that these requests for files from the XAMPP Apache directories are a result of

127.0.0.1 - - [08/Nov/2014:10:33:46 +0000] "GET /favicon.ico HTTP/1.1" 200 5567

in the access log.

The file favicon.ico does not exist in the project base htdocs directory (this is the last thing we are interested in when developing a web app) However, if a favicon.ico file is placed in the base htdocs directory the errors seem to stop.

So I guess that is a "work around" to the issue rather than a genuine solution and the mystery of why the errors (or more to the point why Apache is generating errors to something it cannot find in its own directories) remains a fault.

Still, I thought that posting the work around may be of some assistance to others, and might save them some time.
kimmik
 
Posts: 20
Joined: 24. October 2014 12:08
Operating System: Windows 7 Home Premium


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests