phpMyAdmin Links Not Woking

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpMyAdmin Links Not Woking

Postby compugator » 20. October 2014 20:46

I just did a fresh install of XAMPP 1.8.3 and when I visit the phpMyAdmin page, none of the links work unless you open them in a new tab. Is this some setting that I need to change?
compugator
 
Posts: 1
Joined: 20. October 2014 20:34
Operating System: Windows 7

Re: phpMyAdmin Links Not Woking

Postby kimmik » 25. October 2014 16:18

Yeah!
I get exactly the same thing!
An ugly popup (pink on yellow) to tell me that " Error: token mismatch" and "click to dismiss this notification"
Needless to say no amount of clicking kills the popup - so nothing else within phpMyAdmin is available.

Browser: Firefox 33.0.1

Just tried in IE 11
and get "A fatal JavaScript error has occurred. Would you like to send an error report?"
kimmik
 
Posts: 20
Joined: 24. October 2014 12:08
Operating System: Windows 7 Home Premium

Re: phpMyAdmin Links Not Woking

Postby JJ_Tagy » 25. October 2014 17:02

Sounds like you need to clear your cookies/cache.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: phpMyAdmin Links Not Woking

Postby kimmik » 25. October 2014 17:39

Done - no change - it looks like a javascript problem - almost every page seems to get the "A fatal Javascript error ..." message even if you open in a new tab. Then clicking most buttons produce the uncloseable popup.

Seems far worse in Firefox than IE - but still virtually unusable
kimmik
 
Posts: 20
Joined: 24. October 2014 12:08
Operating System: Windows 7 Home Premium

Re: phpMyAdmin Links Not Woking

Postby JJ_Tagy » 25. October 2014 17:54

Check to see if your IE is set in intranet mode for localhost automatically. Try turning that off.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: phpMyAdmin Links Not Woking

Postby kimmik » 25. October 2014 19:55

Tx for the suggestion:

Made the changes as per http://windows.microsoft.com/en-gb/windows-vista/changing-intranet-security-settings and restarted IE

No prizes though - still the same Javascript error and complete lock up in Firefox (no surprise there as IE setting only) Virtually never use IE so not really much use.

phpAdmin is at least connecting to localhost OK and listing the databases - just cannot use it to do anything that "Error: token mismatch" and "click to dismiss this notification" popup

Interesting to know what browser used by the OP?
kimmik
 
Posts: 20
Joined: 24. October 2014 12:08
Operating System: Windows 7 Home Premium

Re: phpMyAdmin Links Not Woking

Postby JJ_Tagy » 25. October 2014 21:13

The last thing I can think is your phpmyadmin config or deleted files.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: phpMyAdmin Links Not Woking

Postby kimmik » 26. October 2014 10:56

I guess that brings us back to the OP's question.

Other than editing C:\XAMPP\phpMyAdmin\config.inc.php on line 21 to give it the root password of MySQL

I have not changed anything inside phpMyAdmin directory since install. Should I? Is there a requirement?

Is there some other change to make? Should this file be left alone and the password given elsewhere?
kimmik
 
Posts: 20
Joined: 24. October 2014 12:08
Operating System: Windows 7 Home Premium

Re: phpMyAdmin Links Not Woking

Postby Nobbie » 26. October 2014 11:19

What did you do to run phpmyadmin? Which URL did you enter, or what did you do?
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: phpMyAdmin Links Not Woking

Postby kimmik » 26. October 2014 12:40

Simply open the Control Panel v3.2.1
Then click on the "Admin" on the MySQL row
It opens a new tab in my default browser "Firefox" showing no errors and correctly displays all the Databases under localhost
and puts a new line in the Control Panel event window of: [mysql] Executing "http://localhost/phpmyadmin/"

clicking on any of the displayed databases in the left column "flashes" "loading" then correctly displays the tables in the main column. All good so far.

But clicking for example the "Databases" or any of the top button produces the error described above. The page is completely locked up by the popup (no surprise) with no way to close it.
If the menu button is right clicked before any other action and the link opened in a new tab then again thet page is displayed correctly. Of course it also is locked up by the popup as soon as you click on anything! The pages can be closed with the normal Ctrl+W or closing the tab/Firefox.

In IE the result is slightly different - as described above the "Javascript error" is displayed rather than the popup.
kimmik
 
Posts: 20
Joined: 24. October 2014 12:08
Operating System: Windows 7 Home Premium

Re: phpMyAdmin Links Not Woking

Postby Altrea » 26. October 2014 13:00

Did you already try to use the alternative phpmyadmin Design "Original" instead of "pmahomme"?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: phpMyAdmin Links Not Woking

Postby kimmik » 26. October 2014 15:26

@Altea

Sorry to be dumb here but I don't understand your question.

XAMPP was installed "out of the box" I assumed that no changes would be required prior to use (I know I'm dumb!)

All I have done has already been documented in my questions on this forum.
Put simply (because I am and like things to be that way):
changes to httpd.conf to include the extra\*.httpd*.conf virtual hosts - along with the "upgrade to 2.4" change "Require all granted"
setting MySQL root password and change to root password in phpMyadmin conf as detailed above.

I'll be quick to admit that phpMyadmin is not my favourite application and generally we use MySQLQuery/MySQLAdministrator (from the previous install of MySQL5.5 and another db manager product Navicat for MySQL. All 3 of these "appear" to be working as before.

As I said phpMyAdmin is launched from the Control Panel - the fact that it is producing javascript errors and page lockup in Firefox remains a problem.

So back to your response..
What alternative phpMyAdmin design? Where do I find/launch it? What do you mean by "Original" instead of "pmahomme"? - both are as meaningless as each other to me.

Thank you for trying to help such a novice.
kimmik
 
Posts: 20
Joined: 24. October 2014 12:08
Operating System: Windows 7 Home Premium


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests