Error: Apache shutdown unexpectedly.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error: Apache shutdown unexpectedly.

Postby redsue12 » 25. September 2014 23:44

Dear Apache Friends,
I am just getting started with xampp (using a local server to develop some jQuery skills), and have managed to install xampp and run it with administrative privileges, but so far have not been able to start Apache. Here is what I see as it attempts to start:

The check boxes on the left of the Apache, MySQL, FileZilla and Tomcat modules are filled with a red X, and the box next to the Mercury module is empty.

The main logs window reads:
3:39:59 PM [main] Initializing Control Panel
3:39:59 PM [main] Windows Version: Windows 7 Home Premium SP1 64-bit
3:39:59 PM [main] XAMPP Version: 1.8.3
3:39:59 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
3:39:59 PM [main] Running with Administrator rights - good!
3:39:59 PM [main] XAMPP Installation Directory: "c:\xampp\"
3:39:59 PM [main] Checking for prerequisites
3:40:00 PM [main] All prerequisites found
3:40:00 PM [main] Initializing Modules
3:40:00 PM [mysql] XAMPP MySQL is already running on port 3306
3:40:00 PM [filezilla] XAMPP FileZilla is already running on port 21
3:40:00 PM [filezilla] XAMPP FileZilla is already running on port 14147
3:40:00 PM [mercury] XAMPP Mercury is already running on port 25
3:40:00 PM [mercury] XAMPP Mercury is already running on port 79
3:40:00 PM [mercury] XAMPP Mercury is already running on port 105
3:40:00 PM [mercury] XAMPP Mercury is already running on port 106
3:40:00 PM [mercury] XAMPP Mercury is already running on port 110
3:40:00 PM [mercury] XAMPP Mercury is already running on port 143
3:40:00 PM [mercury] XAMPP Mercury is already running on port 2224
3:40:00 PM [Tomcat] Java is already running on port 8005!
3:40:00 PM [Tomcat] Is Tomcat already running?
3:40:00 PM [Tomcat] Java is already running on port 8080!
3:40:00 PM [Tomcat] Is Tomcat already running?
3:40:00 PM [Tomcat] Java is already running on port 8009!
3:40:00 PM [Tomcat] Is Tomcat already running?
3:40:00 PM [main] Enabling autostart for module "Apache"
3:40:00 PM [main] Starting Check-Timer
3:40:00 PM [main] Control Panel Ready
3:40:00 PM [Apache] Autostart active: starting...
3:40:00 PM [Apache] Attempting to start Apache app...
3:40:01 PM [Apache] Status change detected: running
3:40:02 PM [Apache] Status change detected: stopped
3:40:02 PM [Apache] Error: Apache shutdown unexpectedly.
3:40:02 PM [Apache] This may be due to a blocked port, missing dependencies,
3:40:02 PM [Apache] improper privileges, a crash, or a shutdown by another method.
3:40:02 PM [Apache] Press the Logs button to view error logs and check
3:40:02 PM [Apache] the Windows Event Viewer for more clues
3:40:02 PM [Apache] If you need more help, copy and post this
3:40:02 PM [Apache] entire log window on the forums

The Apache errors logs read:
[Wed Sep 24 15:51:12.406765 2014] [ssl:warn] [pid 516:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Sep 24 15:51:12.935795 2014] [ssl:warn] [pid 516:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Sep 24 15:51:13.005799 2014] [mpm_winnt:notice] [pid 516:tid 256] AH00455: Apache/2.4.10 (Win32) OpenSSL/1.0.1i PHP/5.5.15 configured -- resuming normal operations
[Wed Sep 24 15:51:13.005799 2014] [mpm_winnt:notice] [pid 516:tid 256] AH00456: Apache Lounge VC11 Server built: Jul 17 2014 11:50:08
[Wed Sep 24 15:51:13.005799 2014] [core:notice] [pid 516:tid 256] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Wed Sep 24 15:51:13.010800 2014] [mpm_winnt:notice] [pid 516:tid 256] AH00418: Parent: Created child process 1084
[Wed Sep 24 15:51:14.125863 2014] [ssl:warn] [pid 1084:tid 268] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Sep 24 15:51:14.591890 2014] [ssl:warn] [pid 1084:tid 268] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Sep 24 15:51:14.664894 2014] [mpm_winnt:notice] [pid 1084:tid 268] AH00354: Child: Starting 150 worker threads.

The line reading "server certificate does NOT include an ID which matches the server name" seems to point at the main problem, but I haven't been able to find any info which would resolve that. I would greatly appreciate some suggestions as to what steps I might try next.
Thank you for any help you can provide,
redsue 12

P.A. I have read the other posts in this board which point to conflicts with Skype using port 80, but I do not have Skype installed on my machine.
redsue12
 
Posts: 3
Joined: 25. September 2014 23:07
Operating System: Windows 7 Home Premium

Re: Error: Apache shutdown unexpectedly.

Postby Altrea » 26. September 2014 05:55

Hi,

Run the apache_start.bat Script and Post its response please.

Best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Error: Apache shutdown unexpectedly.

Postby redsue12 » 26. September 2014 17:01

Dear Altrea,

Aha! I ran apache_start.bat and a command window opened named C:\Windows\System32\cmd.exe, and found the line:

AH00526: Syntax error on line 563 of C:/xampp/apache/conf/httpd.conf: Illegal option FollowSumLinks

Line 563 was part of a block of code that I added as instructed in the book "Sams Teach Yourself jQuery and JavaScript in 24 Hours". That block of code reads:

<Directory "C:/xampp/htdocs/code">
#Allows Browser Access to Your jQuery and JavaScript code Directory
Options Indexes FollowSumLinks Includes ExecCGI
Allow Override All
Allow From All
</Directory>

Per "Sam", that code was to be added to the httpd.conf file to enable me (the learner) to access a code directory when the server is running. I don't know how important that is, but I removed that block of code and the Apache server is running, according to the main control panel window logs.

However, I am not yet out of the woods...
The left-side check boxes in the Control Panel are still marked with a red "X". Running apache_start.bat results in:

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : AH00072: make_sock: could not bind to address [::]:80
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : AH00072: make_sock: could not bind to address 0.0.0.0:
80
AH00451: no listening sockets available, shutting down
AH00015: Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .

So apparently I still have conflicts with Port 80. I am sure that anything you have to say will be helpful! (I am pretty new to all of this so please be gentle...). Meanwhile I will be reading up on port conflicts.
Thank you,
redsue12
redsue12
 
Posts: 3
Joined: 25. September 2014 23:07
Operating System: Windows 7 Home Premium

Re: Error: Apache shutdown unexpectedly.

Postby JJ_Tagy » 26. September 2014 19:47

Not sure if that block was you or him, but it didn't like SUM - should be SYM. It is short for symbolic.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: Error: Apache shutdown unexpectedly.

Postby redsue12 » 27. September 2014 02:35

Thank you JJ_Tagy! So sorry to bother folks over a typo!
redsue12
redsue12
 
Posts: 3
Joined: 25. September 2014 23:07
Operating System: Windows 7 Home Premium


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests