Apache Not working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Not working

Postby osiris2190 » 17. September 2014 01:51

8:52:51 PM [Apache] Problem detected!
8:52:51 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
8:52:51 PM [Apache] Apache WILL NOT start without the configured ports free!
8:52:51 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
8:52:51 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port

This is the error message that I am getting. I dont have skype so that can't be it. No clue what to do please help
osiris2190
 
Posts: 3
Joined: 17. September 2014 01:50
Operating System: Windows 8

Re: Apache Not working

Postby osiris2190 » 17. September 2014 16:20

Come on ppl I really need some plz! I have over 35 ppl looking at this but no replies! I am reallllllly in need of this to work and have no idea what to do! PLZ HELP
osiris2190
 
Posts: 3
Joined: 17. September 2014 01:50
Operating System: Windows 8

Re: Apache Not working

Postby JJ_Tagy » 17. September 2014 17:31

Come on you! There are over 35 posts asking this exact same question and you can't read a single one?
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: Apache Not working

Postby osiris2190 » 17. September 2014 18:01

Do you really think I am that stupid that I don't read the other posts before I write one of my own? Pretty much every single one I have read are about changing the port on skype. WHICH I DONT HAVE. So explain to me then how that helps me? Oh wait it doesn't. hence the reason I posted this in the first place. If your not willing to help a person out, then please don't bother posting. I am just honestly trying to get some help and nothing I am doing is working.
osiris2190
 
Posts: 3
Joined: 17. September 2014 01:50
Operating System: Windows 8

Re: Apache Not working

Postby JJ_Tagy » 17. September 2014 18:50

Obviously you did not read the posts exactly like yours, so you can answer your own first question. PID 4 will never be Skype, so that is not the typical response.

I, along with 35 other people, was not willing to help, thus no response. Your whining garnered the initial one. So you asked for that initial reply.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: Apache Not working

Postby alfan » 25. September 2014 10:09

i am also facing the same error above pls help for solution
alfan
 
Posts: 3
Joined: 25. September 2014 06:09
Operating System: windows 7

Re: Apache Not working

Postby alfan » 25. September 2014 12:13

Dear user, i got the solutions for the above error ,

go to control panel then go windows features on and off, then uncheck IIS , hopefully you will find the solution for the 80 port
alfan
 
Posts: 3
Joined: 25. September 2014 06:09
Operating System: windows 7

Re: Apache Not working

Postby madamsplash » 08. November 2014 04:58

This has always been an issue when using Xampp - as it requires Port 80 to be free to operate. Many common programs use Port 80 - e.g. Skype, is the most common conflict.

You can (a) shut the Program down while you use Xampp, or as in the case of Skype, the advanced settings can nominate not use Port 80, and 443 ... and this can free up the Port for Xamp.

You can use CMD (command prompt administrator) and type in netstat -aon to see which programs/ports are using port 80 and use task manager to close them.

I should mention that Hackers are now using these same Ports when they have broken into your wireless Router - either via your (aged) Mobile Phone or your (aged) Wireless Device ... or a modern one that is not using device pairing meticulously.
madamsplash
 
Posts: 1
Joined: 08. November 2014 04:37
Operating System: Windows 8

Re: Apache Not working

Postby vishal316 » 08. November 2014 11:14

well try changing the port no for Apache on which it is listening
For e.g if it is asking port 80 to be free but some other application is using it then try using different port.It can be any random port no..for e.g-use prot 1337
I used it and its working.
To change port no:
1)Go to Config tab beside your Apache on Xampp Cantrol panel
2)open Apache(httpd.conf) file
3)In that file Change Listen 80 to
Listen 1337
4)Save that file.
5)then open Apache(httpd-ssl.conf) file
6)change Listen 443 to
Listen 7331
7)Save it.

Try this!!..IT worked for me.hope it works for you as well.
vishal316
 
Posts: 2
Joined: 08. November 2014 09:31
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests