Solved: View website on LAN

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Solved: View website on LAN

Postby ThunderSniper » 16. September 2014 23:25

Hello all,

I have recently reinstalled my computer with Windows 7 Professional 64-bit. Prior to this, I was running Home Premium, only because of warranty. I have a virtual machine running on Oracle VM VirtualBox as well, it is running Windows XP. This machine is installed on the Windows 7 machine. It hosts a lot of my test websites that I enjoy messing around with and a couple of beta ones as well. I used to be able to view these on my host PC (Windows 7) before the reinstall, however, since the reinstall I can no longer do this. I simply get told that the machine could not find the server at "address". This is false, as I know from isup.me and using a proxy that it is working fine.

The only change to the virtual machine was that I had to reinstall the LAN drivers, this meant that the IP address was temporarily on DHCP and not static. Which I have since resolved. However, now that all port forwarding is working perfectly fine, I can't seem to understand why my host pc can no longer view the websites of the server. It's very frustrating as I rely on it as my live-view while coding in DreamWeaver, just makes life easier :D

Before the reinstall, I saved the .vdi to my NAS and am now running the server by using that saved one. Of course I had to "create" a new machine shell I guess you could call it, and the .vdi hdd image is used by this machine as the server.

I really hope I can get some help on this.
Thank you so much in advance,
Thunder.
Last edited by ThunderSniper on 16. September 2014 23:34, edited 1 time in total.
ThunderSniper
 
Posts: 2
Joined: 16. September 2014 23:19
Operating System: Windows XP

Re: View website on LAN

Postby ThunderSniper » 16. September 2014 23:34

Pretty sure I've just sussed it, and while I like to save my dignity, I'd also like to solve this for anyone else that may or may not come across this error.

DO NOT leave your preferred DNS as your default gateway, change it to 8.8.8.8 or 4.4.4.4! MAN I feel stupid!
ThunderSniper
 
Posts: 2
Joined: 16. September 2014 23:19
Operating System: Windows XP


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests