Cant start Apache Server

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cant start Apache Server

Postby daveb86 » 05. September 2014 11:42

Hello there

Im having issues starting Apache

11:39:24 [Apache] Error: Apache shutdown unexpectedly.
11:39:24 [Apache] This may be due to a blocked port, missing dependencies,
11:39:24 [Apache] improper privileges, a crash, or a shutdown by another method.
11:39:24 [Apache] Press the Logs button to view error logs and check
11:39:24 [Apache] the Windows Event Viewer for more clues
11:39:24 [Apache] If you need more help, copy and post this
11:39:24 [Apache] entire log window on the forums


Then when i check the logs i see the following errors

[Fri Sep 05 11:28:11.833899 2014] [ssl:warn] [pid 8248:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Sep 05 11:28:13.060969 2014] [ssl:warn] [pid 8248:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Sep 05 11:28:16.775181 2014] [mpm_winnt:notice] [pid 8248:tid 256] AH00455: Apache/2.4.10 (Win32) OpenSSL/1.0.1i PHP/5.5.15 configured -- resuming normal operations
[Fri Sep 05 11:28:16.776181 2014] [mpm_winnt:notice] [pid 8248:tid 256] AH00456: Apache Lounge VC11 Server built: Jul 17 2014 11:50:08
[Fri Sep 05 11:28:16.776181 2014] [core:notice] [pid 8248:tid 256] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Fri Sep 05 11:28:24.434619 2014] [mpm_winnt:notice] [pid 8248:tid 256] AH00418: Parent: Created child process 8528
[Fri Sep 05 11:28:26.667747 2014] [ssl:warn] [pid 8528:tid 268] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Sep 05 11:28:27.925819 2014] [ssl:warn] [pid 8528:tid 268] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Sep 05 11:28:28.236837 2014] [mpm_winnt:notice] [pid 8528:tid 268] AH00354: Child: Starting 150 worker threads.
Thanks

Dave
www.pc-solutionz.co.uk
daveb86
 
Posts: 1
Joined: 05. September 2014 11:36
Operating System: Windows 7

Re: Cant start Apache Server

Postby @director@ » 05. September 2014 23:19

I'm having the same problem. I tracked it down to the use of port 80 by Skype and switched the XAMPP server and my PHP editor to port 78. Problem solved? I've since updated XAMPP and now have the problem od Apache being rejected by the System on port 80.

Any help is most appreciated :D

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
XAMPP Installer and Version: xampp-win32-1.8.3-5-VC11-installer
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

CONTROL PANEL OUTPUT
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
04:07:38 PM [Apache] Attempting to start Apache app...
04:07:38 PM [Apache] Executing "c:\xampp\apache\bin\httpd.exe"
04:07:38 PM [Apache] Return code: 0
04:07:39 PM [Apache] Status change detected: running
04:07:39 PM [Apache] Status change detected: stopped
04:07:39 PM [Apache] Error: Apache shutdown unexpectedly.
04:07:39 PM [Apache] This may be due to a blocked port, missing dependencies,
04:07:39 PM [Apache] improper privileges, a crash, or a shutdown by another method.
04:07:39 PM [Apache] Press the Logs button to view error logs and check
04:07:39 PM [Apache] the Windows Event Viewer for more clues
04:07:39 PM [Apache] If you need more help, copy and post this
04:07:39 PM [Apache] entire log window on the forums
04:07:57 PM [main] Executing C:\Program Files (x86)\phpDesigner 8\phpDesigner.exe c:\xampp\apache\logs\error.log
04:17:40 PM [Apache] Checking default ports...
04:17:40 PM [Apache] Portblocker Detected: System
04:17:40 PM [Apache] Checking for App: c:\xampp\apache\bin\httpd.exe
04:17:40 PM [Apache] Portblocker Path: Unable to open process
04:17:40 PM [Apache] Portblocker Service Path:
04:17:40 PM [Apache] Problem detected!
04:17:40 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
04:17:40 PM [Apache] Apache WILL NOT start without the configured ports free!
04:17:40 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
04:17:40 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
04:17:40 PM [Apache] Attempting to start Apache app...
04:17:40 PM [Apache] Executing "c:\xampp\apache\bin\httpd.exe"
04:17:40 PM [Apache] Return code: 0
04:17:42 PM [Apache] Status change detected: running
04:17:44 PM [Apache] Status change detected: stopped
04:17:44 PM [Apache] Error: Apache shutdown unexpectedly.
04:17:44 PM [Apache] This may be due to a blocked port, missing dependencies,
04:17:44 PM [Apache] improper privileges, a crash, or a shutdown by another method.
04:17:44 PM [Apache] Press the Logs button to view error logs and check
04:17:44 PM [Apache] the Windows Event Viewer for more clues
04:17:44 PM [Apache] If you need more help, copy and post this
04:17:44 PM [Apache] entire log window on the forums
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
Arrowhead Consumers Union - The Country Club of the 99%
Link: http://www.acucentral.(org/net)
Contact: admin@acucentral.(org/net)
@director@
 
Posts: 1
Joined: 05. September 2014 22:31
Location: Superior National Forest, Arrowhead Region, Minnesota, US
Operating System: Windows 7

Re: Cant start Apache Server

Postby Nobbie » 06. September 2014 10:47

@director@ wrote:Problem solved?


No. Ugly solution.

Simply change Skype (and not Xampp!) not to use Port 80. There is an option menu in Skype where you can set the Ports.


Anyway - this message

Port 80 in use by "Unable to open process" with PID 4!


neither means Skype blocks Port 80 nor Xampp/Apache, but instead Microsoft IIS (the Microsoft Internet Service). If you dont need IIS, you should switch it off and/or deinstall it. It usually comes preinstalled with "Ultimate" Windows versions.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 70 guests