[BUGS] XAMPP 5.6.3-0 & 5.5.19-0 issues

Problems with the Windows version of XAMPP, questions, comments, and anything related.

[BUGS] XAMPP 5.6.3-0 & 5.5.19-0 issues

Postby Altrea » 28. August 2014 06:14

In this thread we collect all information about issues with XAMPP for Windows 5.6.3-0 & 5.5.19-0
To report a bug simply create a new forum thread

XAMPP 5.6.3-0

confirmed

acknowledged

    XAMPP 5.5.19-0

    confirmed

    acknowledged
      We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

      It's like porn for programmers 8)
      User avatar
      Altrea
      AF Moderator
       
      Posts: 8298
      Joined: 17. August 2009 13:05
      XAMPP version: several
      Operating System: Windows 10 Pro x64

      Phonebook broken "Unable to prepare statement 1"

      Postby Altrea » 22. November 2014 00:04

      Bug Report

      The Phonebook example (http://localhost/xampp/phonebook.php) is broken and shows the following messages
      Warning: SQLite3::query(): Unable to prepare statement: 1, no such table: users in C:\xampp\htdocs\xampp\phonebook.php on line 70

      Fatal error: Call to a member function fetchArray() on boolean in C:\xampp\htdocs\xampp\phonebook.php on line 73


      The reason for this is a wrong second parameter for the SQLite3::__construct line in line 35
      (Expected an integer [0-7], given a string '0666')


      Reproducible Testcase

      Start Apache and request the URL http://localhost/xampp/phonebook.php


      Affected XAMPP versions

      All XAMPP versions containing the SQLite3 example of the phonebook (>= XAMPP 1.8.0)


      Solution

      The default value for the second parameter is 6 (SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE).
      The recommend value for such an application would be 2 (SQLITE3_OPEN_READWRITE) or 6 (SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE).
      So omitting the second parameter would be fine.

      • Open \xampp\htdocs\xampp\phonebook.php
      • search for the following line
        Code: Select all
           if(!($db=new SQLite3('sqlite/phonebook.sqlite3', '0666')))
      • change that line to
        Code: Select all
           if(!($db=new SQLite3('sqlite/phonebook.sqlite3')))
      • save the file
      We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

      It's like porn for programmers 8)
      User avatar
      Altrea
      AF Moderator
       
      Posts: 8298
      Joined: 17. August 2009 13:05
      XAMPP version: several
      Operating System: Windows 10 Pro x64

      Security page with italian location white screen of death

      Postby Altrea » 22. November 2014 03:33

      Bug Report

      The security page (http://localhost/security/index.php) cannot be displayed with italian localization. It produces a white screen of death.
      Reason for this is that the language is not mentioned in the listing of the allowed languages in the file \xampp\security\htdocs\lang.php


      Reproducible Testcase

      change the language to Italiano and click on the Link with the name "Sicurezz"


      Affected XAMPP versions
      definitely since XAMPP 1.8.2-4 / 1.8.3-3, maybe even earlier.
      (XAMPP 1.8.0 was correct in its behavior)


      Solution

      There is a language "sl" in the listing which never gets used, so the recommend way is to replace sl with it:
      • Open in your editor the file \xampp\security\htdocs\lang.php
      • Search for the following line
        Code: Select all
           if (($lang == "de") || ($lang == "en") || ($lang == "es") || ($lang == "fr") || ($lang == "jp") || ($lang == "nl") || ($lang == "no") || ($lang == "pl") || ($lang == "pt") || ($lang == "pt_br") || ($lang == "sl") || ($lang == "zh")) {
      • change this line to
        Code: Select all
           if (($lang == "de") || ($lang == "en") || ($lang == "es") || ($lang == "fr") || ($lang == "jp") || ($lang == "nl") || ($lang == "no") || ($lang == "pl") || ($lang == "pt") || ($lang == "pt_br") || ($lang == "it") || ($lang == "zh")) {
      • save the file
      We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

      It's like porn for programmers 8)
      User avatar
      Altrea
      AF Moderator
       
      Posts: 8298
      Joined: 17. August 2009 13:05
      XAMPP version: several
      Operating System: Windows 10 Pro x64

      Bitnami installer leaves httpd command line open

      Postby Altrea » 24. January 2015 16:35

      Bug Report

      The Bitnami installer starts and never stops httpd in the command line which is not transparent for the user.
      After executing the Bitnami XAMPP installer you will be asked if the XAMPP control panel should be opened.
      Because Apache is already started by the installer, the control panel is showing the following messages:
      ##:##:## [Apache] Problem detected!
      ##:##:## [Apache] Port 80 in use by "Unable to open process" with PID ####!
      ##:##:## [Apache] Apache WILL NOT start without the configured ports free!
      ##:##:## [Apache] You need to uninstall/disable/reconfigure the blocking application
      ##:##:## [Apache] or reconfigure Apache and the Control Panel to listen on a different port
      ##:##:## [Apache] Problem detected!
      ##:##:## [Apache] Port 443 in use by "Unable to open process" with PID ####!
      ##:##:## [Apache] Apache WILL NOT start without the configured ports free!
      ##:##:## [Apache] You need to uninstall/disable/reconfigure the blocking application
      ##:##:## [Apache] or reconfigure Apache and the Control Panel to listen on a different port



      Reproducible Testcase
      Execute the installer and do an installation with all the default settings


      Affected XAMPP versions
      XAMPP 5.6.3-0
      XAMPP 5.5.19-0

      Solution
      fixing the installer to close the command line at the end
      or be much more transparent to the user what will get started and which influences that could have
      We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

      It's like porn for programmers 8)
      User avatar
      Altrea
      AF Moderator
       
      Posts: 8298
      Joined: 17. August 2009 13:05
      XAMPP version: several
      Operating System: Windows 10 Pro x64

      misinterpreted charset on several XAMPP administration pages

      Postby Altrea » 26. January 2015 21:50

      Bug Report
      XAMPPs administration page shows several misinterpreted characters on different languages.
      Reason for this is the new default charset which is set to utf-8 by default in all PHP 5.6+ versions (instead of empty string for prior versions).
      The XAMPP administration page is mostly encoded with iso-8859-1 but does not send explicit headers.


      Reproducible Testcase
      every default installation will show this bug


      Affected XAMPP versions
      XAMPP 5.6.3-0


      Solution
      clean fix would mean either
      • convert all XAMPP administration page files to utf-8
        or/AND
      • set explicit encoding headers

      dirty fix
      • convert only the lang files (\xampp\htdocs\xampp\lang\*.* & \xampp\security\htdocs\lang\*.*) to utf-8
      We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

      It's like porn for programmers 8)
      User avatar
      Altrea
      AF Moderator
       
      Posts: 8298
      Joined: 17. August 2009 13:05
      XAMPP version: several
      Operating System: Windows 10 Pro x64


      Return to XAMPP for Windows

      Who is online

      Users browsing this forum: No registered users and 64 guests