XAMPP Error: Apache shutdown unexpectedly ...

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP Error: Apache shutdown unexpectedly ...

Postby tj1026 » 11. August 2014 23:31

I am trying to set up virtual hosts for a number of website developments. The first virtual host was set up my modifying the file
C:\xampp\apache\conf\extra\httpd-vhosts.conf
to include the section
<VirtualHost *:80>
DocumentRoot "D:/Users/usrnme/Documents/dwphp/test"
ServerName test

<Directory "D:/Users/usrnme/Documents/dwphp">
AllowOverride All
Require all granted
</Directory>
</VirtualHost>

After restarting Apache this worked fine.
After stopping Apache, the following section was added
<VirtualHost *:80>
DocumentRoot "D:/Users/usrnme/Documents/Organisations/NIAG/website/DesignN-iag"
ServerName n-iag

<Directory "D:/Users/usrnme/Documents/Organisations/NIAG/website/DesignN-iag">
AllowOverride All
Require all granted
</Directory>
</VirtualHost>

On trying to restart Apache, the error message 'XAMPP Error: Apache shutdown unexpectedly...' was displayed.
The log from the XAMPP control panel was:
Starting apache from XAMPP control panel received error message:
19:43:33 [main] Initializing Control Panel
19:43:33 [main] Windows Version: Windows 7 Professional SP1 32-bit
19:43:33 [main] XAMPP Version: 1.8.3
19:43:33 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
19:43:33 [main] Running with Administrator rights - good!
19:43:33 [main] XAMPP Installation Directory: "c:\xampp\"
19:43:33 [main] Checking for prerequisites
19:43:33 [main] All prerequisites found
19:43:33 [main] Initializing Modules
19:43:33 [Apache] Initializing module...
19:43:33 [Apache] Checking for module existence...
19:43:33 [Apache] Checking for required tools...
19:43:33 [Apache] Checking for service (name="Apache2.4"): Service not installed
19:43:33 [Apache] Service Path: Service Not Installed
19:43:33 [Apache] Checking default ports...
19:43:33 [mysql] Initializing module...
19:43:33 [mysql] Checking for module existence...
19:43:33 [mysql] Checking for required tools...
19:43:33 [mysql] Checking for service (name="mysql"): Service not installed
19:43:33 [mysql] Service Path: Service Not Installed
19:43:33 [mysql] Checking default ports...
19:43:33 [main] The FileZilla module is disabled
19:43:33 [main] The Mercury module is disabled
19:43:33 [main] The Tomcat module is disabled
19:43:33 [main] Starting Check-Timer
19:43:33 [main] Control Panel Ready
19:43:38 [main] Executing notepad.exe c:\xampp\apache\logs\access.log
19:43:42 [main] Executing notepad.exe c:\xampp\apache\logs\error.log
19:43:45 [Apache] Checking default ports...
19:43:45 [Apache] Attempting to start Apache app...
19:43:45 [Apache] Executing "c:\xampp\apache\bin\httpd.exe"
19:43:45 [Apache] Return code: 0
19:43:45 [Apache] Status change detected: running
19:43:45 [Apache] Status change detected: stopped
19:43:45 [Apache] Error: Apache shutdown unexpectedly.
19:43:45 [Apache] This may be due to a blocked port, missing dependencies,
19:43:45 [Apache] improper privileges, a crash, or a shutdown by another method.
19:43:45 [Apache] Press the Logs button to view error logs and check
19:43:45 [Apache] the Windows Event Viewer for more clues
19:43:45 [Apache] If you need more help, copy and post this
19:43:45 [Apache] entire log window on the forums
19:44:47 [main] Executing notepad.exe c:\xampp\apache\logs\error.log
19:44:51 [main] Executing notepad.exe c:\xampp\apache\logs\access.log

Also both log files were empty: access.log and error.log.

When I ran httpd.exe from the command line with the -t option, no errors were reported.

Is there a maximum length for the DocumentRoot string?

Many thanks for your help.
tj1026
 
Posts: 1
Joined: 11. August 2014 23:17
XAMPP Version: 5.5.19
Operating System: Windows 7 Professional, 32 SP1

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests