Problem: can't install xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem: can't install xampp

Postby Mario64 » 11. August 2014 20:32

I'm running Windows XP. I downloaded xampp-win32-1.8.2-5-VC9-installer.exe. When it's installing, the installer always crashes. Inside the xampp folder, there are still files and folders after, though.
Screenshot:
http://snag.gy/aSyo4.jpg
Mario64
 
Posts: 2
Joined: 11. August 2014 19:31
XAMPP Version: 1.8.3
Operating System: Windows XP

Re: Problem: can't install xampp

Postby Nobbie » 11. August 2014 20:54

Requirements for 1.8.2 from apachefriends.org:

XAMPP 1.8.2 (with PHP 5.4): Windows 2003, 2008, 2012, XP, Vista, 7, 8 XAMPP 1.8.3 (with PHP 5.5): (Important: XP or 2003 not supported) 2008, 2012, Vista, 7, 8.
Nobbie
 
Posts: 7035
Joined: 09. March 2008 13:04

Re: Problem: can't install xampp

Postby Altrea » 11. August 2014 22:10

Windows XP is supported for the PHP 5.4 version (XAMPP 1.8.2-X)

I added a break, so the requirements are:
Nobbie wrote:
XAMPP 1.8.2 (with PHP 5.4): Windows 2003, 2008, 2012, XP, Vista, 7, 8
XAMPP 1.8.3 (with PHP 5.5): (Important: XP or 2003 not supported) 2008, 2012, Vista, 7, 8.


I don't really like/trust the Bitnami installers, so i would give the .zip version a try.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6845
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: Problem: can't install xampp

Postby Mario64 » 16. August 2014 16:48

I tried the ZIP version. It worked, I extracted it. I ran /xampp/apache/apache_installservice.bat
Error:
Installing Apache2.4 as an Service
Installing the Apache2.4 service
The Apache2.4 service is successfully installed.
Testing httpd.conf....
Errors reported here must be corrected before the service can be started.
httpd: Syntax error on line 518 of C:/Documents and Settings/RAJAN/My Documents/
xampp2/xampp/apache/conf/httpd.conf: Syntax error on line 17 of C:/xampp/apache/
conf/extra/httpd-xampp.conf: Cannot load /xampp/php/php5ts.dll into server: The
specified module could not be found.
Now we Start Apache2.4 :)
The Apache2.4 service is starting..
The Apache2.4 service could not be started.

A service specific error occurred: 1.

More help is available by typing NET HELPMSG 3547.
------
Could it be because I have multiple failed xampp installation directories with files in them?
Mario64
 
Posts: 2
Joined: 11. August 2014 19:31
XAMPP Version: 1.8.3
Operating System: Windows XP

Re: Problem: can't install xampp

Postby Altrea » 16. August 2014 16:51

Remove all services you registered
Don't install XAMPP in your Users Directory
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6845
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests