XAMPP Error: Apache shutdown unexpectedly...

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP Error: Apache shutdown unexpectedly...

Postby walt1982 » 09. August 2014 23:00

This is a rewrite of the initial post to reflect the current situation.

This is a Windows7 64-bit system, fully up-to-date, withxampp 1.8.3-4.
Xampp is set to run with administrator privileges. MySQL runs with no problem.

I've tried many things:
- I eliminated port conflict with Skype and other things by using different port numbers assigned exclusively to Apache.
- I'm now attempting to access Apache at http://localhost:84 and https://localhost:444.
- I set the McAfee/Windows firewall to allow Apache Server complete two-way access.
- I have tested with the firewall off (with no connection to the Internet) to insure that wasn't the problem.
- Earlier, I had configured my router's DHCP server to assign a fixed IP address to my PC rather than trying to use localhost.

The error log below cites at least 3 anomalies:
- server certificate does NOT include an ID which matches the server name
- Unknown error: AH00141: Could not initialize random number generator
- AH00419: master_main: create child process failed.

It's unclear whether these 3 items are related problems or not.
Hard to imagine I'm the only person having this start-up problem.
The messages and log appear below.

Any assistance would be GREATLY appreciated. :-)
*********************************************************
Here's the xampp control panel message:
8:17:02 AM [Apache] Error: Apache shutdown unexpectedly.
8:17:02 AM [Apache] This may be due to a blocked port, missing dependencies,
8:17:02 AM [Apache] improper privileges, a crash, or a shutdown by another method.
8:17:02 AM [Apache] Press the Logs button to view error logs and check
8:17:02 AM [Apache] the Windows Event Viewer for more clues
8:17:02 AM [Apache] If you need more help, copy and post this
8:17:02 AM [Apache] entire log window on the forums

And here's the Apache error log:
[Tue Aug 12 08:17:01.401204 2014] [ssl:warn] [pid 7196:tid 420] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Aug 12 08:17:01.744404 2014] [ssl:warn] [pid 7196:tid 420] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Aug 12 08:17:01.853604 2014] [mpm_winnt:notice] [pid 7196:tid 420] AH00455: Apache/2.4.9 (Win32) OpenSSL/1.0.1g PHP/5.5.11 configured -- resuming normal operations
[Tue Aug 12 08:17:01.853604 2014] [mpm_winnt:notice] [pid 7196:tid 420] AH00456: Apache Lounge VC11 Server built: Mar 16 2014 12:13:13
[Tue Aug 12 08:17:01.853604 2014] [core:notice] [pid 7196:tid 420] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Tue Aug 12 08:17:01.900404 2014] [mpm_winnt:notice] [pid 7196:tid 420] AH00418: Parent: Created child process 2036
[Tue Aug 12 08:17:01.916004 2014] [:crit] [pid 2036] (-2146173818)Unknown error: AH00141: Could not initialize random number generator
[Tue Aug 12 08:17:01.931604 2014] [mpm_winnt:crit] [pid 7196:tid 420] AH00419: master_main: create child process failed. Exiting.
Last edited by walt1982 on 12. August 2014 16:17, edited 1 time in total.
walt1982
 
Posts: 6
Joined: 09. August 2014 22:25
XAMPP Version: 1.8.3-1
Operating System: Windows 7

Re: XAMPP Error: Apache shutdown unexpectedly...

Postby gsmith » 10. August 2014 19:33

walt1982 wrote:[Sat Aug 09 14:19:55.516392 2014] [:crit] [pid 4056] (-2146173818)Unknown error: AH00141: Could not initialize random number generator
This is the error that is keeping Apache from starting. Random numbers are usually generated by the underlying OS in most cases.

This error is in APR (libaprutil-1.dll) and I'm thinking it because the Cryptographic Services in your Windows are not running. Check this and if disabled, make sure it is not disabled.
gsmith
 
Posts: 135
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP Version: 5.6.3
Operating System: Win XP to 8.1/VS 6,9-12

Re: XAMPP Error: Apache shutdown unexpectedly...

Postby walt1982 » 10. August 2014 20:05

I checked and found that Cryptographic Services is running. It's running with a Logon of "Network Service" so I stopped and started it with Logon of "Local System" but this logon fails with an error message saying "Error 1079 - The account specified for this service is different from the account specified for other services running in the same process". However, I note that there are a number of Network Services set to Disabled or Manual start so I am turning them on. Must now re-boot, so am now sending this reply and will return later with result.
walt1982
 
Posts: 6
Joined: 09. August 2014 22:25
XAMPP Version: 1.8.3-1
Operating System: Windows 7

Re: XAMPP Error: Apache shutdown unexpectedly...

Postby walt1982 » 10. August 2014 20:17

This post was no longer correct, so I have deleted it.
Last edited by walt1982 on 12. August 2014 16:24, edited 3 times in total.
walt1982
 
Posts: 6
Joined: 09. August 2014 22:25
XAMPP Version: 1.8.3-1
Operating System: Windows 7

Re: XAMPP Error: Apache shutdown unexpectedly...

Postby walt1982 » 10. August 2014 21:53

It appears I was mistaken; the Apache error log is as before, including the "AH00141: Could not initialize random number generator".
I have rewritten the first post above to more accurately describe the situation.
Back to Windows Event Viewer...
walt1982
 
Posts: 6
Joined: 09. August 2014 22:25
XAMPP Version: 1.8.3-1
Operating System: Windows 7

Re: XAMPP Error: Apache shutdown unexpectedly...

Postby walt1982 » 12. August 2014 18:47

Problem solved!!
Windows Event Viewer, rather cryptic, led me to check on the possibility of other conflicting servers. I found an old Microsoft SQL Server compact edition that had been installed as part of Visual Studio. It was apparently in conflict with Apache, and when uninstalled, allowed Apache to run OK.
walt1982
 
Posts: 6
Joined: 09. August 2014 22:25
XAMPP Version: 1.8.3-1
Operating System: Windows 7

Re: XAMPP Error: Apache shutdown unexpectedly...

Postby gsmith » 13. August 2014 21:29

Odd, but glad you found the problem! Hopefully I'll remember this edge case if I see this in the future. I have Visual Studio (with SQL Compact) installed and have never run into this problem.
gsmith
 
Posts: 135
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP Version: 5.6.3
Operating System: Win XP to 8.1/VS 6,9-12

Re: XAMPP Error: Apache shutdown unexpectedly...

Postby walt1982 » 13. August 2014 23:04

For future readers, I should add that I had enabled a number of "Network Services" during the earlier problem-solving effort, so maybe it was the combination of things that did it. But the MS SQL Server uninstall was the final change that worked.
walt1982
 
Posts: 6
Joined: 09. August 2014 22:25
XAMPP Version: 1.8.3-1
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 77 guests