Error: Apache shutdown unexpectedly.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error: Apache shutdown unexpectedly.

Postby day » 05. August 2014 19:55

I just downloaded and installed xampp and I am unable to start apache or MySQL. When I press the start button I get this error... Error: Apache shutdown unexpectedly.
It appears I'm not the only one experiencing this problem, maybe my additional information will help. Please let me know if there's anything else I can provide.

I did temporarily disable my firewall. I also turned off UAC (although the warning still popped up on setup). I also uninstalled and reinstalled to no avail.

xxamp version: xampp-win32-1.8.3-4-VC11-installer.exe
Win 8.1 64 bit (I don't know any of the other stuff requested such as edition and service pack)
Installation path: C:\xxampp\
I haven't changed any config or anything, just clicked start once the control panel opened.

Action: I clicked start beside Apache
Reaction expected: Apache would start
Reaction received:
11:14:26 AM [main] Initializing Control Panel
11:14:26 AM [main] Windows Version: Windows 8 64-bit
11:14:26 AM [main] XAMPP Version: 1.8.3
11:14:26 AM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
11:14:26 AM [main] You are not running with administrator rights! This will work for
11:14:26 AM [main] most application stuff but whenever you do something with services
11:14:26 AM [main] there will be a security dialogue or things will break! So think
11:14:26 AM [main] about running this application with administrator rights!
11:14:26 AM [main] XAMPP Installation Directory: "c:\xampp\"
11:14:26 AM [main] Checking for prerequisites
11:14:27 AM [main] All prerequisites found
11:14:27 AM [main] Initializing Modules
11:14:27 AM [Apache] Problem detected!
11:14:27 AM [Apache] Port 80 in use by "Unable to open process" with PID 5968!
11:14:27 AM [Apache] Apache WILL NOT start without the configured ports free!
11:14:27 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
11:14:27 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
11:14:27 AM [Apache] Problem detected!
11:14:27 AM [Apache] Port 443 in use by "Unable to open process" with PID 5968!
11:14:27 AM [Apache] Apache WILL NOT start without the configured ports free!
11:14:27 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
11:14:27 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
11:14:27 AM [main] Starting Check-Timer
11:14:27 AM [main] Control Panel Ready
11:14:29 AM [Apache] Problem detected!
11:14:29 AM [Apache] Port 80 in use by "Unable to open process" with PID 5968!
11:14:29 AM [Apache] Apache WILL NOT start without the configured ports free!
11:14:29 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
11:14:29 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
11:14:29 AM [Apache] Problem detected!
11:14:29 AM [Apache] Port 443 in use by "Unable to open process" with PID 5968!
11:14:29 AM [Apache] Apache WILL NOT start without the configured ports free!
11:14:29 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
11:14:29 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
11:14:29 AM [Apache] Attempting to start Apache app...
11:14:30 AM [Apache] Status change detected: running
11:14:30 AM [Apache] Status change detected: stopped
11:14:30 AM [Apache] Error: Apache shutdown unexpectedly.
11:14:30 AM [Apache] This may be due to a blocked port, missing dependencies,
11:14:30 AM [Apache] improper privileges, a crash, or a shutdown by another method.
11:14:30 AM [Apache] Press the Logs button to view error logs and check
11:14:30 AM [Apache] the Windows Event Viewer for more clues
11:14:30 AM [Apache] If you need more help, copy and post this
11:14:30 AM [Apache] entire log window on the forums

I don't have this file \xampp\control-panel.log

Here is the error.log from the control panel
[Tue Aug 05 11:12:30.977713 2014] [ssl:warn] [pid 5968:tid 344] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Aug 05 11:12:31.318604 2014] [ssl:warn] [pid 5968:tid 344] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Aug 05 11:12:31.615802 2014] [mpm_winnt:notice] [pid 5968:tid 344] AH00455: Apache/2.4.9 (Win32) OpenSSL/1.0.1g PHP/5.5.11 configured -- resuming normal operations
[Tue Aug 05 11:12:31.615802 2014] [mpm_winnt:notice] [pid 5968:tid 344] AH00456: Apache Lounge VC11 Server built: Mar 16 2014 12:13:13
[Tue Aug 05 11:12:31.615802 2014] [core:notice] [pid 5968:tid 344] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Tue Aug 05 11:12:31.623809 2014] [mpm_winnt:notice] [pid 5968:tid 344] AH00418: Parent: Created child process 6020
[Tue Aug 05 11:12:32.707531 2014] [ssl:warn] [pid 6020:tid 400] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Aug 05 11:12:33.138820 2014] [ssl:warn] [pid 6020:tid 400] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Tue Aug 05 11:12:33.218873 2014] [mpm_winnt:notice] [pid 6020:tid 400] AH00354: Child: Starting 150 worker threads.

I haven't done anything else. Thanks for any help!!
day
day
 
Posts: 1
Joined: 05. August 2014 19:32
Operating System: Win 8

Re: Error: Apache shutdown unexpectedly.

Postby JJ_Tagy » 05. August 2014 20:35

Run the control panel with Admin rights. Since they are the same PID, my suspicion is Skype.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 39 guests