please help me up

Problems with the Windows version of XAMPP, questions, comments, and anything related.

please help me up

Postby kingjames » 05. August 2014 15:44

Please i need help

10:48:38 AM [main] Initializing Control Panel
10:48:38 AM [main] Windows Version: Windows 7 Ultimate SP1 32-bit
10:48:38 AM [main] XAMPP Version: 1.8.3
10:48:38 AM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
10:48:38 AM [main] You are not running with administrator rights! This will work for
10:48:38 AM [main] most application stuff but whenever you do something with services
10:48:38 AM [main] there will be a security dialogue or things will break! So think
10:48:38 AM [main] about running this application with administrator rights!
10:48:38 AM [main] XAMPP Installation Directory: "c:\xampp\"
10:48:38 AM [main] Checking for prerequisites
10:49:35 AM [main] All prerequisites found
10:49:35 AM [main] Initializing Modules
10:49:35 AM [Apache] Problem detected!
10:49:35 AM [Apache] Port 80 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 316!
10:49:35 AM [Apache] Apache WILL NOT start without the configured ports free!
10:49:35 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
10:49:35 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
10:49:35 AM [Apache] Problem detected!
10:49:35 AM [Apache] Port 443 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 316!
10:49:35 AM [Apache] Apache WILL NOT start without the configured ports free!
10:49:35 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
10:49:35 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
10:49:35 AM [main] Enabling autostart for module "Apache"
10:49:35 AM [main] Enabling autostart for module "MySQL"
10:49:35 AM [main] Enabling autostart for module "FileZilla"
10:49:35 AM [main] Enabling autostart for module "Tomcat"
10:49:35 AM [main] Starting Check-Timer
10:49:35 AM [main] Control Panel Ready
10:49:36 AM [Apache] Autostart active: starting...
10:49:36 AM [Apache] Problem detected!
10:49:36 AM [Apache] Port 80 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 316!
10:49:36 AM [Apache] Apache WILL NOT start without the configured ports free!
10:49:36 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
10:49:36 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
10:49:36 AM [Apache] Problem detected!
10:49:36 AM [Apache] Port 443 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 316!
10:49:36 AM [Apache] Apache WILL NOT start without the configured ports free!
10:49:36 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
10:49:36 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
10:49:36 AM [Apache] Attempting to start Apache app...
10:49:36 AM [mysql] Autostart active: starting...
10:49:36 AM [mysql] Attempting to start MySQL app...
10:49:37 AM [filezilla] Autostart active: starting...
10:49:37 AM [filezilla] Attempting to start FileZilla app...
10:49:37 AM [Tomcat] Autostart active: starting...
10:49:37 AM [Tomcat] Attempting to start Tomcat app...
10:49:37 AM [Apache] Status change detected: running
10:49:38 AM [Apache] Status change detected: stopped
10:49:38 AM [Apache] Error: Apache shutdown unexpectedly.
10:49:38 AM [Apache] This may be due to a blocked port, missing dependencies,
10:49:38 AM [Apache] improper privileges, a crash, or a shutdown by another method.
10:49:38 AM [Apache] Press the Logs button to view error logs and check
10:49:38 AM [Apache] the Windows Event Viewer for more clues
10:49:38 AM [Apache] If you need more help, copy and post this
10:49:38 AM [Apache] entire log window on the forums
10:49:38 AM [filezilla] Status change detected: running
10:49:39 AM [mysql] Status change detected: running
10:50:13 AM [Tomcat] Status change detected: running
10:51:16 AM [Apache] Problem detected!
10:51:16 AM [Apache] Port 80 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 316!
10:51:16 AM [Apache] Apache WILL NOT start without the configured ports free!
10:51:16 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
10:51:16 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
10:51:16 AM [Apache] Problem detected!
10:51:16 AM [Apache] Port 443 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 316!
10:51:16 AM [Apache] Apache WILL NOT start without the configured ports free!
10:51:16 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
10:51:16 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
10:51:16 AM [Apache] Attempting to start Apache app...
10:51:16 AM [Apache] Status change detected: running
10:51:17 AM [Apache] Status change detected: stopped
10:51:17 AM [Apache] Error: Apache shutdown unexpectedly.
10:51:17 AM [Apache] This may be due to a blocked port, missing dependencies,
10:51:17 AM [Apache] improper privileges, a crash, or a shutdown by another method.
10:51:17 AM [Apache] Press the Logs button to view error logs and check
10:51:17 AM [Apache] the Windows Event Viewer for more clues
10:51:17 AM [Apache] If you need more help, copy and post this
10:51:17 AM [Apache] entire log window on the forums
kingjames
 
Posts: 5
Joined: 11. July 2014 19:08
Operating System: windows

Re: please help me up

Postby JJ_Tagy » 05. August 2014 16:34

Looks like you are trying to start/autostart Apache while you already have it started as a service.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: please help me up

Postby kingjames » 05. August 2014 17:33

if i start apache it will shut done so what will be done to resolve it?
kingjames
 
Posts: 5
Joined: 11. July 2014 19:08
Operating System: windows

Re: please help me up

Postby msoucy » 05. August 2014 21:06

Hi,

New user to forum and also recently set this up at work for testing a tool. I had to edit the httpd.conf file in C:\xampp\apache\conf and search for the following lines:
Listen 80 <-- make a copy of it (copy/paste below exiting line) and comment it out with #Listen 80. On copy of line change 80 to 8080
Next search for: ServerName localhost:80 and make a copy of this line, comment one out like noted above, and change 80 to 8080

So in your file the lines should look like

#Listen 80
Listen 8080

and

#ServerName localhost:80
ServerName localhost:8080

Then try and start Apache from the control panel. That *should* resolve your problem, but I make no guarantees ;-)

Mike
msoucy
 
Posts: 1
Joined: 05. August 2014 20:59
Operating System: Windows 8.1

Re: please help me up

Postby Altrea » 05. August 2014 21:51

No, his problem is that Apache is already started by windows service. No need to change any ports.

Simply request http://localhost in your browser
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests