? Remote dev ?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

? Remote dev ?

Postby intellilogic » 31. July 2014 20:49

I have a dedicated WAMP server here where I work. Using my IDE I work on the files via mapped windows drive with both my laptop and desktop.
This solution works quite well, the WAMP server is managing versions, getting backup up, lovely lovely. What I want is for mobile.
I have the mapped drive 'offline' on the laptop and I'd like to use it with XAMPP, but it won't because it's "remote".

What are my options, what's my best solution? I have copied the files to another directory and pointed Apache at that when I go remote; but that's a half-assed fix.
I really prefer using the native offline drive as it will manage all syncing issues and such.
intellilogic
 
Posts: 6
Joined: 31. July 2014 16:30
Operating System: Windows Server 2012

Re: ? Remote dev ?

Postby Nobbie » 01. August 2014 09:57

intellilogic wrote:I have the mapped drive 'offline' on the laptop and I'd like to use it with XAMPP, but it won't because it's "remote".


Please explain more precisely what is meant by that.

And please tell us, what you tried you configure in Xampp, what happens, which error occurs etc.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: ? Remote dev ?

Postby intellilogic » 01. August 2014 10:15

Server 2012 running XAMPP is called rh-webdev and I access it via the network.
Q:\ is a windows drive map to \\rh-webdev\htdocs on both desktop and laptop.
I've made it available offline, so it keeps a cached copy I can access when I am off network.
It syncs back up when I reconnect to the network.

On the laptop I installed XAMPP and get it up and working fine.
Then I try to change:
Code: Select all
DocumentRoot "Q:\"
<Directory "Q:\">
    Order allow,deny
    Allow from all
</Directory>


Then I get apache error from windows events:
The Apache service named reported the following error:
>>> DocumentRoot must be a directory .


No surprise, apache doesn't like remote drives.
So how can I resolve this problem while making the solution most feasible to my work flow?
intellilogic
 
Posts: 6
Joined: 31. July 2014 16:30
Operating System: Windows Server 2012

Re: ? Remote dev ?

Postby Nobbie » 01. August 2014 10:45

intellilogic wrote:No surprise, apache doesn't like remote drives.


No - simply wrong!

The problem is NOT apache, and not the remove drive, it is the drive letter. Drive letters are always ONLY assigned to the currently logged in user. Apache does not run with your user ID if you start it as a service. EIther start apache AFTER you are logged in and NOT as a service, or simply replace Q:\ in the DocumentRoot by the full path \\rh-webdev\htdocs (what i recommend).

But still keep in mind, that Apache runs with a different UserID (usually "System"), if you run it as a service. You have to grant sufficient rights to the System User for //rh-webdev/htdocs (by the way, i recommend using slashes instead of backslashes, as slash works as well and backslash does have a special meaning as a metacharacter in some contexts). Or you also may subsitute the user, which executes Apache as a service (you will find the options in the Windows Setup). But this only applies if you run Apache as service (what is not a must), you also may run Apache not as a service.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Resolved - Thanks Nobbie :)

Postby intellilogic » 01. August 2014 18:48

Ok, I resolved it. It's a domain so I couldn't give a local(machine) user 'system' access to a domain resource.
But what I could do was install as service like I had and prefer and then set the service to run under a domain user!
Drive letter doesn't work, I experimented with this; I used the slashes as you suggested //rh-webdev/htdocs

For anyone who comes along in the future and wants to do this:
WinKey+R (run) : services.msc (enter) -> (find) apache service -> (r-clk) properties -> Log On (tab) -> select domain user
Probably best if domain user has admin priv to the machine (mine did)
intellilogic
 
Posts: 6
Joined: 31. July 2014 16:30
Operating System: Windows Server 2012

Re: Resolved - Thanks Nobbie :)

Postby Nobbie » 01. August 2014 19:57

intellilogic wrote:Ok, I resolved it


Nice.

But i cannot find any "thank you very much for that appropriate help" or similar. Why not? Its poor. Dont know why.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: ? Remote dev ?

Postby intellilogic » 02. August 2014 12:07

Your not looking hard enough, because it's been there the whole time in the tittle ;)
"Resolved - Thanks Nobbie :)"
intellilogic
 
Posts: 6
Joined: 31. July 2014 16:30
Operating System: Windows Server 2012


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests