h264 streaming not working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

H264 streaming wont work

Postby Zoo School » 15. July 2014 23:32

I am using the following to serve html content locally for education programmes over a WiFi network.
- XAMPP 1.8.2-3 / Apache 2.4
- 32 bit Windows XP computer
- Visual C++ 2008 Redist installed
Much of the material is short videos which I have encoded as .mp4 and these download fine but it would be faster and more useable to stream instead.

I have;
extracted the precompiled mod_h264_streaming.so (from http://dl.dropbox.com/u/4602124/apache_mod_h264_streaming-2.2.7.zip) to c:\xampp\apache\modules
edited httpd.conf to add "LoadModule h264_streaming_module modules/mod_h264_streaming.so", "AddHandler h264-streaming.extensions .mp4"

BUT then the server will not restart, no error message is generated. Any ideas? Suggestions? Help?
User avatar
Zoo School
 
Posts: 4
Joined: 15. July 2014 23:15
Location: Christchurch, New Zealand
Operating System: Windows XP

Re: H264 streaming wont work

Postby JJ_Tagy » 16. July 2014 03:41

First, you should probably type in German if you post in the German part of the forums. Second, if you are truly running windows, that file will not do anything for you. http://www.fileinfo.com/extension/so

You should be looking for .dll files.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: H264 streaming wont work

Postby Zoo School » 17. July 2014 04:49

I didn't know there was an English area! will do.

now if .so was not applicable, none of XAMPP's Apache modules would load would they? Surely Id use the appropriate .dll for a Windows server not windows hosting an Apache server?
User avatar
Zoo School
 
Posts: 4
Joined: 15. July 2014 23:15
Location: Christchurch, New Zealand
Operating System: Windows XP

Re: h264 streaming not working

Postby gsmith » 17. July 2014 09:09

Depends says it's a Win32 DLL binary however I'm betting it's for Apache 2.2.x.
You could try this: https://www.apachehaus.net/modules/mod_h264_streaming/
specifcally, mod_h264_streaming-2.2.7-2.4.x-x86.zip
gsmith
 
Posts: 194
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP version: 0.0.0
Operating System: Win XP to 2012R2/VS 6,9,11,14

Re: h264 streaming not working

Postby Zoo School » 17. July 2014 21:58

GSmith - you are my savior! Thank you so so so so (pun intended) much
That has done the trick.
User avatar
Zoo School
 
Posts: 4
Joined: 15. July 2014 23:15
Location: Christchurch, New Zealand
Operating System: Windows XP


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests