i need solution

Problems with the Windows version of XAMPP, questions, comments, and anything related.

i need solution

Postby kingjames » 11. July 2014 19:17

i have this error after i install xampp 1.8.3. Please help me out.Thanks

5:49:40 PM [main] Initializing Control Panel
5:49:40 PM [main] Windows Version: Windows 7 Ultimate SP1 32-bit
5:49:40 PM [main] XAMPP Version: 1.8.3
5:49:40 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
5:49:40 PM [main] You are not running with administrator rights! This will work for
5:49:40 PM [main] most application stuff but whenever you do something with services
5:49:40 PM [main] there will be a security dialogue or things will break! So think
5:49:40 PM [main] about running this application with administrator rights!
5:49:40 PM [main] XAMPP Installation Directory: "c:\xam\"
5:49:40 PM [main] Checking for prerequisites
5:50:23 PM [main] All prerequisites found
5:50:23 PM [main] Initializing Modules
5:50:23 PM [Apache] Problem detected!
5:50:23 PM [Apache] Port 80 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 568!
5:50:23 PM [Apache] Apache WILL NOT start without the configured ports free!
5:50:23 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:50:23 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:50:23 PM [Apache] Problem detected!
5:50:23 PM [Apache] Port 443 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 568!
5:50:23 PM [Apache] Apache WILL NOT start without the configured ports free!
5:50:23 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:50:23 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:50:23 PM [mysql] MySQL Service detected with wrong path
5:50:23 PM [mysql] Change XAMPP MySQL and Control Panel settings or
5:50:23 PM [mysql] Uninstall/disable the other service manually first
5:50:23 PM [mysql] Found Path: c:\xampp\mysql\bin\mysqld.exe --defaults-file=c:\xampp\mysql\bin\my.cnf mysql
5:50:23 PM [mysql] Expected Path: c:\xam\mysql\bin\mysqld.exe --defaults-file=c:\xam\mysql\bin\my.ini mysql
5:50:23 PM [mysql] Problem detected!
5:50:23 PM [mysql] Port 3306 in use by "c:\xampp\mysql\bin\mysqld.exe --defaults-file=c:\xampp\mysql\bin\my.cnf mysql"!
5:50:23 PM [mysql] MySQL WILL NOT start without the configured ports free!
5:50:23 PM [mysql] You need to uninstall/disable/reconfigure the blocking application
5:50:23 PM [mysql] or reconfigure MySQL and the Control Panel to listen on a different port
5:50:23 PM [main] Starting Check-Timer
5:50:23 PM [main] Control Panel Ready
5:50:37 PM [Apache] Problem detected!
5:50:37 PM [Apache] Port 80 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 568!
5:50:37 PM [Apache] Apache WILL NOT start without the configured ports free!
5:50:37 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:50:37 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:50:37 PM [Apache] Problem detected!
5:50:37 PM [Apache] Port 443 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 568!
5:50:37 PM [Apache] Apache WILL NOT start without the configured ports free!
5:50:37 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:50:37 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:50:37 PM [Apache] Attempting to start Apache app...
5:50:38 PM [Apache] Status change detected: running
5:50:41 PM [Apache] Status change detected: stopped
5:50:41 PM [Apache] Error: Apache shutdown unexpectedly.
5:50:41 PM [Apache] This may be due to a blocked port, missing dependencies,
5:50:41 PM [Apache] improper privileges, a crash, or a shutdown by another method.
5:50:41 PM [Apache] Press the Logs button to view error logs and check
5:50:41 PM [Apache] the Windows Event Viewer for more clues
5:50:41 PM [Apache] If you need more help, copy and post this
5:50:41 PM [Apache] entire log window on the forums
5:53:39 PM [Apache] Problem detected!
5:53:39 PM [Apache] Port 80 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 568!
5:53:39 PM [Apache] Apache WILL NOT start without the configured ports free!
5:53:39 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:53:39 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:53:39 PM [Apache] Problem detected!
5:53:39 PM [Apache] Port 443 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 568!
5:53:39 PM [Apache] Apache WILL NOT start without the configured ports free!
5:53:39 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:53:39 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:53:39 PM [Apache] Attempting to start Apache app...
5:53:39 PM [Apache] Status change detected: running
5:53:39 PM [Apache] Status change detected: stopped
5:53:39 PM [Apache] Error: Apache shutdown unexpectedly.
5:53:39 PM [Apache] This may be due to a blocked port, missing dependencies,
5:53:39 PM [Apache] improper privileges, a crash, or a shutdown by another method.
5:53:39 PM [Apache] Press the Logs button to view error logs and check
5:53:39 PM [Apache] the Windows Event Viewer for more clues
5:53:39 PM [Apache] If you need more help, copy and post this
5:53:39 PM [Apache] entire log window on the forums
5:53:45 PM [mysql] Problem detected!
5:53:45 PM [mysql] Port 3306 in use by "c:\xampp\mysql\bin\mysqld.exe --defaults-file=c:\xampp\mysql\bin\my.cnf mysql"!
5:53:45 PM [mysql] MySQL WILL NOT start without the configured ports free!
5:53:45 PM [mysql] You need to uninstall/disable/reconfigure the blocking application
5:53:45 PM [mysql] or reconfigure MySQL and the Control Panel to listen on a different port
5:53:45 PM [mysql] Attempting to start MySQL service...
5:54:28 PM [Apache] Problem detected!
5:54:28 PM [Apache] Port 80 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 568!
5:54:28 PM [Apache] Apache WILL NOT start without the configured ports free!
5:54:28 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:54:28 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:54:28 PM [Apache] Problem detected!
5:54:28 PM [Apache] Port 443 in use by ""c:\xampp\apache\bin\httpd.exe" -k runservice" with PID 568!
5:54:28 PM [Apache] Apache WILL NOT start without the configured ports free!
5:54:28 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:54:28 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:54:28 PM [Apache] Attempting to start Apache app...
5:54:28 PM [Apache] Status change detected: running
5:54:29 PM [Apache] Status change detected: stopped
5:54:29 PM [Apache] Error: Apache shutdown unexpectedly.
5:54:29 PM [Apache] This may be due to a blocked port, missing dependencies,
5:54:29 PM [Apache] improper privileges, a crash, or a shutdown by another method.
5:54:29 PM [Apache] Press the Logs button to view error logs and check
5:54:29 PM [Apache] the Windows Event Viewer for more clues
5:54:29 PM [Apache] If you need more help, copy and post this
5:54:29 PM [Apache] entire log window on the forums
kingjames
 
Posts: 5
Joined: 11. July 2014 19:08
Operating System: windows

Re: i need solution

Postby JJ_Tagy » 11. July 2014 20:00

Looks like you are running them as services AND trying to start them from the control panel. Also, you aren't running with admin rights.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: i need solution

Postby kingjames » 12. July 2014 11:22

So , what do i do to overcome my challenge
kingjames
 
Posts: 5
Joined: 11. July 2014 19:08
Operating System: windows

Re: i need solution

Postby JJ_Tagy » 12. July 2014 15:21

If that is your problem, then run the control panel with admin rights and don't try to start Apache/mysql if you leave the services on.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: i need solution

Postby kingjames » 14. July 2014 14:20

Ok,thanks for your reply but how do i go about it ? I mean how to run the control panel with admin rights, the process please?
kingjames
 
Posts: 5
Joined: 11. July 2014 19:08
Operating System: windows

Re: i need solution

Postby JJ_Tagy » 14. July 2014 15:13

JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests