Apache Disabled [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Disabled [SOLVED]

Postby MandeeD » 02. July 2014 15:37

Apache in XAMPP was going great and then the next time I started it, Apache wouldn't start. It would attempt to start, and then say Apache could not start. Now, the Apache button has been completely disabled and the control panel says:

9:42:07 AM [main] XAMPP Installation Directory: "f:\xampp\"
9:42:07 AM [main] Checking for prerequisites
9:42:08 AM [main] All prerequisites found
9:42:08 AM [main] Initializing Modules
9:42:08 AM [Apache] Problem detected: Apache Not Found!
9:42:08 AM [Apache] Disabling Apache buttons
9:42:08 AM [Apache] Run this program from your XAMPP root directory!
9:42:08 AM [main] Starting Check-Timer
9:42:08 AM [main] Control Panel Ready

The error.log for Apache did not say anything useful. I have been searching for answers for a couple days and still cannot figure out what is wrong. Port 80 is not the issue. Any help would be much appreciated!
Last edited by MandeeD on 03. July 2014 14:52, edited 1 time in total.
MandeeD
 
Posts: 6
Joined: 02. July 2014 15:32
Operating System: Windows 7

Re: Apache Disabled Even Though it Worked Fine the Other Day

Postby Altrea » 02. July 2014 16:26

Is XAMPP still installed at path "f:\xampp\"?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8288
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache Disabled Even Though it Worked Fine the Other Day

Postby MandeeD » 02. July 2014 16:30

I moved it to a flash drive temporarily, but the problem still occurred at path "c:\xampp\"
MandeeD
 
Posts: 6
Joined: 02. July 2014 15:32
Operating System: Windows 7

Re: Apache Disabled Even Though it Worked Fine the Other Day

Postby MandeeD » 02. July 2014 16:33

Altrea wrote:Is XAMPP still installed at path "f:\xampp\"?

I moved it to a flash drive temporarily, but the problem still occurred at path "c:\xampp\"
MandeeD
 
Posts: 6
Joined: 02. July 2014 15:32
Operating System: Windows 7

Re: Apache Disabled Even Though it Worked Fine the Other Day

Postby Altrea » 02. July 2014 16:33

execute the \xampp\setup_xampp.bat script to correct the paths
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8288
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache Disabled Even Though it Worked Fine the Other Day

Postby MandeeD » 02. July 2014 16:38

Altrea wrote:execute the \xampp\setup_xampp.bat script to correct the paths

Ran that, and the Apache Start button is still disabled.
MandeeD
 
Posts: 6
Joined: 02. July 2014 15:32
Operating System: Windows 7

Re: Apache Disabled Even Though it Worked Fine the Other Day

Postby Altrea » 02. July 2014 16:49

Restart the xampp control panel, try to start apache (if possible) and post (copy&paste) us the full contents of the log window
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8288
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache Disabled Even Though it Worked Fine the Other Day

Postby MandeeD » 02. July 2014 16:57

Altrea wrote:Restart the xampp control panel, try to start apache (if possible) and post (copy&paste) us the full contents of the log window

The Start button for Apache is completely disabled so it will not start. Even when running as administrator, the Service check box is also disabled. The Control Panel says this:
Code: Select all
11:57:26 AM  [main]    Initializing Control Panel
11:57:26 AM  [main]    Windows Version: Windows 7 Home Premium SP1 64-bit
11:57:26 AM  [main]    XAMPP Version: 1.8.2
11:57:26 AM  [main]    Control Panel Version: 3.2.1  [ Compiled: May 7th 2013 ]
11:57:26 AM  [main]    Running with Administrator rights - good!
11:57:26 AM  [main]    XAMPP Installation Directory: "f:\xampp\"
11:57:26 AM  [main]    Checking for prerequisites
11:57:26 AM  [main]    All prerequisites found
11:57:26 AM  [main]    Initializing Modules
11:57:26 AM  [Apache]    Problem detected: Apache Not Found!
11:57:26 AM  [Apache]    Disabling Apache buttons
11:57:26 AM  [Apache]    Run this program from your XAMPP root directory!
11:57:26 AM  [main]    Starting Check-Timer
11:57:26 AM  [main]    Control Panel Ready

None of Apache's logs are recording any error information.
MandeeD
 
Posts: 6
Joined: 02. July 2014 15:32
Operating System: Windows 7

Re: Apache Disabled Even Though it Worked Fine the Other Day

Postby MandeeD » 03. July 2014 14:52

Fixed it! Somehow my httdp.exe file was gone. So I replaced it and moved the xampp folder back to my C: drive, and then redirected the files once again. So far so good!
MandeeD
 
Posts: 6
Joined: 02. July 2014 15:32
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests