Tomcat Started/Stopped with errors, return code: 255

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Tomcat Started/Stopped with errors, return code: 255

Postby efoertsch » 20. June 2014 17:11

I am new with XAMPP. I have Apache and MySQL running OK. When I click to start Tomcat, I get the following:

11:58:26 AM [Tomcat] Tomcat Started/Stopped with errors, return code: 255
11:58:26 AM [Tomcat] Make sure you have Java JDK or JRE installed and the required ports are free
11:58:26 AM [Tomcat] Check the "/xampp/tomcat/logs" folder for more information

There is nothing in /xampp/tomcat/logs (other than NOTEMPTY file). I did see where Skype can interfere but I made sure it isn't running.
I am usıng XAMPP 1.8.2, Java - jdk1.6.0_45

Any suggestions?

Thanks

Eric

Update
I haven't completely solved my problem yet but I think part of the problem is that I needed to append C:\Windows\System32\ in front of reg and find commands in catalina_start.bat and (I presume) catalina_stop.bat.

After doing this I can start Tomcat in a DOS window and then XAMPP Control Panel shows Tomcat started. But I can't start or stop Tomcat directly from the control panel. If I try to start Tomcat from the XAMPP control panel directly I still get the 255 error code. Clicking the stop button on the control panel does not stop the service. I can only stop it via doing Cntl C in the DOS window where I started it.

Update #2
I guess it (or I) just needed a good nights sleep - and a restart of the contol panel. Today Tomcat starts and stops from the XAMPP control panel OK. So for whatever reason, I needed to add the Windows path(noted in first update) to the reg and find programs so the catalina_start/stop batch files would run correctly. Or perhaps I need to update my environment variables. But at this point I am not going to argue with success.
efoertsch
 
Posts: 1
Joined: 20. June 2014 15:30
XAMPP Version: 1.8.2-1
Operating System: Windows 8.1

Re: Tomcat Started/Stopped with errors, return code: 255

Postby Neelsk » 19. August 2014 17:39

Hi All
Please help. This is the first time I am trying to use Xampp. Everything installed fine on Windows server 2003 but Tomcat do not start and returns error code 1.
I have Java JDK installed. When I manually start the Catalina Start.bat file , Tomcat starts up. As soon as I close the Catalina script, Tomcat stops.
Neelsk
 
Posts: 1
Joined: 19. August 2014 16:54
XAMPP Version: 1.8.3
Operating System: Server 2003

Re: Tomcat Started/Stopped with errors, return code: 255

Postby Alex R4 » 20. August 2014 14:08

Hi There,
Have a look into xampp/tomcat/logs directory.
There are two log files you can look at: catalina_date.log and localhost_access_log.date.txt
These log files can give you an idea where the problem is.

On my machine I don't use tomcat with xampp. When I saw your post I just tried it out. It worked out of the box with no modification at all.
Alex R4
 
Posts: 22
Joined: 08. April 2014 11:24
Location: Adelaide/Australia
XAMPP Version: 1.8.2-1
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 69 guests