access Forbidden

Problems with the Windows version of XAMPP, questions, comments, and anything related.

access Forbidden

Postby joe.private00 » 18. June 2014 05:38

Hi there,

I just got an error on my xammp where I trying to access my phpadmin it shows " Access Forbidden new xammp security concept..bla..bla bla error 403 "
Does any one know how o fix it?

Thanks,

Joe
joe.private00
 
Posts: 10
Joined: 18. June 2014 05:14
Operating System: Windows 8

Re: access Forbidden

Postby Altrea » 18. June 2014 05:43

Hi Joe,

joe.private00 wrote:Does any one know how o fix it?

Yes, you need to do bla bla bla and after that you should see bla bla bla...

We do not have enough information to help you.
[FGA]Insufficient debug information

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: access Forbidden

Postby joe.private00 » 19. June 2014 09:26

The Full Information actually like this :

Access forbidden!

New XAMPP security concept:

Access to the requested directory is only available from the local network.

This setting can be configured in the file "httpd-xampp.conf".

If you think this is a server error, please contact the webmaster.

Error 403

127.0.0.1
Apache/2.4.7 (Win32) OpenSSL/1.0.1e PHP/5.5.6

Thx
joe.private00
 
Posts: 10
Joined: 18. June 2014 05:14
Operating System: Windows 8

Re: access Forbidden

Postby Altrea » 19. June 2014 10:48

We still do not have enough information.
What Do you type in your browser?
What does your apache log files say?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: access Forbidden

Postby joe.private00 » 20. June 2014 02:56

I do it by firefox, Opera, Chrome, and Internet Explorer the result is same. Where is apache log? and how do I read it ?

thanks
joe.private00
 
Posts: 10
Joined: 18. June 2014 05:14
Operating System: Windows 8

Re: access Forbidden

Postby joe.private00 » 23. June 2014 03:01

Do you have the core of problems? Or are there any other solution? perhaps switch into another Xammp (lower version)? but how do I export database?

thx
joe.private00
 
Posts: 10
Joined: 18. June 2014 05:14
Operating System: Windows 8

Re: access Forbidden

Postby Altrea » 23. June 2014 05:09

joe.private00 wrote:Do you have the core of problems?

The core of these problems very commonly are unexperienced users.

We cannot help you if you don't answer my questions correct. So i repeat:
What Do you type in your browsers address bar to get this result?

You can find the requested log files by clicking the Logs Button in your XAMPP control panel.
We need the contents of the access.log and the error.log
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: access Forbidden

Postby joe.private00 » 23. June 2014 09:19

from browser I call it by typing :

http://localhost/phpmyadmin

On The Xammp error says " [Mon Jun 23 03:17:03.003045 2014] [authz_core:error] [pid 4252:tid 1696] [client ::1:65410] AH01630: client denied by server configuration: D:/xampp/phpMyAdmin "
(on the last line )

On the


thx
joe.private00
 
Posts: 10
Joined: 18. June 2014 05:14
Operating System: Windows 8

Re: access Forbidden

Postby Altrea » 23. June 2014 11:31

We need the entry it this specific request from your access.log too
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: access Forbidden

Postby joe.private00 » 24. June 2014 04:18

access log:

::1 - - [23/Jun/2014:04:26:43 -0500] "GET /mcmo/ HTTP/1.1" 200 19673 "http://localhost/mcmo/" "Mozilla/5.0 (Windows NT 6.3; rv:30.0) Gecko/20100101 Firefox/30.0"
::1 - - [23/Jun/2014:04:40:48 -0500] "GET /mcmo/ HTTP/1.1" 200 19673 "http://localhost/mcmo/" "Mozilla/5.0 (Windows NT 6.3; rv:30.0) Gecko/20100101 Firefox/30.0"
::1 - - [23/Jun/2014:04:54:47 -0500] "GET /mcmo/ HTTP/1.1" 200 19673 "http://localhost/mcmo/" "Mozilla/5.0 (Windows NT 6.3; rv:30.0) Gecko/20100101 Firefox/30.0"
::1 - - [23/Jun/2014:05:08:45 -0500] "GET /mcmo/ HTTP/1.1" 200 19673 "http://localhost/mcmo/" "Mozilla/5.0 (Windows NT 6.3; rv:30.0) Gecko/20100101 Firefox/30.0"
::1 - - [23/Jun/2014:22:18:36 -0500] "GET /phpmyadmin HTTP/1.1" 403 1199 "-" "Mozilla/5.0 (Windows NT 6.3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1847.116 Safari/537.36"
joe.private00
 
Posts: 10
Joined: 18. June 2014 05:14
Operating System: Windows 8

Re: access Forbidden

Postby Nobbie » 24. June 2014 11:33

Did you change anything in your Xampp/Apache configuration?

What is Drive D:?

The errorcode 403 usually means, that Apache cannot read the folder (or file) due to missing rights in the filesystem. In that case D:/xampp/phpMyAdmin cannot be read by Apache (i.e. the User, which runs Apache).

It is on you to find out, why this happens. There must be something wrong with D:/Xampp/phpMyAdmin
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: access Forbidden

Postby joe.private00 » 25. June 2014 04:19

I don't change the configuration. D:\XAMPP is the directory that first time I Installed. The Default is C:\XAMMP but I change it into Drive D:
joe.private00
 
Posts: 10
Joined: 18. June 2014 05:14
Operating System: Windows 8

Re: access Forbidden

Postby joe.private00 » 30. June 2014 04:03

NO..Solution? I must find my own way out..

thx,
joe.private00
 
Posts: 10
Joined: 18. June 2014 05:14
Operating System: Windows 8

Re: access Forbidden

Postby Altrea » 30. June 2014 12:02

It is difficult to help you because we don't know your configuration.
On my fresh XAMPP 1.8.3.3 test environment the access.log for that request looks like this:
::1 - - [30/Jun/2014:12:55:15 +0200] "GET /phpmyadmin HTTP/1.1" 301 334 "-" "Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36"
::1 - - [30/Jun/2014:12:55:15 +0200] "GET /phpmyadmin/ HTTP/1.1" 200 56111 "-" "Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36"

As you can see, if you request the phpmyadmin location without a trailing slash, there is a redirect acting (Statuscode 301 - moved permanently) that will route to /phpmyadmin/ (with trailing slash).
That is not the case on your environment, so the configuration must be different.

Maybe you should start to show us your configuration, for example your \xampp\apache\conf\extra\httpd-xampp.conf file beginning with line 100 (phpmyadmin alias) up to the end.
If you have defined any access rules we need to know them too, or if you have changed any existing Apache configuration.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: access Forbidden

Postby joe.private00 » 01. July 2014 04:27

This is the complete of the file please show me which one is wrong..thanks...

#
# XAMPP settings
#

<IfModule env_module>
SetEnv MIBDIRS "D:/xampp/php/extras/mibs"
SetEnv MYSQL_HOME "\\xampp\\mysql\\bin"
SetEnv OPENSSL_CONF "D:/xampp/apache/bin/openssl.cnf"
SetEnv PHP_PEAR_SYSCONF_DIR "\\xampp\\php"
SetEnv PHPRC "\\xampp\\php"
SetEnv TMP "\\xampp\\tmp"
</IfModule>

#
# PHP-Module setup
#
LoadFile "D:/xampp/php/php5ts.dll"
LoadModule php5_module "D:/xampp/php/php5apache2_4.dll"

<FilesMatch "\.php$">
SetHandler application/x-httpd-php
</FilesMatch>
<FilesMatch "\.phps$">
SetHandler application/x-httpd-php-source
</FilesMatch>

#
# PHP-CGI setup
#
#<FilesMatch "\.php$">
# SetHandler application/x-httpd-php-cgi
#</FilesMatch>
#<IfModule actions_module>
# Action application/x-httpd-php-cgi "/php-cgi/php-cgi.exe"
#</IfModule>


<IfModule php5_module>
PHPINIDir "D:/xampp/php"
</IfModule>

<IfModule mime_module>
AddType text/html .php .phps
</IfModule>

ScriptAlias /php-cgi/ "D:/xampp/php/"
<Directory "D:/xampp/php">
AllowOverride None
Options None
Require all denied
<Files "php-cgi.exe">
Require all granted
</Files>
</Directory>

<Directory "D:/xampp/cgi-bin">
<FilesMatch "\.php$">
SetHandler cgi-script
</FilesMatch>
<FilesMatch "\.phps$">
SetHandler None
</FilesMatch>
</Directory>

<Directory "D:/xampp/htdocs/xampp">
<IfModule php5_module>
<Files "status.php">
php_admin_flag safe_mode off
</Files>
</IfModule>
AllowOverride AuthConfig
</Directory>

<IfModule alias_module>
Alias /security "D:/xampp/security/htdocs/"
<Directory "D:/xampp/security/htdocs">
<IfModule php5_module>
<Files "xamppsecurity.php">
php_admin_flag safe_mode off
</Files>
</IfModule>
AllowOverride AuthConfig
Require all granted
</Directory>

Alias /licenses "D:/xampp/licenses/"
<Directory "D:/xampp/licenses">
Options +Indexes
<IfModule autoindex_color_module>
DirectoryIndexTextColor "#000000"
DirectoryIndexBGColor "#f8e8a0"
DirectoryIndexLinkColor "#bb3902"
DirectoryIndexVLinkColor "#bb3902"
DirectoryIndexALinkColor "#bb3902"
</IfModule>
Require all granted
</Directory>

Alias /phpmyadmin "D:/xampp/phpMyAdmin/"
<Directory "D:/xampp/phpMyAdmin">
AllowOverride AuthConfig
Require all granted
</Directory>

Alias /webalizer "D:/xampp/webalizer/"
<Directory "D:/xampp/webalizer">
<IfModule php5_module>
<Files "webalizer.php">
php_admin_flag safe_mode off
</Files>
</IfModule>
AllowOverride AuthConfig
Require all granted
</Directory>
</IfModule>

#
# New XAMPP security concept
#
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
Order deny,allow

Deny from all
Allow from ::1 127.0.0.0/8 \
fc00::/7 10.0.0.0/8 172.16.0.0/12 192.168.0.0/16 \
fe80::/10 169.254.0.0/16

ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</LocationMatch>
joe.private00
 
Posts: 10
Joined: 18. June 2014 05:14
Operating System: Windows 8

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests