Ap0ache locked to port 443 after changing port nmbr

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Ap0ache locked to port 443 after changing port nmbr

Postby nextenso » 10. June 2014 12:45

Hi, new to Apache. please can someone help.

After installing Xampp 1.8.3-4 I can't start Apache. I have a programme called Akruto Sync that uses port 80 and 443 which can not be re-configured.

Following instructions given, I changed the 2 Apache files from port 80 to 8080 (in both places) and port 443 to 4444 (also tried 4433). Apache continues to say it needs ports 80 and 443. MySql, Filezilla and Tomcat start ok. I tried closing down and re-starting.

I use Avast anti-virus and firewall. Win 7 has all latests updates.

Here is the log entry shown in the control panel window. - also this data is not showing in the Apache log files. Only the install log has data in it. I tried starting new files in the two not containing any data, still no log entries.

12:17:46 [main] Control Panel Ready
12:17:57 [Apache] Problem detected!
12:17:57 [Apache] Port 80 in use by "C:\Program Files\Akruto\AkrutoSync.exe" with PID 4772!
12:17:57 [Apache] Apache WILL NOT start without the configured ports free!
12:17:57 [Apache] You need to uninstall/disable/reconfigure the blocking application
12:17:57 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
12:17:57 [Apache] Problem detected!
12:17:57 [Apache] Port 443 in use by "C:\Program Files\Akruto\AkrutoSync.exe" with PID 4772!
12:17:57 [Apache] Apache WILL NOT start without the configured ports free!
12:17:57 [Apache] You need to uninstall/disable/reconfigure the blocking application
12:17:57 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
12:17:57 [Apache] Attempting to start Apache app...
12:17:57 [Apache] Status change detected: running
12:17:59 [Apache] Status change detected: stopped
12:17:59 [Apache] Error: Apache shutdown unexpectedly.
12:17:59 [Apache] This may be due to a blocked port, missing dependencies,
12:17:59 [Apache] improper privileges, a crash, or a shutdown by another method.
12:17:59 [Apache] Press the Logs button to view error logs and check
12:17:59 [Apache] the Windows Event Viewer for more clues
12:17:59 [Apache] If you need more help, copy and post this
12:17:59 [Apache] entire log window on the forums
Rgds Jonathan
nextenso
 
Posts: 1
Joined: 10. June 2014 12:21
Operating System: win7 64bit

Re: Ap0ache locked to port 443 after changing port nmbr

Postby Nobbie » 10. June 2014 13:54

nextenso wrote:Following instructions given, I changed the 2 Apache files from port 80 to 8080 (in both places) and port 443 to 4444 (also tried 4433).


Please explain more precisely, which files you changed (we need the filenames and the full path) and what you did change (show code).

P.S.: Anyway, it is only the worst "solution" to change Apache ports, as Port 80 and 443 are the default Ports for HTTP and HTTPS. If you change these in your installation, you always have to apply the port number in all local URLs (like http://localhost:8080/test/index.html or https://localhost:4444/another/test), which may also cause problems with standard software products like Wordpress, Joomla etc.

It is not a good idea, to change the Apache Ports. If you really cannot run Akruto on another Port, you should think about stopping Akruto, while running Apache. I dont think there is a need to run both of them always at the same time. Finally, you should think about installing Apache on a different PC.
Nobbie
 
Posts: 8767
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 42 guests