Access network

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Access network

Postby devFR » 22. May 2014 11:41

Hello,

I explain my problem, when I used my intranet on network, it's impossible to execute a task on page PHP ( execute form after send in textbox), but on localhost I need problem to execute this script.
Before I have problem access in folder "htdocs/xampp", he can a login and password and I have a problem to acces to Phpmyadmin.

I resolved this 2 problems with file : httpd-xampp.conf

But I don't resolved for my folder contain a website.

Xampp : 1.8.1
OS. Windows Server 2012 R2
Xampp control panel : 3.2.1

I need you help.
Thank you.

Sorry for my english.
devFR
 
Posts: 2
Joined: 22. May 2014 11:27
XAMPP Version: 1.8.3-1
Operating System: Windows Server 2012 R2

Re: Access network

Postby Nobbie » 22. May 2014 12:31

devFR wrote:Sorry for my english.


Sorry, but this is really to hard to understand. Either write in your native language and/or try to use Google translator or similar.
Nobbie
 
Posts: 6992
Joined: 09. March 2008 13:04

Re: Access network

Postby devFR » 22. May 2014 12:59

Sorry,

I can not run my php pages with xamp network, while in my local pages work.
I edit the httpd-xampp.conf file but I can not run my pages.
Do you have an idea or could it come?
By modifying this file I happened to run phpmyadmin and access to xamp htdocs folder without login.

my file :
Code: Select all
#
# XAMPP settings
#

<IfModule env_module>
    SetEnv MIBDIRS "D:/xampp/php/extras/mibs"
    SetEnv MYSQL_HOME "\\xampp\\mysql\\bin"
    SetEnv OPENSSL_CONF "D:/xampp/apache/bin/openssl.cnf"
    SetEnv PHP_PEAR_SYSCONF_DIR "\\xampp\\php"
    SetEnv PHPRC "\\xampp\\php"
    SetEnv TMP "\\xampp\\tmp"
</IfModule>

#
# PHP-Module setup
#
LoadFile "D:/xampp/php/php5ts.dll"
LoadFile "D:/xampp/php/libpq.dll"
LoadModule php5_module "D:/xampp/php/php5apache2_4.dll"

<FilesMatch "\.php$">
    SetHandler application/x-httpd-php
</FilesMatch>
<FilesMatch "\.phps$">
    SetHandler application/x-httpd-php-source
</FilesMatch>

#
# PHP-CGI setup
#
#<FilesMatch "\.php$">
#    SetHandler application/x-httpd-php-cgi
#</FilesMatch>
#<IfModule actions_module>
#    Action application/x-httpd-php-cgi "/php-cgi/php-cgi.exe"
#</IfModule>


<IfModule php5_module>
    PHPINIDir "D:/xampp/php"
</IfModule>

<IfModule mime_module>
    AddType text/html .php .phps
</IfModule>

ScriptAlias /php-cgi/ "D:/xampp/php/"
<Directory "D:/xampp/php">
    AllowOverride None
    Options None
    Require all denied
    <Files "php-cgi.exe">
          Require all granted
    </Files>
</Directory>

<Directory "D:/xampp/cgi-bin">
    <FilesMatch "\.php$">
        SetHandler cgi-script
    </FilesMatch>
    <FilesMatch "\.phps$">
        SetHandler None
    </FilesMatch>
</Directory>

<Directory "D:/xampp/htdocs/xampp">
    <IfModule php5_module>
       <Files "status.php">
          php_admin_flag safe_mode off
       </Files>
    </IfModule>
    AllowOverride AuthConfig
    Require all granted
</Directory>


<Directory "D:/xampp/htdocs/test">
    <IfModule php5_module>
       <Files "form-insert-user.php">
          php_admin_flag safe_mode off
       </Files>
    </IfModule>
    AllowOverride AuthConfig
    Require all granted
</Directory>

<IfModule alias_module>
    Alias /security "D:/xampp/security/htdocs/"
    <Directory "D:/xampp/security/htdocs">
        <IfModule php5_module>
          <Files "xamppsecurity.php">
             php_admin_flag safe_mode off
          </Files>
        </IfModule>
        AllowOverride AuthConfig
   </Directory>

    Alias /licenses "D:/xampp/licenses/"
    <Directory "D:/xampp/licenses">
        Options +Indexes
        <IfModule autoindex_color_module>
            DirectoryIndexTextColor  "#000000"
            DirectoryIndexBGColor "#f8e8a0"
            DirectoryIndexLinkColor "#bb3902"
            DirectoryIndexVLinkColor "#bb3902"
            DirectoryIndexALinkColor "#bb3902"
        </IfModule>
        Require all granted
   </Directory>

    Alias /phpmyadmin "D:/xampp/phpMyAdmin/"
    <Directory "D:/xampp/phpMyAdmin">
        AllowOverride AuthConfig
        Require all granted
    </Directory>
   
   Alias /xampp "D:/xampp/htdocs/xampp"
    <Directory "D:/xampp/htdocs/xampp">
        AllowOverride AuthConfig
        Require all granted
    </Directory>
   
   Alias /test "D:/xampp/htdocs/test"
    <Directory "D:/xampp/htdocs/test">
        AllowOverride AuthConfig
        Require all granted
    </Directory>
   
    Alias /webalizer "D:/xampp/webalizer/"
    <Directory "D:/xampp/webalizer">
        <IfModule php5_module>
          <Files "webalizer.php">
             php_admin_flag safe_mode off
          </Files>
        </IfModule>
        AllowOverride AuthConfig
        Require all granted
    </Directory>
</IfModule>

#
# New XAMPP security concept
#
<LocationMatch "^/(?i:(?:xampp|test|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
        Order deny,allow
       Allow from ::1 127.0.0.0/8
   Allow from all
   ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</LocationMatch>


Thank you.
devFR
 
Posts: 2
Joined: 22. May 2014 11:27
XAMPP Version: 1.8.3-1
Operating System: Windows Server 2012 R2


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 40 guests