PHP Mongo with XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP Mongo with XAMPP

Postby jacobm001 » 14. May 2014 19:29

I'm trying to install php_mongo, but I'm getting an odd error. According to my php_about() output I need php_mongo-1.5.2-5.4-vc9.dll, but it won't load in the XAMPP framework. When starting Apache I get the message, "PHP Startup: Unable to load dynamic library "\xampp\php\ext\php_mongo...' - %1 is not a valid Win32 application.

Any idea what causes this?
jacobm001
 
Posts: 1
Joined: 14. May 2014 19:26
XAMPP Version: 1.8.3
Operating System: Windows 7

Re: PHP Mongo with XAMPP

Postby Nobbie » 15. May 2014 09:32

jacobm001 wrote:I'm trying to install php_mongo, but I'm getting an odd error. According to my php_about() output I need php_mongo-1.5.2-5.4-vc9.dll


What is "php_about()"?

Anyway, you cannot extend Xampp/PHP with a foreign DLL (the error message is quite typical), if it is not delivered out of the box, you have build one from scratch. You need the Xampp Development Package (i dont know if this is still available, it has been formerly), you need the source package of php_mongo, you need the appropriate Microsoft C Compiler (i.e. Visual C 9) and a projekt file.

This is a unfortunately an experts job and not easy to maintain. Therefore Xampp/PHP comes precompiled with a lot of extensions already built in, did you check if php_mongo is missing?
Nobbie
 
Posts: 6653
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests