XAMPP not checking for wordpress plugin updates

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP not checking for wordpress plugin updates

Postby IceDarkness » 11. May 2014 09:16

I seem to be having a weird problem with XAMPP and wordpress. Since the new versions, it will no longer check for plugin updates and instead gives this error at the top of the page:

Warning: Invalid argument supplied for foreach() in \wordpress\wp-includes\update.php on line 295

The code in the file is this:

Code: Select all
   $response = json_decode( wp_remote_retrieve_body( $raw_response ), true );
   foreach ( $response['plugins'] as &$plugin ) {
      $plugin = (object) $plugin;
   }


Works fine on the server, just not in xampp.
IceDarkness
 
Posts: 2
Joined: 11. May 2014 09:13
XAMPP Version: 5.5.19
Operating System: Windows 7

Re: XAMPP not checking for wordpress plugin updates

Postby Altrea » 11. May 2014 20:04

Wordpress issue, you should ask that at a wordpress support board.
Very common the used Wordpress version is not able to run on the PHP version you are using (your Live Server very common uses a different version).
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6946
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: XAMPP not checking for wordpress plugin updates

Postby IceDarkness » 15. May 2014 16:59

Yeah, looks like my server is running PHP 5.4.23 and xampp is 5.5.11.
IceDarkness
 
Posts: 2
Joined: 11. May 2014 09:13
XAMPP Version: 5.5.19
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 26 guests