"localhost/security" not working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

"localhost/security" not working

Postby WhiteHatSkiddie » 25. April 2014 05:47

The following error occurs
Warning: include(lang/1%00'=1.php): failed to open stream: No such file or directory in C:\xampp\security\htdocs\index.php on line 12

Warning: include(): Failed opening 'lang/1%00'=1.php' for inclusion (include_path='.;C:\xampp\php\PEAR') in C:\xampp\security\htdocs\index.php on line 12


Here is the code for index.php
Code: Select all
<?php
   if (file_get_contents("lang.tmp") == "") {
      header("Location: splash.php");
      exit;
   }
?>

<html>
   <head>
      <meta name="author" content="Kai Oswald Seidler, Kay Vogelgesang, Carsten Wiedmann">
      <link rel="icon" href="img/xampp.ico">
      <?php include "lang/".file_get_contents("lang.tmp").".php"; ?>
      <title><?php echo $TEXT['global-xampp']; ?> | Security Section</title>
   </head>

   <frameset rows="68,*" border="0" framespacing="0">
      <frame name="head" src="head.php" frameborder="0" scrolling="no">
      <frameset cols="170,*" border="0" framespacing="0">
         <frame name="navi" src="navi.php" frameborder="0" scrolling="auto">
         <frame name="content" src="security.php" frameborder="0" marginwidth="20">
      </frameset>
   </frameset>
</html>

Basically i want to make a root password and an internet password when going into the localhost
I am using the xampp version 1.8.3-4
WhiteHatSkiddie
 
Posts: 1
Joined: 25. April 2014 05:41
XAMPP Version: 5.5.19
Operating System: Windows 8.1

Re: "localhost/security" not working

Postby brianlurie » 13. May 2014 23:12

in file -> lang.tmp write only en -> set up english language and all will be correct
brianlurie
 
Posts: 1
Joined: 13. May 2014 23:09
XAMPP Version: 5.5.19
Operating System: Windows 7 64-bit

Re: "localhost/security" not working

Postby Bamsen » 04. November 2014 17:51

Uhm.. What am i supposed to type?
Bamsen
 
Posts: 2
Joined: 04. November 2014 17:33
XAMPP Version: 1.8.0
Operating System: windows 8 and 7

Re: "localhost/security" not working

Postby Bamsen » 04. November 2014 17:52

brianlurie wrote:in file -> lang.tmp write only en -> set up english language and all will be correct

What am i supposed to write in lang.tmp?
Bamsen
 
Posts: 2
Joined: 04. November 2014 17:33
XAMPP Version: 1.8.0
Operating System: windows 8 and 7

Re: "localhost/security" not working

Postby Nobbie » 04. November 2014 20:21

en
Nobbie
 
Posts: 7035
Joined: 09. March 2008 13:04

Re: "localhost/security" not working

Postby Terry.Ryder » 13. May 2015 21:29

same issue.

contents of lang.tmp:

1%00'=1


How should complete contents read?
Terry.Ryder
 
Posts: 2
Joined: 13. May 2015 19:47
XAMPP Version: 5.6.3
Operating System: Windows 7 Home Premium

Re: "localhost/security" not working

Postby Terry.Ryder » 13. May 2015 21:32

Sorry, got it. Entire file contents are:

en

This is working.
Thanks.
Terry.Ryder
 
Posts: 2
Joined: 13. May 2015 19:47
XAMPP Version: 5.6.3
Operating System: Windows 7 Home Premium


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests