VirtualHosts wont serve webfonts

Problems with the Windows version of XAMPP, questions, comments, and anything related.

VirtualHosts wont serve webfonts

Postby greyfell » 21. April 2014 03:40

Hi, I have a working XAMPP portable install on Win7 64. I have sites that serve webfonts (*.ttf, *.woff, *.svg, etc.). If I drop the website inside of /htdocs and load it, I have no problems. However, when using the site with a VirtualHost, I get a 404 error on the webfonts. I've tried AddTypes in .htaccess, etc. but nothing. This is my vhost config:

Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
    DocumentRoot "C:\Portable Apps\_Internet Tools\XAMPP\htdocs"
    ServerName localhost
    ErrorLog "logs/localhost.error.log"
    CustomLog "logs/localhost.access.log" combined
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot "D:\Stuff\The Vault\Work\Tech\__Test Area\_test.local"
    ServerName test.local
    ErrorLog "logs/works.localhost.dev.error.log"
    CustomLog "logs/works.localhost.dev.access.log" combined
    <Directory "D:\Shane\The Vault\Work\Tech\__Test Area\_test.local">
        AllowOverride All
        Require all granted
        Options Indexes FollowSymLinks
    </Directory>
</VirtualHost>


Any help would be greatly appreciated...really ripping my hair out on this one!
greyfell
 
Posts: 2
Joined: 21. April 2014 03:33
Operating System: Win7 64

Re: VirtualHosts wont serve webfonts

Postby greyfell » 21. April 2014 04:03

Dear anyone else who is going crazy because of this: default XAMPP install has an alias in /apache/conf/extra/httpd-autoindex.conf for /icons/.
greyfell
 
Posts: 2
Joined: 21. April 2014 03:33
Operating System: Win7 64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests