XAMPP - Object not found! on any files/directories

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP - Object not found! on any files/directories

Postby f0xx » 19. April 2014 23:10

Hello,

I'm having a problem trying to install XAMPP on my Windows 7 machine. Essentially when I start apache and mysql the xampp index page (localhost) works fine. In my local file directory I have tried this:

In: C:\xampp\htdocs I've created a file called 'test.php' then in the Web Browser I have tried localhost/test.php and I get the 'Object not found!' error.

I have tried creating a directory called: C:\xampp\htdocs\oop then added a index file: C:\xampp\htdocs\oop\index.php

and in the Web Browser tried 'localhost/oop' and 'localhost/oop/index.php' but am receiving the same error.

My error log is:

[Sat Apr 19 22:09:09.742135 2014] [ssl:warn] [pid 3508:tid 260] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Apr 19 22:09:10.248164 2014] [ssl:warn] [pid 3508:tid 260] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Apr 19 22:09:10.346169 2014] [mpm_winnt:notice] [pid 3508:tid 260] AH00455: Apache/2.4.9 (Win32) OpenSSL/0.9.8y PHP/5.4.27 configured -- resuming normal operations
[Sat Apr 19 22:09:10.346169 2014] [mpm_winnt:notice] [pid 3508:tid 260] AH00456: Apache Lounge VC10 Server built: Mar 17 2014 11:15:11
[Sat Apr 19 22:09:10.346169 2014] [core:notice] [pid 3508:tid 260] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sat Apr 19 22:09:10.365170 2014] [mpm_winnt:notice] [pid 3508:tid 260] AH00418: Parent: Created child process 2692
[Sat Apr 19 22:09:11.325225 2014] [ssl:warn] [pid 2692:tid 272] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Apr 19 22:09:11.687246 2014] [ssl:warn] [pid 2692:tid 272] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Apr 19 22:09:11.734249 2014] [mpm_winnt:notice] [pid 2692:tid 272] AH00354: Child: Starting 150 worker threads.
[Sat Apr 19 22:14:57.151005 2014] [ssl:warn] [pid 5348:tid 260] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Apr 19 22:14:57.207008 2014] [core:warn] [pid 5348:tid 260] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Apr 19 22:14:57.461023 2014] [ssl:warn] [pid 5348:tid 260] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Apr 19 22:14:57.514026 2014] [mpm_winnt:notice] [pid 5348:tid 260] AH00455: Apache/2.4.9 (Win32) OpenSSL/0.9.8y PHP/5.4.27 configured -- resuming normal operations
[Sat Apr 19 22:14:57.514026 2014] [mpm_winnt:notice] [pid 5348:tid 260] AH00456: Apache Lounge VC10 Server built: Mar 17 2014 11:15:11
[Sat Apr 19 22:14:57.514026 2014] [core:notice] [pid 5348:tid 260] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sat Apr 19 22:14:57.517026 2014] [mpm_winnt:notice] [pid 5348:tid 260] AH00418: Parent: Created child process 2356
[Sat Apr 19 22:14:58.340073 2014] [ssl:warn] [pid 2356:tid 272] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Apr 19 22:14:58.659092 2014] [ssl:warn] [pid 2356:tid 272] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sat Apr 19 22:14:58.717095 2014] [mpm_winnt:notice] [pid 2356:tid 272] AH00354: Child: Starting 150 worker threads.
Other things which I've tried:

In the httpd.conf file I have changed the 'Listen 80' to 'Listen 1337' (Skype is also turned off) but it doesn't resolve anything.

I have also looked at the Documentroot and it seems fine:

DocumentRoot "C:/xampp/htdocs"
<Directory "C:/xampp/htdocs">
I've tried:

DocumentRoot "C:\xampp\htdocs"
<Directory "C:\xampp\htdocs">
But the same problem.

I'm new to using XAMPP and configuring it so any help is much appreciated.

Thank you in advance.
f0xx
 
Posts: 3
Joined: 19. April 2014 22:56
Operating System: Windows 7 Professional

Re: XAMPP - Object not found! on any files/directories

Postby Altrea » 19. April 2014 23:29

Hi,

Which editor do you use to create the files?

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: XAMPP - Object not found! on any files/directories

Postby f0xx » 19. April 2014 23:54

Hi Altrea,

Thank you for your reply. I have been creating blank documents (right click then create text document), then manually changing the file extension to .php.
I have also tried moving a PHP file from one of my live hosted websites which do work on my online hosting from FTP.

Both are still giving the 'Object not found!' error.

Kind regards,

James.
f0xx
 
Posts: 3
Joined: 19. April 2014 22:56
Operating System: Windows 7 Professional

Re: XAMPP - Object not found! on any files/directories

Postby f0xx » 20. April 2014 01:09

Hi,

I forgot to mention, when editing the files I put a simple 'Hello World' script which I edited using Notepad++

Thanks,

James.
f0xx
 
Posts: 3
Joined: 19. April 2014 22:56
Operating System: Windows 7 Professional

Re: XAMPP - Object not found! on any files/directories

Postby Altrea » 20. April 2014 11:49

Hi,

Then we need the contents of your apache access.log for further information.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 77 guests