How to change default domain name for Apache Admin button

Problems with the Windows version of XAMPP, questions, comments, and anything related.

How to change default domain name for Apache Admin button

Postby Curious Carl » 18. April 2014 01:05

THIS IS THE PROBLEM I AM HAVING:
The URL for the browser address bar (after clicking the Admin button) begins with http://localhost/...

I want the URL to begin with http://localhost:2375/... (note the additional port number)


SOME BACKGROUND:
My PC is Windows Vista Home Premium SP2.

I recently (April 2014) installed XAMPP 1.8.3. With that install came Apache 2.4.7 and PHP 5.5.9. I upgraded phpMyAdmin to 4.1.13 and set the root password (after much researching). The XAMPP Control Panel is version 3.2.1.

I have searched the internet and have read at least 25 articles in the Apache Forum and trying to find a solution to this situation. I have searched the Apache Friends Support Forum for "Apache Admin button" and found 25 hits. I searched for "Admin button" and found 273 hits. In all of those hits, none of them addressed my particular problem.

I have read the Apache Documentation in several places (including Access Control, Mapping URLs to the Filesystem, Microsoft Windows, URL Rewriting Guide, Configuration Files, and Filters). I did not see any discussion about the situation I'm experiencing.

I have also read much in the XAMPP splash screen (http://localhost:2375/xampp) without finding anything helpful for this problem.



THE ACTION:
When I installed XAMPP, I discovered I had to change the port that Apache listens on from 80 to 2375. 2375 was my choice. Apparently IIS or something else uses port 80. (I changed Skype to not consider port 80.)

I searched Bing and Google and read many of the files in the XAMPP folders and finally was able to change the port in C:\xampp\apache\conf\httpd.txt by changing Listen 2375. I did not change anything else in the text file.

With that change, I can start Apache via the XAMPP Control Panel and then open a browser (Firefox) and type an address like http://localhost:2375/wxyz.html and the wxyz document appears. I am okay with having to type the port number. So that part works well.


THE EXACT PROBLEM:
But when I click the Admin button on the XAMPP Control Panel, the browser opens, and the address begins as http://localhost/
An error (404) occurs. [Obviously, the Control Panel does not know that I changed the port that Apache listens on.]


INFORMATION I DESIRE:
What I am wanting to accomplish is to learn the file name (if the solution is that simple) that I can edit with a change to the localhost (or to 127.0.0.1) so that pressing the Admin button results in the address bar beginning with http://localhost:2375/.


COMMENTS:
Any help anyone can give me will be greatly appreciated.

Note - I would like to be able to have full use of the Control Panel, but not having full use is not a deal breaker.

Thank you very much for your time regardless of the outcome.

Curious Carl
Curious Carl
 
Posts: 2
Joined: 18. April 2014 00:38
Operating System: Windows Vista Home Premium

Re: How to change default domain name for Apache Admin butto

Postby JJ_Tagy » 18. April 2014 01:23

First, it is better to figure out what program is using port 80 and change that. However, if you still insist on using alternate port: What happens in the control panel if you click the "Config" button and then "Service and Port Settings" button on the new window?
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: How to change default domain name for Apache Admin butto

Postby Curious Carl » 28. April 2014 15:29

To answer your question about what happens when I change the value of the Main Port in the Service Setting box, "It works!".

I opened the XAMPP Control Panel and started Apache and then clicked the Config button on the top right side of the panel. The Configuration of Control Panel window opened. I clicked the Services and Port Settings button. When the Service Settings windows opened, I changed the Main Port value of 80 to my desired value of 2375. I did all of this as you indicated. After saving the changes, I could click the Admin button and get the Welcome to XAMPP for Windows! screen. Problem solved.

For mySQL, clicking its Admin button took me to the Welcome to phpMyAdmin login screen. That problem solved too.

Thank you so much for solving my problems JJ_Tagy. You obvously have experience with the software.

Thanks again.

Curious Carl
Curious Carl
 
Posts: 2
Joined: 18. April 2014 00:38
Operating System: Windows Vista Home Premium


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests