Upload Max Filesize

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Upload Max Filesize

Postby superdoc » 11. April 2014 19:12

Good afternoon. I am not a programmer but I am in healthcare. I put my Wordpress live site on to a test localhost using Xampp. Everything works great except one thing. Max file size uploads are set by default to 2M, post max size to 4M. Numerous plugins are larger than that so I went into the xampp php.ini ie the settings one not the dev or prod version. I changed the max upload to 20M and post max size to 30M, saved, reset the xampp control panel and went into the admin of my local site. STILL, could not upload because of the so called 2M was hit on php.ini. Meaning, it was not reading what I had changed on the php.ini in xampp. Any help? To get around it, I unzipped the plugin folder and manually put it into the wp/content/plugins under htdoc. It worked but would like to do it the regular way. Thanks a lot!

Mark
superdoc
 
Posts: 1
Joined: 11. April 2014 19:00
Operating System: windows

Re: Upload Max Filesize

Postby JJ_Tagy » 11. April 2014 20:14

php.ini changes aren't affected by the control panel. Instead, stop and restart Apache.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: Upload Max Filesize

Postby Altrea » 12. April 2014 10:53

superdoc wrote:I went into the xampp php.ini ie the settings one not the dev or prod version. I changed the max upload to 20M and post max size to 30M, saved

Be sure you changed the correct true setting. There are many comments in the php.ini which only show you how to use these settings. Doing any change in the comments will not have any effect.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8297
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Upload Max Filesize

Postby hwalker1 » 28. March 2015 20:44

JJ_Tagy wrote:php.ini changes aren't affected by the control panel. Instead, stop and restart Apache.

I wish that this had been seen by me earlier today. It would have saved me 8 hours of head scratching.
Best post on the forum. Thanks. :D
hwalker1
 
Posts: 29
Joined: 10. November 2010 11:59
Location: United Kingdom
Operating System: Windows 7 Ultimate 64 bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests