New PHP5 XML Features are not available?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

New PHP5 XML Features are not available?

Postby netzilla » 07. August 2004 09:48

Hi, experts,

i am tring to use those new PHP5 XML functionalities with XAMPP, but i met a lot of problems:

i use examples from
1. http://www.zend.com/php5/articles/php5-xmlphp.php
2.http://php5.bitflux.org/phpconf2004/title.php

Even some simple example codes can not excutes

1. DOM
method call to childNodes will cause the apache crash

2. XMLReader
this is the most exsting one i am looking for , but
i got :
Fatal error: Class 'XMLReader' not found in C:\apachefriends\xampp\htdocs\xml\xmlreader.php on line 3

3.SAX
SAX is working fine, but it's the legacy technology, i dont want to use it

i took a look at the php.ini and php5.ini stored under the php folder in the home dir of XAMPP, found out that the ext of XMLReader,DOM are not active, then i modify those ini files,restart the XAMPP, the error still there, seems that this does not help.

could you please help me to solve this? i am eager to use those xml features.

any help are highly appriciated.

best regards.
netz
netzilla
 
Posts: 1
Joined: 07. August 2004 09:36

Postby Bugman » 07. August 2004 23:17

WHy not download apache 2 and copy over its version of XML folder and see what happens then?

Bugman
Bugman
 
Posts: 53
Joined: 13. July 2004 23:39

Postby Feli » 15. August 2004 23:28

Dear Netzilla

re. Fatal error: Class 'XMLReader' not found in C:\apachefriends\xampp\htdocs\xml\xmlreader.php on line 3:

I had the same problem on my Windows XP PC with PHP5 and xmlreader and could solve it with the following steps:
1. Install XAMPP with default settings and in default directories

2. The PHP files php.exe and php.ini are in two directories:
- c:/apachefriends/xampp/php
- c:/apachefriends/xampp/apache/bin
Rename them in the php directory so you are sure that they run from the apache/bin directory.

3. In php.ini (in the apache/bin directory), activate the
extension=php_xmlreader.dll
by removing the semicolon in front of it.

4. Start Apache, xmlreader should run now.

5. To run PHP5 with xmlreader in the DOS-box in command line mode,
add a path entry
c:>path=%path%;c:\apachefriends\xampp\apache\bin

This should do the trick, try now
c:>php -i
on my PC it shows "XMLReader => enabled"

Good Luck...Feli
Feli
 
Posts: 1
Joined: 15. August 2004 23:12


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests