Apache will not start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache will not start

Postby shotsky » 19. March 2014 14:17

Xampp with Apache has been running fine, but this morning it will not start:
06:10:34 [main] Initializing Control Panel
06:10:34 [main] Windows Version: Windows 7 Ultimate SP1 64-bit
06:10:34 [main] XAMPP Version: 1.8.3
06:10:34 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
06:10:34 [main] Running with Administrator rights - good!
06:10:34 [main] XAMPP Installation Directory: "d:\xampp\"
06:10:34 [main] Checking for prerequisites
06:10:36 [main] All prerequisites found
06:10:36 [main] Initializing Modules
06:10:36 [main] The Mercury module is disabled
06:10:36 [main] The Tomcat module is disabled
06:10:36 [main] Enabling autostart for module "Apache"
06:10:36 [main] Enabling autostart for module "MySQL"
06:10:36 [main] Enabling autostart for module "FileZilla"
06:10:36 [main] Starting Check-Timer
06:10:36 [main] Control Panel Ready
06:10:36 [Apache] Autostart active: starting...
06:10:36 [Apache] Attempting to start Apache app...
06:10:37 [mysql] Autostart active: starting...
06:10:37 [mysql] Attempting to start MySQL app...
06:10:38 [filezilla] Autostart active: starting...
06:10:38 [filezilla] Attempting to start FileZilla app...
06:10:39 [mysql] Status change detected: running
06:10:39 [filezilla] Status change detected: running
06:10:47 [Apache] Attempting to start Apache app...
06:10:47 [Apache] Status change detected: running
06:10:48 [Apache] Status change detected: stopped
06:10:48 [Apache] Error: Apache shutdown unexpectedly.
06:10:48 [Apache] This may be due to a blocked port, missing dependencies,
06:10:48 [Apache] improper privileges, a crash, or a shutdown by another method.
06:10:48 [Apache] Press the Logs button to view error logs and check
06:10:48 [Apache] the Windows Event Viewer for more clues
06:10:48 [Apache] If you need more help, copy and post this
06:10:48 [Apache] entire log window on the forums

I did not install anything new, no system/firewall/router changes, no port changes - it even ran for a short while today, then after I stopped it, it would no longer start. I have rebooted multiple times, looked in my router configs, etc. and see nothing that has changed. My apache log file is blank, so it is not writing an error.
Any help would be appreciated.
John
shotsky
 
Posts: 3
Joined: 05. March 2014 14:54
Operating System: win7-64

Re: Apache will not start

Postby gsmith » 20. March 2014 08:21

Have a look in the Event Viewer in Windows, if it doesn't land in the log (errors before log is opened) it should land in the event viewer.
gsmith
 
Posts: 196
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP version: 0.0.0
Operating System: Win XP to 2012R2/VS 6,9,11,14

Re: Apache will not start

Postby shotsky » 20. March 2014 12:38

Thanks. I did find the problem: I had been adding a new directory callout in the config file, then commented it out to finish later. Unfortunately, I commented out the closing tag of the previous directory. Hard to find, but eventually did find it.
shotsky
 
Posts: 3
Joined: 05. March 2014 14:54
Operating System: win7-64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests