Apache/XAMPP error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache/XAMPP error

Postby alouayed » 11. March 2014 04:59

Hi there,

I am new to XAMPP and all its features. I am trying to get familiarized with MySQL by a tutorial which recommended to download and install XAMPP. The recommendation was to turn UAC so I did, but I got an error like this:
10:50:48 PM [main] Initializing Control Panel
10:50:48 PM [main] Windows Version: Windows 8 64-bit
10:50:48 PM [main] XAMPP Version: 1.8.3
10:50:48 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
10:50:48 PM [main] You are not running with administrator rights! This will work for
10:50:48 PM [main] most application stuff but whenever you do something with services
10:50:48 PM [main] there will be a security dialogue or things will break! So think
10:50:48 PM [main] about running this application with administrator rights!
10:50:48 PM [main] XAMPP Installation Directory: "c:\xampp\"
10:50:48 PM [main] Checking for prerequisites
10:50:48 PM [main] All prerequisites found
10:50:48 PM [main] Initializing Modules
10:50:48 PM [Apache] Problem detected!
10:50:48 PM [Apache] Port 80 in use by "C:\Program Files (x86)\Skype\Phone\Skype.exe" with PID 6664!
10:50:48 PM [Apache] Apache WILL NOT start without the configured ports free!
10:50:48 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
10:50:48 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
10:50:48 PM [Apache] Problem detected!
10:50:48 PM [Apache] Port 443 in use by "C:\Program Files (x86)\Skype\Phone\Skype.exe" with PID 6664!
10:50:48 PM [Apache] Apache WILL NOT start without the configured ports free!
10:50:48 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
10:50:48 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
10:50:48 PM [mysql] XAMPP MySQL is already running on port 3306
10:50:48 PM [main] Starting Check-Timer
10:50:48 PM [main] Control Panel Ready
10:51:06 PM [mysql] Attempting to stop MySQL (PID: 9184)
10:51:07 PM [mysql] Status change detected: stopped
11:04:09 PM [Apache] Attempting to start Apache app...
11:04:09 PM [Apache] Status change detected: running
11:04:15 PM [Apache] Status change detected: stopped
11:04:15 PM [Apache] Error: Apache shutdown unexpectedly.
11:04:15 PM [Apache] This may be due to a blocked port, missing dependencies,
11:04:15 PM [Apache] improper privileges, a crash, or a shutdown by another method.
11:04:15 PM [Apache] Press the Logs button to view error logs and check
11:04:15 PM [Apache] the Windows Event Viewer for more clues
11:04:15 PM [Apache] If you need more help, copy and post this
11:04:15 PM [Apache] entire log window on the forums

I turned off the UAC but it showed that I still need some admin rights. Even I changed the ports in the XAMPP control panel for Apache from 80 to 29221 and from 443 to 29222 after I checked the ports availabilities with "netstat -a" in CMD but still having that error. When I press the log button in XAMPP beside apache, it give me a blank document. When I check the event viewer in windows, it doesn't show the new errors or specifically the errors about this crash. I even allowed apache in windows firewall but it doesn't do anything.

Could you help me with that? And could you let me know on how to get more info and tutorials about these programs?

Thank you.
alouayed
 
Posts: 2
Joined: 11. March 2014 04:32
Operating System: windows 8.1 64BIT

Re: Apache/XAMPP error

Postby Nobbie » 11. March 2014 20:36

alouayed wrote:And could you let me know on how to get more info and tutorials about these programs?


Which programs do you mean by "these programs"?

I am not sure if a tutorial fits to your needs, as you have big troubles already by reading simple error messages. Even if the Control Dialog tells you very exactly and precisely what is going wrong, you do not take any action against it, as if you do not see this error message (which appears as well for port 80 and port 443). Why?
Nobbie
 
Posts: 8759
Joined: 09. March 2008 13:04

Re: Apache/XAMPP error

Postby gsmith » 12. March 2014 19:27

A bit condescending today are we Nobbie? Instead of wasting your time with that, why not just save everyone some time and point out what to you is blatantly obvious but to a new person it might not be so obvious?

alouayed, the clues are in these lines;

10:50:48 PM [Apache] Port 80 in use by "C:\Program Files (x86)\Skype\Phone\Skype.exe" with PID 6664!
10:50:48 PM [Apache] Apache WILL NOT start without the configured ports free!
10:50:48 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
10:50:48 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
10:50:48 PM [Apache] Problem detected!
10:50:48 PM [Apache] Port 443 in use by "C:\Program Files (x86)\Skype\Phone\Skype.exe" with PID 6664!
10:50:48 PM [Apache] Apache WILL NOT start without the configured ports free!

Skype is getting in the way. Either turn it off or change the ports it uses.

Man that was just so difficult to do Nobbie. Maybe you need to take a break from the board for awhile.
gsmith
 
Posts: 194
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP version: 0.0.0
Operating System: Win XP to 2012R2/VS 6,9,11,14

Re: Apache/XAMPP error

Postby alouayed » 13. March 2014 05:29

Thank you "gsmith", yet I'm new but such errors I can read very well and I mentioned that I changed both the ports but still have the error. I know that Skype is in the way but I didn't want to turn Skype off as it might take more time, in windows 8, than changing the ports.
alouayed
 
Posts: 2
Joined: 11. March 2014 04:32
Operating System: windows 8.1 64BIT

Re: Apache/XAMPP error

Postby Nobbie » 13. March 2014 11:01

gsmith wrote:A bit condescending today are we Nobbie?


Youre post counter is on 12. When mine was on 12, i was very calm. But if you gonna answer thousands(!) of times exactly the same question and in most cases, people simply do not read the errors (what is the idea of error messages, if Users dont read them??), you will get "condescending". Surely! Dont say "no", simply wait. And first of all, answer to more than 5.000 problems (12 is quite less) and then we talk to each other again, ok?! Thx in advance.

gsmith wrote:Maybe you need to take a break from the board for awhile.


Seems so. Will you take over for the next 5.000 problems? Thx again.
Last edited by Nobbie on 13. March 2014 11:27, edited 1 time in total.
Nobbie
 
Posts: 8759
Joined: 09. March 2008 13:04

Re: Apache/XAMPP error

Postby Nobbie » 13. March 2014 11:05

alouayed wrote:I mentioned that I changed both the ports but still have the error. I know that Skype is in the way but I didn't want to turn Skype off as it might take more time, in windows 8, than changing the ports.


Where did you change "both the ports" (in Skype or in Apache, and how did you do that?) and what happens after?

P.S.: If you changed the ports in the Xampp Control Dialog only, this is not working (and its the wrong action):

a) it does not have any effect on Apache, because Apache is not "configured" by the Dialog Box, but by httpd.conf file in c:/xampp/apache/conf. There is a LISTEN option, which defines the Port, on which Apache "listens" (omen est nomen).

b) anyway, it is wrong to change Apache (and it is not that, what is suggested by the error message). You must change Skype instead and leave Apache as it is. Port 80 and 443 are the standard TCPIP Ports for the http and the https protocoll and should be used for Webservers exclusively. Skype does it wrong and uses the same ports per default. You *should* change this in the Skype Options Menu.

If you change Apache instead, you have to specify the Portnumber in all URLs later on (like http://localhost:29221/mysite/index.html and https://localhost:29222/mysavesite/index.php) what is quite ugly and leads to many problems for many scripts.
Nobbie
 
Posts: 8759
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests