libmysql_.dll missing when accessing mysql with perl

Problems with the Windows version of XAMPP, questions, comments, and anything related.

libmysql_.dll missing when accessing mysql with perl

Postby Perl_Man » 28. February 2014 06:09

I have no problem accessing mysql with php but keep getting the missing libmysql_.dll when I try to access mysql using perl. I have no problem accessing Apache from my FF browser when using perl script. I can run any perl script in my browser ok except when trying to access mysql. I started out with xampp 1.8.2 for windows on my windows 7 and had the problem. So after I tried copying libmysql.dll (from xampp/mysql/lib...there are a number of the similar .dll files there but none with an underscore) to various locations and even renaming it to libmysql_.dll and even libmysql__.dll (that's two underscores) at one time (when I copied it to xamp/perl/bin) I managed to get past the missing libmysql_.dll problem but got a "The procedure entry point mysql_get_parameters could not be located in the dynamic link library libmysql_.dll". I tried installing strawberry perl and copied the (strawberry) libmysql__.dll (two underscores...and renamed it to libmysql_.dll (one underscore) but that didn't work either. I have since uninstalled strawberry perl and xampp 1.8.2 and installed xampp 1.8.3 but I have the same problem. It doesn't matter what cgi-bin script I use when trying to connect with mysql...they all give the same missing libmysql_.dll error. I wanted to try xampp 1.8.1 (someone had mentioned it worked for him) but I couldn't find a download for that older version.
Posts: 2
Joined: 28. February 2014 05:38
Operating System: windows 7

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 91 guests