[BUGS] XAMPP 1.8.3-3 & 1.8.2-4 issues

Problems with the Windows version of XAMPP, questions, comments, and anything related.

[BUGS] XAMPP 1.8.3-3 & 1.8.2-4 issues

Postby Altrea » 18. February 2014 20:17

In this thread we collect all information about issues with XAMPP for Windows 1.8.3-3 & 1.8.2-4
To report a bug simply create a new forum thread

XAMPP 1.8.3-3

confirmed

    acknowledged


      XAMPP 1.8.2-4

      confirmed

        acknowledged
          We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

          It's like porn for programmers 8)
          User avatar
          Altrea
          AF Moderator
           
          Posts: 6829
          Joined: 17. August 2009 13:05
          XAMPP Version: 5.5.19
          Operating System: Windows 10 Pro x64

          Errors and fixes in the "php.ini" file distributed w/ xampp

          Postby CristianDeluxe » 18. March 2014 04:25

          I did not know where to put this, if this is not the right place, moderator please move it to the right place.

          The file "php.ini" that comes by default with xampp has the following errors and/or fixes:

          Code: Select all
          [PHP]
          ...
          ; line 240
          y2k_compliance=On
          ...
          ; line 336
          allow_call_time_pass_reference
          ...
          ; line 340 to 370
          safe_mode=Off
          safe_mode_gid=Off
          safe_mode_include_dir=   
          safe_mode_exec_dir=   
          safe_mode_allowed_env_vars=PHP_
          safe_mode_protected_env_vars=LD_LIBRARY_PATH
          ; line 722
          register_globals=Off
          ; line 732
          register_long_arrays=Off
          ; line 786 to 794
          magic_quotes_gpc=Off
          magic_quotes_runtime=Off
          magic_quotes_sybase=Off
          ...
          [Session]
          ...
          ;line 1625
          session.bug_compat_42=On
          ;line 1634
          session.bug_compat_warn=On
          ...


          All these variables have been removed as of version PHP 5.4.0.

          More info:
          http://es1.php.net/ini.core
          http://www.php.net/manual/en/features.safe-mode.php

          Code: Select all
          [PHP]
          ...
          ; line 322
          serialize_precision=100
          ...


          serialize_precision must be set to 17 as it's the new PHP default value since version 5.3.5.

          More info:
          http://www.serverphorums.com/read.php?7,270282,270282
          http://www.php.net/manual/en/ini.list.php

          Code: Select all
          [Session]
          ...
          ; line 1542
          session.use_only_cookies=0
          ...


          session.use_only_cookies must be set to 1 as it's the new PHP default value since version 5.3.0.

          More Info:
          http://es1.php.net/session.configuration

          session.use_only_cookies specifies whether the module will only use cookies to store the session id on the client side. Enabling this setting prevents attacks involved passing session ids in URLs. This setting was added in PHP 4.3.0. Defaults to 1 (enabled) since PHP 5.3.0.

          http://es1.php.net/manual/en/session.configuration.php#ini.session.use-only-cookies


          Code: Select all
          [MSSQL]
          ...
          ; line 1774
          mssql.compatability_mode=Off
          ...


          This is a typo error in the variable name, the correct string is: mssql.compatibility_mode

          Code: Select all
          ...
          ; line 1420
          [PostgresSQL]
          ...


          This is a typo error in the group name, the correct string is: PostgreSQL

          Sorry for my bad English, I hope these "fixes" can be solved for upcoming versions.
          CristianDeluxe
           
          Posts: 1
          Joined: 04. October 2009 13:09


          Return to XAMPP for Windows

          Who is online

          Users browsing this forum: No registered users and 31 guests